Error warning - You must specify a tax agency for the tax account.

Turtle CharlesTurtle Charles Member Posts: 4
edited April 19 in Accounts Business Range
I try recording a payment using the Pay Tax and I get a message about having to specify a tax agency for the tax account. There is already a tax agency set up by previous bookkeeper. The problem has been in the past records were made using the 'write cheque' process but the GST liability accounts were not clearing and instead the amounts kept rising. I read the manual which states to use the Pay Tax process to writ tax cheques or this is what will happen - liability amounts increase instead of reduce on payment. When I try using the Pay Tax process Get this error message. Tried everything I know of to eradicate. Any help appreciated. Cheers.

Comments

  • DebonAirDebonAir Member Posts: 412
    edited May 2017
    You can check that the Aust Tax Office (Supplier) is actually set up in the Preferences.
    Go to Preferences, Tax and check that the correct ATO (some accounts have several) and then try again.

  • RobynRobyn Member Posts: 24
    edited April 19

    Hi Turtle, we had a  similar problem even though the supplier was set up correctly as a tax agency.

    What I noticed was that it would accept a "Pay Tax"  PAYG liability or GST payment cheque but not any other sort of liability cheque so... what I now do is process a liability cheque that Reckon will accept (you might find that it will accept PAYG payments without any error messages), save it and then go back to it and edit it for the correct liability account that you need the payment to come from (and for the correct amount.)

    Sound messy but it's the only way I've worked out to pay other company taxes without that error message appearing.

  • Turtle CharlesTurtle Charles Member Posts: 4
    edited March 2017
    Thanks DebonAir. It is set up in preferences and I even set up some dummy ones to check if there were any errors with these. It all got a bit messy but a long story short - For some reason I have to alternate the tax account in the account window of the Pay Tax cheque details before the customer job box showed the Tax Agency in the box at end of line/s. After this alternating and then finally setting the GST paid (which was the one giving me the trouble by looks) it appears to process the cheque with no error blocking the process. I think a glitch in the Reckon software maybe. 
  • Turtle CharlesTurtle Charles Member Posts: 4
    edited March 2017
    Thanks, Robyn. I replied to post above DebonAir about what I had found after much searching. Not sure why this is happening but it may be a glitch in the software I have got installed. If I click the account GST Paid first up then I can still place the rest of the details in the 'write cheque' but cannot  process past that error. But, if I click on another liability a/c first and then swap it back to GST paid, all seems t work.
  • DebonAirDebonAir Member Posts: 412
    edited March 2017
    I did have this problem  in the past, and it was a duplication error when importing files to start a new file. I found I had to import the lists without the ATO or Tax codes and just use them when the new file was created.

  • Turtle CharlesTurtle Charles Member Posts: 4
    edited March 2017
    Okay. I have not imported any files and only using the ones already set up. After I figured the workaround by just clicking on another a/c first in the selection box of the Pay Tax write cheque and then clicking on the GST Paid a/c which is giving me the trouble it appears, I can get the info entered and cheque written (recorded. But, I have noticed the GST paid & collected amounts are not decreasing once the cheque is written and it acts like if writing the cheque if paying off an expense. Not sure what is happening there yet. I am writing the cheques thru the Pay Tax channel.
  • TraceyTracey Member Posts: 1
    edited April 2019

    Thank you, I was struggling with the same issue and changing the account and then back again solved the problem.
Sign In or Register to comment.