Reckon one API: invalid_client

Stream LendingStream Lending Member Posts: 3
edited February 2019 in Reckon One
I have followed the auth document step by step but I still get this error.

The first step is all good. I can get the code from the response
But when trying to get the access_token, I always received 'invalid_client'

Here are the request details:

It's a local env with client id and secret. The callback url is: http://localhost

Client id is: 665df5df-0588-4ee8-8add-0a156576e8bc
Client secret: c12bbb8a-2443-4acb-96ec-83aa22fc421f
HttpType: POST
URL: https://identity.reckon.com/connect/token
Header: 
{'Content-Type': 'application/x-www-form-urlencoded', 'Authorization': 'Basic NjY1ZGY1ZGYtMDU4OC00ZWU4LThhZGQtMGExNTY1NzZlOGJjOmMxMmJiYjhhLTI0NDMtNGFjYi05NmVjLTgzYWEyMmZjNDIxZg=='}

Body:
{'code': '9aff562a59207c6cc2fb21b24875b252',
'redirect_uri': 'http://localhost', 'grant_type': 'authorization_code'}
 

Response:
<Response [400]>  400  
{"error":"invalid_client"} Please help me with this issue ASAP. We have been stuck by this problem for ages.

Comments

  • PhuongDoPhuongDo Reckon Developer Partner Posts: 196 ✭✭
    edited August 2018
    Hi there,

    Based on what I know, it could be the callback URL you registered with this client id is not localhost, but it could be something else as well.
    You should contact [email protected] so they can see what is the real issue. 

    Thanks,

    Phuong


    Phuong Do / Reckon Developer Partner

    [email protected]

  • Le HuynhLe Huynh Member Posts: 1
    edited February 2019
    is there any update on this subject?. I had exact same issue
  • Stream LendingStream Lending Member Posts: 3
    edited July 2018
    nop. Reckon support told me that my token is valid. But I still got invalid_client...and I don't know how to fix it from my side and what to do next. I used the postman as they said with exact the same input but still no good news. This process took me 2 weeks and no result. So we have to put a delay on the integration of Reckon...  If you have any solution, please let me know thx
  • IftiIfti Reckon Staff Posts: 457 ✭✭
    edited July 2018
    HI there,

    As per your recent email, creating new profile seems to have fixed this issue.

    Please let us know if you still need any help.

    Thanks

    Ifti
Sign In or Register to comment.