Reckon One API - Invalid Client

JDMNetworksJDMNetworks Member Posts: 3
edited September 7 in Reckon One
When accessing the Reckon One API with PHP OAuth 2.0 client and/or PostMan, I am receiving an 'Invalid Client' response when attempting to retrieve my Access Token (after successfully retrieving an Authorization Code).

I have been trying to rouse any sort of response out of the API support team via email and they have been completely ignoring my emails for last 10 days - not a single word or response received from them.

Is there any support team at all, or is it time to migrate to a more capable accounts platform?


Comments

  • IftiIfti Reckon Staff Posts: 459 ✭✭
    edited February 2019
    Hi there,

    Thank you for your post.

    Can you please tell us where you emailed as we have responded to all other emails that were sent to us.

    You usually get this error if you followed implicit flow instead of the default Authorization flow.

    Can you please ensure that you're following this article? If it still fails, please pass us the payload that you're sending so that we can check it.

    Thanks

    Ifti
  • Jason HollisJason Hollis Reckon Staff Posts: 615 ✭✭
    edited September 7
    Hi JDM,

    I have checked our support logs and the last mail received by us was on May 28th 2018.

    Please ensure you use [email protected] as this is the support email. It would also be helpful to advise your support ticket ID and email you sent to so we can follow this up.

    Ifti will of course now help with your issue directly. 


    Kind regards,
    Jason
  • Ruth NewellRuth Newell Member Posts: 6
    edited August 2018
    Hi Jason,
    I read your answer to the client who wanted to change the name of their Reckon Hosted file, as I did, but I have changed it according to your instructions, but when I try to open in via the Q drive, and I select the newly named file, it syas that this Reckon Accounts could not use the path to the Company File (Error 6177).  I have tried to find Reckon in my computer programs, but I don't think I have ever downloaded it onto my computer, so I cannot locate it to find the Database Server Manager.  I access the file online for my employer, but do not work from his computer.  What can I do to access the file again please?
    Ruth Newell
    [email protected]l.com

  • JDMNetworksJDMNetworks Member Posts: 3
    edited September 7
    I never received any Support Ticket ID's - I have been sending all emails to [email protected]
    I have checked my server logs and every email I've sent successfully queued at the Office 365 SMTP servers - below is an example from my Exim logs for the most recent email I sent:

    2018-08-16 09:04:02 1fq6hh-0003Nk-DD => [email protected] R=dnslookup T=remote_smtp H=reckon-com.mail.protection.outlook.com [65.55.88.170] X=TLSv1.2:ECDHE-RSA-AES256-SHA384:256 CV=yes K C="250 2.6.0 <000d01d434fd$03c48cd0$0b4da670$@jdmnet.com.au> [InternalId=609885356459, Hostname=TY2PR06MB2830.apcprd06.prod.outlook.com] 85500 bytes in 0.561, 148.679 KB/sec Queued mail for delivery"
    2018-08-16 09:04:02 1fq6hh-0003Nk-DD Completed
    Sounds like there is some sort of problem on your end that is preventing my emails from being visible - my domain isn't on any blacklists that I am aware of.

    I have followed the Authorization Code flow as per the documentation - indeed, if I try to use PostMan as per the example in the documentation, I get the same "Invalid Client" error.
  • Jason HollisJason Hollis Reckon Staff Posts: 615 ✭✭
    edited August 2018
    Looks like your emails are being blocked for some reason as a successful email will return a support ticket. We definitely haven't been ignoring you for 10 days.

    Apologies all the same. Please let us know the email you are using by emailing (please ignore the irony) [email protected] attn: Jason Hollis and we'll do some more digging as you'll most likely need to use it again.

    As for the grant type, AUTHORIZATION CODE is the one we set by default and I have checked your account, and Authorization Code is the flow so you should be right.

    There are 3 common errors.

    1. The client ID is incorrect (we can't post that here, so you will need to email us - use another email if you have to with some proof of ID such as your redirect URI.

    2. You aren't using the correct response, scope or state types.

    response_type=code
    scope=openid+read+write+offline_access
    state=random_state&nonce=random_nonce

    3. The client ID has become corrupted. This can happen from time to time. 

    I am thinking it's 1 or 3. If 3, we'll just set you up a new one. 


    Regards,
    Jason
  • RavRav Administrator Posts: 9,799 Administrator
    edited August 2018
    Creating seperate thread Please reference the new conversation here: I have changed the file name as per instructions but cannot access my file again ...
  • Jason HollisJason Hollis Reckon Staff Posts: 615 ✭✭
    edited August 2018
    I have updated your credentials now Jacob. You should get them soon. We will also take a look at why your email is not getting to us, as it has done so in the past (as you know). Thanks for sending through the info.

    Jason
  • Jason HollisJason Hollis Reckon Staff Posts: 615 ✭✭
    edited August 2018
    Jacob I can confirm you are not blacklisted at our end. Please try to send a simple TEST using the effected email and also a gmail account which will help us identify the issue. Thanks again, Jason
  • JDMNetworksJDMNetworks Member Posts: 3
    edited August 2018
    Email is sorted, looks to have been an issue with Office 365 inbound that has since cleared up. 
Sign In or Register to comment.