STP Error

Paul MasonPaul Mason Member Posts: 56
edited September 2 in Accounts Hosted
Ive just started using a new Comany file and now I have this error

ATO Messages


The following error messages have been returned from the ATO and need to be reviewed. You may need to make changes in your accounting product before submitting again.


Error message
The element 'AddressDetailsPostal' in namespace 'http://www.sbr.gov.au/ato/payevnt' has invalid child element 'CountryC' in namespace 'http://www.sbr.gov.au/ato/payevnt'. List of possible elements expected: 'Line1T' in namespace 'http://www.sbr.gov.au/ato/payevnt'. Hint: while processing parent element [AddressDetailsPostal] child mandatory element [Line1T] was expected but not found

Comments

  • Kris_WilliamsKris_Williams Member Posts: 1,184 ✭✭✭
    edited August 16
    You need to check the details in the company info, name address etc. looks like the country is an issue to begin with, also postal address
  • Paul MasonPaul Mason Member Posts: 56
    edited August 16
    I just lodged last weeks STP & just checked it all Ok, No errors and I had made no changes to our company info page ?
    all looks ok and all fields are completed
    as most of my employees are casual, they do not all appear on each pay run, I have also check all their address fields and all looks ok, Just no Country field box in employee 

  • Kris_WilliamsKris_Williams Member Posts: 1,184 ✭✭✭
    edited August 16
    The only country field that I can see is under company info
  • RavRav Administrator Posts: 10,895 Administrator
    edited August 16
    Hi Paul,
    There are some details for this particular error message (and others) in this help guide -
    HELP GUIDE: Common ATO STP Errors in Reckon GovConnect

    Are there any new employees in this submission that weren't in previous?
  • Paul MasonPaul Mason Member Posts: 56
    edited August 17
    Thanks Kris & Rav
    Using the thoughts below, Ive re lodged it again just to see if it does work this time ......Pending

    If you had successful submissions before this, is there a new employee(s) compared to other submissions? If so, check their address. If nothing is different from the last successful lodgement, simply try submitting again as normal. The ATO sometimes returns this error when they have problems processing on their end.



  • Paul MasonPaul Mason Member Posts: 56
    edited September 2
    lt worked when I re submitted it (no changes) just simply re submitted
  • Kris_WilliamsKris_Williams Member Posts: 1,184 ✭✭✭
    edited September 2
    Glad it worked for you, good to keep in mind for submissions that don’t go through
Sign In or Register to comment.