STP app login loop problem

pshevpshev Member Posts: 10

Been using the STP app for a year with no problems

Now trying to login ask for ABN = 41204219806, select company, says company is already registered, goes back to login page, login again, goes back to select company/abn and keeps going in a loop

Tried deleting app and reinstalling, no difference

Any help appreciated please

Comments

  • RavRav Administrator Posts: 9,785 Administrator

    Hi @pshev

    It sounds like you've logged into a brand new account on the app because its asking you to register the ABN again.

    Can you confirm if you are using the same email address & password to login that were used when the STP app account was first created?

  • pshevpshev Member Posts: 10

    Hi Rav,

    Yes i'm am using the same email and password when originally created - email: [email protected]

  • RavRav Administrator Posts: 9,785 Administrator

    Thanks @pshev

    I've just had a look and it looks like there was an error in registration. I've just cleared that out now so hopefully that re-enables access to your STP app account but can you give it a go when you have a chance.

    Let me know if you still have any trouble.

    Cheers

  • pshevpshev Member Posts: 10

    Thanks Rav

    I have just tried but still doing the same thing going in circles

  • RavRav Administrator Posts: 9,785 Administrator

    Thanks for getting back to me @pshev

    Ok, are you using the Android or iOS version of the app?

    If its Android, can you please try the following steps -

    • Close the STP app in full ie. swipe it away from your running apps
    • Go into your Phone Settings; Settings ➡️ Apps ➡️ Reckon STP ➡️ Storage ➡️ Clear Data
    • Go to into your app store and check you have the latest update of the STP app installed ie. just check if you have any updates available to you. If there are, please download & install
    • Open the STP app and login

    Let me know if you still experience the same thing after the above steps.

  • pshevpshev Member Posts: 10

    Thanks Rav

    using iOS (iphone8) app v1.13.5

  • RavRav Administrator Posts: 9,785 Administrator

    Ok cool thanks for that.

    Hmmm I know you've already mentioned you are, but just triple checking, are you 100% certain you're logging into the STP app with the [email protected] email address? ie. no chance of a typo being made in the email address when you logged in etc.

    When I look at the ABN and account in our system, it definitely shows up under that email address so realistically should be taking you in provided you're using the right credentials, which sounds like you are.

  • pshevpshev Member Posts: 10

    Thanks Rav

    Have triple checked spelling and definitely right email

    This is a strange one, i've even tried my ipad, downloaded the STP app, entered my email password, no fifference

    Here is a step by step with screenshots with what i am doing, hope it helps


  • RavRav Administrator Posts: 9,785 Administrator
    edited November 12

    Thanks heaps @pshev, yes definitely strange one for me as well. Your screenshots show that your logging in with the right account credentials so it should be taking you straight in rather than asking you to register an ABN. I have made one small change on my end, although I'm not confident that its going to have any effect on the issue you're experiencing. Regardless though, can you give it another go and let me know.

    I've also sent through the details of what is happening here to our app devs this morning. Hopefully they can share some insight from the backend side of things that I can't see. I'll keep you posted on that.

  • pshevpshev Member Posts: 10

    Thanks Rav, still doing the same thing, no difference

  • RavRav Administrator Posts: 9,785 Administrator

    Hi @pshev

    I haven't forgot about your case but I know its been a while since my last update to you and I do apologise for that.

    While our dev team have been investigating, the cause of the problem has also proven to be a bit elusive so far. They have however completed some work this morning on a potential fix, and need you to do something specific which I'll outline below.

    • Go to portal.reckon.com
    • Sign in with your STP app account credentials
    • Let me know as soon as you've done this

    Apologies for the hassle but if you could perform the above when you have a moment and let me know that'll be great.

  • pshevpshev Member Posts: 10

    Thanks Rav,

    Done that not sure if you can read screenshot but says “Other account found. Please select which product portal you would like to open

    IPA Books+ “

  • RavRav Administrator Posts: 9,785 Administrator
    edited November 25

    Awesome thank you @pshev and yes the screenshot is great.

    Just one more favour if you could please.

    Sign out of that account and/or close that tab/browser.

    Head back to portal.reckon.com and this time click the Create Account option and use the exact same email address from your app account to sign up to the Reckon Portal. (Don't use the Sign in with Google or Office 365 options).

    If you could give me a screenshot again after this I'd really appreciate it


    Cheers

  • RavRav Administrator Posts: 9,785 Administrator

    Great stuff, thank you so much for doing all that and for the screenshots.

    Sit tight just for now, my dev is going to come back to me soon and complete their testing. I'll let you know as soon as I hear back from them.

  • RavRav Administrator Posts: 9,785 Administrator

    Hi again @pshev

    Ok, I've just heard back from the team and hopefully their fix will do the trick.

    Can you please close the STP app fully from your running apps (if its open in the background). Open it back up again after this and login as normal.

    Hopefully it gets you in but please let me know.

    Cheers

  • RavRav Administrator Posts: 9,785 Administrator

    Thanks for trying anyway @pshev, will need to take this back to our devs.

    In regard to that strange error from the first screenshot, I note that it came up on the 'Create Account' screen. Were you attempting to create an account just in error? (as opposed to logging in).

  • pshevpshev Member Posts: 10

    Thanks Rav

    No, just logging in

  • RavRav Administrator Posts: 9,785 Administrator

    @pshev

    I'm going to shoot through an email to you in a few minutes with some info on the next step/route we'd like to take. I'll send it through to the email address that is registered to your Community account.

Sign In or Register to comment.