Welcome to the brand new Reckon Community!

For some tips on getting started check out the 'About Reckon Community' section

Wont't let me restore backup, it says file is read-only

RebeccaRebecca Member Posts: 36
I work on two separate computers that are not linked in any way. 
I have a desktop computer, and a laptop.

I have Reckon Accounts Pro loaded on both computers.

when I have used Reckon Accounts, I save a back-up copy to a USB stick.
Then I go to my other computer and want to use my updated company file, so I open existing company file, and ask to restore from a back up.  I agree to replace the old company file on the computer, (as I only want the current version I've just worked on).

However Reckon Accounts comes up with the following error message: "The file is set to read-only.  Try again with a different file name."

If I change the file name, it restores, and I can use the current version, but then I have so many companies with different names from every time I use the other computer, its just silly.  I don't want to keep changing the company name, gets way too confusing, I just want to keep writing over the old one, and replacing it with my current backup. 

Am I doing this wrong?



  • Kim ChapmanKim Chapman Accredited Partner Posts: 20
    edited April 2016
    Hi Rebecca. Rather than opening the file. Just Open Accounts, then restore. Alternately rather than having the company file open, close it and try restoring then. Hope this helps. Kind Regards Kim Chapman
  • RebeccaRebecca Member Posts: 36
    edited June 16
    HI Kim,

    I'm not sure I follow you.

    When you open Reckon Accounts, you get three options:
    Create a new company
    Open or restore an existing company
    Open a sample file.

    I select Open or restore an existing company.   then you have three new options

    Open a company file
    Restore a backup copy
    Restore a portable file

    If I select open company file (as I think you are suggesting), it does not view my back ups as a company file, they are not able to be selected, as Reckon Accounts is looking for an actual file. 

    If I select Restore a backup copy, which is what I want to do, I get the problem I have explained above. 

    Also I never close Reckon Accounts without closing the company first.  This is the correct procedure and prevents issues with the company arising from not being closed down correctly.  This means I have to select my company every time I open accounts, and it doesn't open automatically. 

    If I have mis-understood you, please try again.  I'm still stuck.

    Kind Regards,
  • RebeccaRebecca Member Posts: 36
    edited June 16
    I might add the following to be more specific...

    I am able to choose the back up I want to restore, my error comes when I go to save with the same name as the existing file on the computer hard drive.  ( I am not restoring my file to the USB where I am getting my backup from). 

    I hope this will help someone resolve my query (and it didn't confuse them more).

  • AndrewAndrew Member Posts: 14
    edited October 2018

    Rebecca, this is just Windows Vista or 7 being overly secure.

    When you get to the point to click your filename in 'save to', instead of left clicking on it, right click it and go down the bottom of the list to 'Properties'. Left click 'Properties' then untick "Read only'. Now 'Okay' your way back to the list and left click the filename to save to it.

    Unfortunately you will have to do this every time.

    As a bookkeeper with a number of clients I have to do this all the time!!



  • RebeccaRebecca Member Posts: 36
    edited June 16
    Great!  This worked.  Thankyou Andrew, this was the loop hole I was looking for!

    Thanks again!
    Kind Regards,
  • Sally McIntosh, Accredited ConsultantSally McIntosh, Accredited Consultant Accredited Partner Posts: 649
    edited February 2017

    Hi Rebecca,

    The other option which also gets around this constant unticking is to open your "old" file, then when you go to restore your backup over the top it will not require the unticking as it just lets it override no problems.

    Kind regards,

    Sally McIntosh ([email protected])

Sign In or Register to comment.