(MAPI error code 00000000 (0) at line 921 in sendmail.cpp)

  • 2
  • Problem
  • Updated 2 weeks ago
  • In Progress
Hey Reckon Accounts Team,

We have come across this issue recently where we try to email invoices and this error pops up instead of our email client. We are running Windows 10 Pro 64bit, our email client is Outlook 2016 and we are using Reckon Premiere Edition 2017. We have set Outlook to be our default email program in Windows and are running both Reckon accounts and Outlook as Administrator. Any help would be appreciated.
Photo of Lachlan

Lachlan

  • 202 Points 100 badge 2x thumb
  • Inconvenienced

Posted 2 months ago

  • 2
Photo of John G

John G, Information Support Analyst

  • 24,500 Points 20k badge 2x thumb
Hello Lachlan,

Thanks for asking.

A few questions.
When did this problem first emerge?  Were you able to send successfully previously?
Does this problem occur on just one PC or on all PCs?
Can you save the invoice to PDF successfully?


regards,
John.
Photo of Lachlan

Lachlan

  • 202 Points 100 badge 2x thumb
John,

Thanks for the quick reply. 
The problem first came up early January this year, it only occurs on one PC of three and we can successfully save invoices to PDF 
Photo of Orkun Evren

Orkun Evren

  • 494 Points 250 badge 2x thumb
Lachlan, we too experienced it in December last year after a series of windows automatic updates. There was one particular update to Microsoft outlook that made the running as administrator not work. The only way I got our emails working again was by going through the updates around that time and removing any relating to outlook. I tried it on one machine and when I found which update was the culprit, I was able to remove that particular update from all our other machines. Now all working again. Might be worth a look at your microsoft office updates.
Photo of Lachlan

Lachlan

  • 202 Points 100 badge 2x thumb
Orkun, 

Will check this out thank you.
Photo of John G

John G, Information Support Analyst

  • 24,500 Points 20k badge 2x thumb
Thanks Lachlan,

Is there any reason why you are running both RAB and Outlook as Administrator?  Both programmes being the latest version do not need to be Run as Admin.  Are the other 2 PCs configured to Run as Admin?


regards,
John
Photo of Lachlan

Lachlan

  • 202 Points 100 badge 2x thumb
John, 

We have done so due to recommendations on similar issues others have had on this site. We do not run as administrator on any other machine.

We have just tried what Orkun has suggested and have fixed the issue... for now.
Photo of Orkun Evren

Orkun Evren

  • 494 Points 250 badge 2x thumb
John, the workaround of running both Reckon software and Outlook has been ongoing since Win10 first came out. I have been told to run both in admin mode by Reckon Technical Support. We run 9 workstations and a server on RAE 2017. Admittedly we are running Outlook 2017 as part of Office Enterprise 2017 package. 

Glad it worked Lachlan
Photo of Orkun Evren

Orkun Evren

  • 494 Points 250 badge 2x thumb
Sorry John that should have been Outlook 2007 as part of the OE 2007 package...
Photo of Lachlan

Lachlan

  • 202 Points 100 badge 2x thumb
John,

Another thing to note that we had found when playing around a bit today was that if we had outlook completely closed then pressed the email button in Reckon it would open outlook without the error. But if you had outlook open then the error would persist.
Photo of John G

John G, Information Support Analyst

  • 24,500 Points 20k badge 2x thumb
Hello Orkun, Lachlan

Yes the recent updates to Outlook have caused some difficulties for some users and deleting that update is the workaround.

regards,
John
Photo of John G

John G, Information Support Analyst

  • 24,500 Points 20k badge 2x thumb
Hello Lachlan,

Its very unusual that problems occur with Outlook open and not with Outlook closed - usually the experience is the other way around.

It suggests that there is an issue with the Windows profile being used on that PC.  Create a new profile (with admin privileges) and log in with it and does the problem still occur?


regards,
John.
Photo of Kevin Russell

Kevin Russell, Accredited Partner

  • 33,268 Points 20k badge 2x thumb
John it has happened AGAIN after I installed Reckon 2018. Spent 45 minutes on the phone with tech support. Got nowhere. Please can we have a fix. Please. Please. All these temporary fixes aren't helping. It needs to be once and for all. Thank you.