"unhandled error occurred within core services"

  • 1
  • Problem
  • Updated 2 months ago
Hi I got the message as attached, for a payrun that's flagged with an 'Error' status.

Having thought about it a bit, my guess is that this is because I didn't enter any tax or super amount for one employee (15 year old doing a few hours a week). I have successfully processed payruns for this employee before, with zero tax and super, but on those occasions I physically keyed in "0" into the field. I suspect that on this occasion I just left the greyed out placeholder value of $0.00 that appears automatically and submitted that. My guess is that it was sent through as a NULL value rather than zero, which is why it was rejected. Which I guess is a bug - the field should either force an entry, or pass through zero if nothing is entered.

(I'm an ex-software tester!)

I've submitted an adjustment for the payrun which is basically a complete duplicate, except with the zero values keyed in, and it went through ok.

Just putting this out there in case it helps someone and maybe gets a bug fixed. I haven't tried reproducing the problem with another non-entered zero value because I don't want to filth up my list of payruns with errors, so I can't be sure that this is the problem but it seems a good bet.

Cheers.


Photo of Marshall

Marshall

  • 70 Points

Posted 2 months ago

  • 1
Photo of Rav

Rav, Community Manager

  • 89,244 Points 50k badge 2x thumb
Hi Marshall,
This error message means there was an issue with the ATO's SBR2 service at the time of submission and as such it hasn't been processed. You can verify this yourself in the ATO Business Portal (if you have access to it) or the employee can confirm this in their MyGov account.

My recommendation is to recreate the payrun and submit again.