1920 error when installing Reckon Accounts Premier 2017 on Windows 7

  • 1
  • Question
  • Updated 10 months ago
  • Answered
Hi,
We are currently using Reckon Accounts Premier 2016; on a PC with Windows 7 Pro 64-bit. The working installation is a 'Server plus Workstation' install. Another PC connects (Workstation only) and two users work happily on the same company file in multi-user mode.
I am trying to upgrade to Reckon Accounts Premier 2017, but the installation of 2017 keeps failing.
The green bar gets almost 90% across and it says 'Starting Services' down the bottom. But I keep getting 'Error 1920.Service Quickbooks Database Manager Service (QBCFMonitor Service) failed to start.
I did a few searches and it points to a .Net Framework 3.5.1 problem. I have checked the Windows components and .Net Framework 3.5.1 was already installed, but the 2 child options were not. I added the two child options. .Net Framework 4.6.1 was also installed previously.
So i am stuck and can't get past this.
I don't want to uninstall Reckon Accounts 2016 because I need to keep a fallback position. But I need to get 2017 working.
Any thoughts/suggestions???
Cheers,
Greg
Photo of Greg Miller

Greg Miller

  • 120 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Linda Putland

Linda Putland, Accredited Partner

  • 6,632 Points 5k badge 2x thumb
Hi Greg - I have seen this issue with installations of Point of Sale before.  Uninstall .Net 4.6.1 - then your installation of Premier should proceed smoothly - then you will need to install .net 4.6.1 again....
Cheers Linda
Photo of Greg Miller

Greg Miller

  • 120 Points 100 badge 2x thumb
Hi Linda, thanks for your suggestion, but I am no further forward. This is what I did:
I uninstalled .Net 4.6.1 and tried the install again, with exactly the same error.
So I then removed .Net 3.5.1 through Windows Components in Programs and Features. I then restarted the PC and re-installed .Net 3.5.1 and then re-started the PC again. I then tried the install of Reckon Accounts Premier 2017 again and I still received exactly the same error at exactly the same point.
So I am still stuck.
Photo of Linda Putland

Linda Putland, Accredited Partner

  • 6,632 Points 5k badge 2x thumb
Thats no good :(  .... I suppose one thing I didnt check - are you logged on as the administrator of that computer?  can you try installing again by going to the Temp folder where the files have unzipped and then right clicking on the setup.exe file and choosing Run as Administrator - this may be stopping the service from starting?

Actually - just read your question again - are you trying to install this on the server machine?  if so, have you stopped ALL the Reckon(QB) services before running the installation?

Failing this -I think a call to Tech Support is in order?
Photo of Greg Miller

Greg Miller

  • 120 Points 100 badge 2x thumb
So I've tried all that. I have disabled the QB services in this PC; I am logged in as a local administrator but I have also chosen Run as Administrator.....still not working, exactly the same error.
I have just emailed Tech Support.
Photo of Bilhan Thener

Bilhan Thener

  • 250 Points 250 badge 2x thumb
Hi, I come across your post here, did you get any answer regarding your problem? I'm facing the same problem, I'm trying to install Reckon account 2017 on Windows 10 and it keep giving me the 1920 error. Tried calling the support they keep telling me to start the service. I would not call them if I'm able to start it.

Thank you
Photo of John G

John G, Information Support Analyst

  • 27,360 Points 20k badge 2x thumb
Welcome to the Reckon Community Bilhan,

Did you reboot the PC immediately before installing the upgrade?
Did you stop and restart the QBCF Monitor Service (or QuickBooks Database Manager Service) in the Services.msc module?

If you did and still had the problem then you may find that stopping and starting the print spooler service before you install may resolve the issue. 

Please follow the recommendations in this KB: Installation Interrupted when installing Accounts Business until the issue is resolved.


regards,
John.
Photo of Bilhan Thener

Bilhan Thener

  • 250 Points 250 badge 2x thumb
Hi John,
Thank you for your reply. Yes I tried restarting the computer, and even create a new profile. This computer is freshly installed. The QBCF Monitor service is not starting at all it keep showing the service cannot be start on a timely manner. I will come back to to you on stopping the print spooler.

Thank you
Photo of Bilhan Thener

Bilhan Thener

  • 250 Points 250 badge 2x thumb
Hi, I followed the KB but it still coming with the same error that it cannot start the service. We are running the windows 10 on VMWare, is there an issue with that? and does it work at all on windows 10?
Photo of John G

John G, Information Support Analyst

  • 27,360 Points 20k badge 2x thumb
Hi Bilhan,

Running in VMware should not be an issue.
Did you restart the VMware and then try to install?


regards,
John
Photo of Bilhan Thener

Bilhan Thener

  • 250 Points 250 badge 2x thumb
Hi John,
Yes try restarting the windows, turn it off, nothing,create a new admin user, nothing work so far. I tried installing it on windows 7 and it work. that is why I asked whether it work with Win 10 at all.

Thanks
Photo of John G

John G, Information Support Analyst

  • 27,360 Points 20k badge 2x thumb
Hello Bilhan,

Yes, 2017 works perfectly on Windows 10.

Please restart the VMware,  stop and restart the QBCF Monitor Service (or QuickBooks Database Manager Service) in the Services.msc module and install.  If it fails again follow the guide in the KB: Installation Interrupted when installing Accounts Business until the issue is resolved.


regards,
John.
Photo of Bilhan Thener

Bilhan Thener

  • 250 Points 250 badge 2x thumb
Hi John,
I end up installing it on a physical computer. and it work. I'm not sure whats wrong with installing it on vmware.
Thank you for your support.

Bilhan
Photo of John G

John G, Information Support Analyst

  • 27,360 Points 20k badge 2x thumb
Good to hear you are up and running Bilhan.


regards,
John