Allow this application to login automatically not working

  • 1
  • Question
  • Updated 4 weeks ago
  • Answered
Hi, we are having trouble with allowing integrated applications to login to Reckon Accounts automatically.

We are using Reckon Accounts Enterprise 2017. It is installed on a Windows Server 2012 R2 operating system.

I can connect the integration application to the Reckon Accounts company file when the Reckon Accounts application UI is open, but when the Reckon Accounts application UI is closed the connection fails with the below error:
"This application is not allowed to log into this Reckon Accounts company data file automatically. The Reckon Accounts administrator can grant permission for automatic login through the Integrated Application preferences."

I have tried re-adding the Integrated Application under Company Preferences, ensuring that the 'Allow this application to login automatically' option is selected. See attached screenshot.

I have tried connecting using three different third party applications and none of them work. I can connect when the UI is open but not when it is closed. This makes me think it is a Reckon Accounts issue but when i called the support number they said there should be nothing stopping the connection and couldn't help me further.

Has anyone else got this working?

thanks,
Ben
Photo of Ben

Ben

  • 122 Points 100 badge 2x thumb

Posted 1 month ago

  • 1
Photo of Jason Hollis

Jason Hollis, Head of Product

  • 8,914 Points 5k badge 2x thumb
Hi Ben,

This is likely a Windows issue we have encountered previously. I will source the possible fix and post here. 

Jason
Photo of Ben

Ben

  • 122 Points 100 badge 2x thumb
Thank you that would be really helpful!
Photo of Jason Hollis

Jason Hollis, Head of Product

  • 8,914 Points 5k badge 2x thumb
Please review this fix

We do not warrant it's use, however it has fixed similar errors as advised by developer partners. 

Also ensure the QBW file has no security restrictions, and is being used successfully in multi-user mode by other users. 

Jason. 
Photo of Jason Hollis

Jason Hollis, Head of Product

  • 8,914 Points 5k badge 2x thumb
Hi Ben, I have QODBC and CData both working, so its not the app or Reckon, but something local. That makes it harder to find unfortunately. 

Did these simply STOP WORKING, or they were never working in this environment? 
Photo of Ben

Ben

  • 122 Points 100 badge 2x thumb
No they have never worked in this environment. Do you think it could be the Windows Server 2012 R2 operating system?
Photo of Jason Hollis

Jason Hollis, Head of Product

  • 8,914 Points 5k badge 2x thumb
Hi Ben, can you try running CData at ADMIN level priveledge. What is the result?
Photo of Ben

Ben

  • 122 Points 100 badge 2x thumb
Thanks again for helping me out with this. I tried that with the same result.

As a test I tried changing the CDATA service to 'Run as a Windows service', created a new Connection in CDATA, authorised it in Integrated Applications preference and then it connected when Reckon was closed - great!

But... when I closed and re-opened the CDATA web interface, the test connection failed again.

I reopened Reckon, tested the CDATA Connection and it worked, closed Reckon and it is still working. It seems that when I close the CDATA web interface it stops working

Is there a Reckon Accounts logfile that may hold some clue to the problem?
Photo of Jason Hollis

Jason Hollis, Head of Product

  • 8,914 Points 5k badge 2x thumb
Sure is. Search for QBSDKLOG.txt

Also turn on verbose logging first. 

  • Find qbsdk.ini 
  • Add/Edit the following lines:

    [Log]
    Level=verbose
    UnlimitedSize=Y
    [Parser]
    DumpRequestData=Y