An error occurred submitting single touch payroll details to the API.

  • 5
  • Problem
  • Updated 3 weeks ago
I have set up the Gov Connect and went to submit my first file in STP  (R1) to Gov Connect and this error message came up:  
  • An error occurred submitting single touch payroll details to the API.
How do you trouble with such little information or direction on how to correct!  Is anyone else experiencing the same issue?


I have rang the help number and went through the selection for R1 support but feel this is nothing but a tunes station with no message recording of my progress in the queue for the last 30 minute.  What is the help phone number for R1

Thank you
Photo of Naomi Kohler

Naomi Kohler

  • 280 Points 250 badge 2x thumb

Posted 4 months ago

  • 5
Photo of Mandy

Mandy

  • 380 Points 250 badge 2x thumb
I am getting the same error. Is there any fix to this?
Photo of Naomi Kohler

Naomi Kohler

  • 280 Points 250 badge 2x thumb
Yes was finally able to work out that is was the legal name not correct.  Copy from Gov Connect directly to R1 settings so it is exactly the same.

Photo of Corry Breugem

Corry Breugem

  • 72 Points
I have the same problem and even after copying the name from Gov Connect to the R1 to make sure it is spelled exactly the same....still get the error message. Any help is very much appreciated. 
Photo of Ellen

Ellen

  • 90 Points 75 badge 2x thumb
I too have followed all the steps above but to no avail... has anyone found a solution yet?  Welcome any other suggestions!!
Photo of Mike

Mike

  • 92 Points 75 badge 2x thumb
I'm stuck with this error message as well and the above instructions didn't help. Frankly I think that some sort of STP data validation function should be available in R1 to identify any data issues in such a way so that users like us can correct as needed instead of having to contact support... 

Mind you, STP has been around for a year and in the forum you can find a number of posts similar to this one, some of them dating several months back (... if not a year).
You'd think that the STP functionality could have been improved in the meantime to identify at least common mistakes and alert users with a clear error message... 
Photo of Rav

Rav, Community Manager

  • 80,506 Points 50k badge 2x thumb
Hi folks,
If you've tried the above, the only thing that I can think of which has any bearing on this error is the length of the company name. Does your company name exceed 38 characters?
If so, drop off some characters to bring it below 38, from what I understand STP can only take a maximum of 38.

Try that out and see how you get on.
Photo of Ellen

Ellen

  • 90 Points 75 badge 2x thumb
Hi Rav
I have tried that too. I've also tried removing special characters so the name is letters only but to no avail. Is there some other quirk we need to be aware of?
Photo of jessie

jessie

  • 74 Points
Check the employees address state has been selected from drop down menus not hand written.
Photo of bao dang

bao dang

  • 122 Points 100 badge 2x thumb
I am having the same issue, would be helpful if the error messages were a little more helpful like "Company name not matching" or "Legal address not matching" instead of a generic API issue. What type of error handling is this.
Photo of Wallina

Wallina

  • 202 Points 100 badge 2x thumb
Hi! I am also having the same issue! I have done all of the above and still having trouble....so frustrating. Any further suggestions Rav???

Photo of Tracey Good

Tracey Good

  • 266 Points 250 badge 2x thumb
Same here, have checked all the above but I still get the error. But I did see in govConnec my address is blank
(Edited)
Photo of bao dang

bao dang

  • 122 Points 100 badge 2x thumb
I checked my employee's State and picked the values, this fixed it. So I think its best to double triple check all the fields. A more specific error message would be more useful from the program, that's just lazy error handling.
Photo of jessie

jessie

  • 106 Points 100 badge 2x thumb
I had this frustrating trouble, problem for me was the employee addresses, choose the state from the drop down menu. So frustrating how long it took!!!
Photo of Mandy

Mandy

  • 380 Points 250 badge 2x thumb
After trying lots of fixes..I called the help desk 3 days in a row and they repaired it from their end. I dont know how and they didnt explain it
Photo of Ellen

Ellen

  • 130 Points 100 badge 2x thumb
Thanks Mandy - I may have to do the same... 
I've checked and rechecked employee addresses three times and that is not the issue!
Photo of Wallina

Wallina

  • 202 Points 100 badge 2x thumb
Thanks Mandy, I am phoning today after countless times of checking and still not getting any futher...

Photo of Tracey Good

Tracey Good

  • 266 Points 250 badge 2x thumb
I thought my addresses were correct but when I checked the postcodes were missing somehow. I fixed that and stp now works
Photo of Tanya

Tanya

  • 112 Points 100 badge 2x thumb
Thanks guys for your feed back - I have been away on AL so hopefully I can resolve it today pending help from IT.

No my company name does not exceed the character limit.  I have double checked with the ATO the correct legal name and spelling also.  I have reentered all employees addresses and ensured that only drop down menus were used.

Making phone call, lets see if my call is received?
Photo of LINH

LINH

  • 102 Points 100 badge 2x thumb
HI, 
I HAVE THE SAME ISSUE , PLEASE HELP ABN 69 600 886 431

Thanks


Photo of Peter

Peter

  • 270 Points 250 badge 2x thumb
My reckon one company file was set up with a different email address. (different from the ATO's)
Maybe this is an issue?
If so how can I change that?
Note that I already have changed the email address in my book settings to be the same as the ATO's.
Photo of Peter

Peter

  • 270 Points 250 badge 2x thumb
Another question.
Is payment of the payroll required to be entered as paid in reckon one prior to sending the payrun information to govconnect STP?
Photo of Peter

Peter

  • 270 Points 250 badge 2x thumb
And/or in the employee area, in the rectangle for employee username, the selection in my case is limited to one choice and that is our business email address (with behind it in between brackets a long number)
What is Reckon One asking when it wants to know the employee username, if not the name we use for this employee? (like Michael or David etc)

Clutching at straws here. Really do not know where to look for 'the error'
Did all other checks as suggested above.
Very frustrating.
Photo of Peter

Peter

  • 270 Points 250 badge 2x thumb
So, HOOORRAY.

I had paid the employees on the payrun, in 'real life', but had not informed my Reckon One book about this.
As soon as I put in the information that all payments in the payrun were paid, the payrun information was accepted by GovConnect.

Why is this not made clear anywhere?
(Edited)
Photo of Tanya

Tanya

  • 112 Points 100 badge 2x thumb
Finally fixed the problem! Even after conferring with the ATO to ensure I had the correct spelling of Legal Business Name etc, the issue was that the ATO has our entire Business Name in capital letters and I did not.

A little note or tip on just how exact the Business Name must be ie: capitals, spacing, characters would have saved me, some of these guys and your IT department a whole lot of anguish and frustration these past few weeks!
Photo of Ellen

Ellen

  • 130 Points 100 badge 2x thumb
I too finally fixed my problem!  There is another thing not mentioned in Rav's list above which you need to look out for.. for me it was that I had '+61' in my phone number in the payroll settings and special characters are not allowed.  
To fix go to Payroll Settings (COG wheel > Settings > Payroll settings > General) and ensure no special characters in the phone number.

Sounds like there are a lot of potential errors however this was the one holding me up - I hope this info helps at least one other person resolve their issue!
Photo of Vele Bunda

Vele Bunda

  • 90 Points 75 badge 2x thumb
I have the same issue, after trying everything explained above I'm still unable to submit to the STP
Photo of Vele Bunda

Vele Bunda

  • 90 Points 75 badge 2x thumb

This conversation is no longer open for comments or replies.