column item not appearing in sales report

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
I have created a column on my invoice to record our Batch No.s
I need this column to appear in my Sales Reports.

I cannot see an option to modify my Sales report to include this column.


Is there a way of displaying my Batch no. column?
and if not why not?

This would save me considerable time :)

Thank you for any help.

Cheers
Karen
Photo of Karen

Karen

  • 704 Points 500 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Kathy Mackinlay

Kathy Mackinlay

  • 3,150 Points 3k badge 2x thumb
can you select the Other 1 item from the available fields in the report. this would select the column you want.
Photo of Karen

Karen

  • 704 Points 500 badge 2x thumb
thanks Kathy, tried that. Column is empty. I think that refers to payroll maybe?
Photo of Donna Barletta

Donna Barletta

  • 738 Points 500 badge 2x thumb
I don't know if this will do what you want, but try
Go into the stock edit section and create a custom field called Batch,
Go to your custom invoice and select that custom field called batch to show on your invoice.  Then you can do reports when you have selected the custom field called batch when you modify your reports.  I don't know if you have to do it for all stock codes (if you do - export the file into a spreadsheet, and copy the information from that one stock code you set up with a custom field, and paste it into all the others, save as a Quickbooks file{the same that was exported before you changed it to a xl format, then import the list),  Like I said I don't know if it'll work - try it on a couple of stock items first (both with the custom field added and without it added - just to see if you need to do it to all stock items - and see if the reports will show the information your asking for, and if it does, then  continue with all stock if necessary.
Photo of Karen

Karen

  • 704 Points 500 badge 2x thumb
Thanks Donna, I will have look later as i can't do custom fields in multi user mode. Sounds a bit complicated , and we have many++++ items ;)
Photo of Donna Barletta

Donna Barletta

  • 738 Points 500 badge 2x thumb
Ok I did one, and you don't need to do all the stock likes.
1. go to a stock line, make a custom field Batch and tick.



After you click OK,  you'll see the menu - don't enter anything in the field, just click OK.



Go to the home screen, and click on invoice.
On the Tab bar above create Invoice you'll see a customise button.

Click on Manage Templates, and select the invoice template that you use,
Then click OK
Click on Additional customisation down the bottom

Then click on the columns tab at the Top.  Click both boxes for Screen and Print beside Batch.
The Order Numbers are where you'd like that column to appear on the invoices from left to right.  So you can change these numbers around to suit yourself.  Then click OK.  
#you may get a error message after this telling you that the fields are overlapping  (you shouldn't, but you might if you're working on other fields).  If you do, just go into layout designer and move the lines around until the fields aren't overlapping any more. 



Then, create an invoice using this same invoice that you just customised, and put in your batch numbers.

Then when you want to create a report, select the report you want, then select modify up the top


And this menu appears.  Go through the Columns until you find Batch, and click on it.
this will give you the report and will show all the batch numbers beside each entry.
If you'd like to do this same report, but just for items in batch 3, Select Filters tab at the top,
Then on the left you'll find a Filter list - go through that until you find Batch, and then type in the batch number you want in the Batch field and press OK.
Memorise the report - so all these selections are saved and you won't need to set it up again.
Photo of Karen

Karen

  • 704 Points 500 badge 2x thumb
thank you Donna, you are a treasure! I will have a go tonight when everyone else logs off as I am in multi user mode in daytime.

thank you :)
Photo of Karen

Karen

  • 704 Points 500 badge 2x thumb
Hi Donna,

thnk you for taking the time to suggest this.

However , sorry this did not work. Yes i can now display the column in my report but the Batch no. is absent. Its on the invoice. e.g.:
.

but both reports i use are blank, i need to display all batches so i can export to a SS 



also i have 194 items that I assume i  would have to individually go in and do this to. Very time wasting. (or, i am time poor!)

so why can't a column you create just show up as an option
very user unfriendly IMO
what's the point of having an option of a column in your  template when it serves no purpose?

so have i done something wrong?

thank you :)
Photo of Karen

Karen

  • 704 Points 500 badge 2x thumb
Hi Donna, i had another look this morning and i realised i now had 2 columns for Batch, the old one i created and the new one
so i had to untick the old and tick the new and it worked. thank you!!!

thank you for your brilliant help!!!!
(Edited)
Photo of Donna Barletta

Donna Barletta

  • 738 Points 500 badge 2x thumb
Why are you doing it 194 times.  I only did it for one stock item, and it worked for all the others that weren't set up with the customised field, in the stock set up. or do you mean you have to change 194 invoices - sorry I have no short cut for that :(  
Photo of Karen

Karen

  • 704 Points 500 badge 2x thumb
no i didn't need to do it 194 times. i thought at first i had to do it to each item but i didn't.
Photo of Donna Barletta

Donna Barletta

  • 738 Points 500 badge 2x thumb
We set up a column in our invoices to record serial numbers (as I always used to forget to record it) but we never have to do a report for this, just show it on the invoice.
Oh - and then I read all of your email - no you don't have to do it for all of your stock items, just one. try it you'll see :)  so glad I could help.
Photo of Karen

Karen

  • 704 Points 500 badge 2x thumb
Yes you have helped immensely !! Now my sale reports inc .the Batch no.s . i am doing  happy dance!! thank you!
Photo of Donna Barletta

Donna Barletta

  • 738 Points 500 badge 2x thumb
Oh yes - I know that dance.