Company File Server setup

  • 1
  • Question
  • Updated 10 months ago
  • Answered
Hi all,

I've been using Reckon on my own for a while but I have recently put on a new staffer in the office and she needs to access Reckon as well.  The data file is currently located on our OneDrive, which is mirrored locally on all computers (so there's a physical copy of the file on the two computers).  The problem with OneDrive is it doesn't allow us to work on the file at the same time, and we are having problems with OneDrive creating multiple copies so I've decided we need to set up the Company File Server to manage it.

The problem is I can't find any documentation on setting up the company file server.  I've uninstalled and reinstalled Reckon on the host computer with the company file server, but once that's done I have no idea what to do in order to get the second computer to access the data file from the host computer.

Can anyone direct me to some documentation that will guide me on how to get the second computer to access that data file?

Thanks
Photo of GoatyMcGoatBoat

GoatyMcGoatBoat

  • 1,016 Points 1k badge 2x thumb

Posted 1 year ago

  • 1
Photo of Rav

Rav, Community Manager

  • 71,724 Points 50k badge 2x thumb
Check out the info in this KB -

Installing, updating and configuring Reckon Accounts in Windows Server

There are more articles and help content in our KnowledgeBrowser, just add some keywords in the search box.
Photo of Bakaka Bakaka

Bakaka Bakaka

  • 192 Points 100 badge 2x thumb
Hi Goaty, depending on your version of Reckon (Premiere). Please note the followings:

- Host and Client workstations. 

Where the host is - the Reckon Accounts with Company File Server (during installation) should be installed there.

Where the client is - Reckon Account should (during installation) be installed there. 

Make sure, that the company data file is stored on the network where the clients workstations can have access to. Tip: Create a folder on the c-drive of the host PC (eg folder name: Reckon Company Data File)...put the data file inside that folder and share that folder so it is available on the network. 

Also, inside the your Reckon at the Host PC - Go to Reckon Account (at the host PC) and click "Company" tab and select "Set Up Users". Go ahead and set up the users (5 max) and create their passwords as well.

At the client PC - open Reckon Account (once installed at the client workstation/pc) and locate the company file where you have stored on the network (from that folder you have shared: Reckon Company Data File). Once you locate it, double click on the company file server, and a prompt dialog box should open and asks you for the user id and password...go ahead and enter the user and password and there you go.

Feel free to let me know if you have any further queries.

Cheers.
Photo of GoatyMcGoatBoat

GoatyMcGoatBoat

  • 1,016 Points 1k badge 2x thumb
Sorry Rav but that link doesn't help at all.  To be clear: I have two PCs in the office both running Windows 10, the first will act as the file server and a client and the second will act as a client only.  Both PCs need to be able to access the company file at the same time.  I do not have anything running Windows Server, although we will almost certainly set up a dedicated server in the future.

Bakaka Bakaka - Thanks for that, that's helped get started.  I've shared the company files folder and I can open the file from the second PC, however if the file is already open on the first PC then we get this error when trying to open it on the second one:



The host PC definitely has multi-user mode enabled:



EDIT: Also one more thing, on the second PC things seem VERY VERY slow, it takes upwards of two or three minutes to open the company file and get to the home screen whereas the host PC will do it in ten seconds or less.  Both PCs are similar spec, the host is slightly quicker but not enough to account for that big a difference.  Network is wired ethernet.

Any thoughts?

Cheers
(Edited)
Photo of Bakaka Bakaka

Bakaka Bakaka

  • 192 Points 100 badge 2x thumb
Yes, make sure to press the "Switch to multi user mode. Do me a favor - restart the host and the client pc and start up the Reckon up on both PC. Cheers.
Photo of GoatyMcGoatBoat

GoatyMcGoatBoat

  • 1,016 Points 1k badge 2x thumb
Thanks, multi-user mode was already started and both PCs have been rebooted... problem persists.
Photo of Bakaka Bakaka

Bakaka Bakaka

  • 192 Points 100 badge 2x thumb
On the host pc - have you set up the user (ie: accountant) with password? and have you entered already too those details (id and password) on the client PC?
Photo of GoatyMcGoatBoat

GoatyMcGoatBoat

  • 1,016 Points 1k badge 2x thumb
Yes, I have a user called "Office" in addition to the "Admin" user.

However, the error comes up before Reckon asks for the username/password.  It comes up immediately after double-clicking the company file, before Reckon even shows the splash screen or anything else.
Photo of Bakaka Bakaka

Bakaka Bakaka

  • 192 Points 100 badge 2x thumb
this means, that something is not right. Make sure too that right from the beginning of the setup - Reckon Accounts with Company File Server should be installed on the host. And Reckon Account ONLY should be installed on the client. Thereafter, it should work. Not forgetting the multiuser mode to be enabled on the host machine. Then you can select to open the company data file from the Reckon Account (client PC) computer. 

please verify once again the setup and confirm that you have carried out the steps i mentioned above. If you have, then no issue should persist thereafter. Cheers.
Photo of GoatyMcGoatBoat

GoatyMcGoatBoat

  • 1,016 Points 1k badge 2x thumb
Unfortunately this is exactly the process I took... Reckon and Company File Server on the host, Reckon only on the client, and multi-user mode is enabled on the host.

The file will open on one machine at a time, but won't open on both machines at the same time :(
Photo of John Graetz

John Graetz

  • 20,322 Points 20k badge 2x thumb
Do you have a second licence for the second user?  If you have only one licence, only one person can login at a time.
John L G
Photo of GoatyMcGoatBoat

GoatyMcGoatBoat

  • 1,016 Points 1k badge 2x thumb
Thanks John, as far as I'm aware Reckon Accounts Premier allows up to five users doesn't it?

Regardless this issue is occurring before the user login is entered, it occurs immediately after the file is opened on the second PC.  Reckon doesn't open at all, no splash screen, I just get the error message shown above.
Photo of Shisir

Shisir, Employee

  • 3,058 Points 3k badge 2x thumb

Hi Goaty,

This sounds more like networking and/or Permission issue to me, when you say you can open only on one PC at a time.

Can you please advise what version of Windows 10 operating system you have? As for the networking purposes Reckon Accounts needs it to be Professional edition at minimum.

If you have Windows 10 professional and have shared the file with another PC, can you please try below?

  1. On your Host PC, open Reckon Accounts Database server manager. ( you have installed this on server)
  2. Click on add folder
  3. Select the folder where your Reckon Accounts file is located. And press OK
  4. Now click on scan
  5. This should scan the folder and lists your file on the box below, "Reckon Accounts file found".
  6. once this is done press Close and exit out of this window.
  7. this will create a .ND file. which is required for the networking purpose as it hold the appropriate information about the address of the file etc.
Once this is done please try opening your file from the Host PC first and than the second PC.

Please let me know how it goes.
Regards
Shisir
Photo of GoatyMcGoatBoat

GoatyMcGoatBoat

  • 1,016 Points 1k badge 2x thumb
Hi Shisir,

Both PCs are running up-to-date Windows 10 Pro:



I've gone through the exact process you outline above, the problem still persists.

Thanks
Photo of Shisir

Shisir, Employee

  • 3,058 Points 3k badge 2x thumb

Great thanks for the update Goaty,

Please try this. http://kb.reckon.com.au/issue_view.asp?ID=3949

Regards
Shisir
Photo of GoatyMcGoatBoat

GoatyMcGoatBoat

  • 1,016 Points 1k badge 2x thumb
Hi again Shisir,

I've followed that KB article...

Solution 1:  Switch the file to multi-user mode
File is already in multi-user mode


Solution 2: delete the *.nd file
Done:


Solution 3:  give QBDataServiceUserXX Full Control permissions to the folder containing the company file.
Done:



Solution 4:  Verify that the Accounts Business network is properly setup
I went to the KB article there and followed everything, it didn't help.



PARTIAL SOLUTION:
Just to try and isolate the problem, I turned multi-user mode off on the Host PC and enabled it on the Client PC.... once the database server on the Client PC was running and Reckon was open, I was able to also open Reckon on the Host PC!

This method won't work in the long run though, as the Host PC (the PC that has the physical files on it) should be the one to host multi-user access.... the Host PC is my PC, and it needs to be the main host so that I can work from it anytime.  The second PC in the office, the admin PC, needs to be the Client in this situation.

I'm very confused as to why it will work in one direction, but not the other.
(Edited)
Photo of GoatyMcGoatBoat

GoatyMcGoatBoat

  • 1,016 Points 1k badge 2x thumb
Update
I've reset things back to the way they were (with the Host PC hosting multi-user access) and the problem has returned, however one interesting change is that the Client PC is now accessing the file from the network share much, much faster... no idea why, it just seems to be many times faster than it was.  

The error still persists though:
Photo of Shisir

Shisir, Employee

  • 3,058 Points 3k badge 2x thumb
Hi Goaty,
After deleting the .nd file, did you scanned the folder again, from database server manager (DBSM) , from the server PC? so it creates the new ND file?
If not Please repeat the step again.
1) delete the nd file from server/PC1.
2) scan the folder again using DBSM from the PC1.
3) Open the file from the PC1.
4) switch to MU Mode.
5) try open the file from the PC2.
Hope this works
Regards
Shisir
Photo of GoatyMcGoatBoat

GoatyMcGoatBoat

  • 1,016 Points 1k badge 2x thumb
Hi Shisir,

I've been through the process above to create the new ND file several times and unfortunately it still hasn't helped :(

Thanks
Photo of Shisir

Shisir, Employee

  • 3,058 Points 3k badge 2x thumb

Hi Goaty,

Let's take a step back and start from beginning again. As we have done quite different steps and may have confused ourselves.

  1. Create a new folder and copy your company file across to this new folder. (just a QBW company file) In your main PC.
  2. Make sure you can see/access this folder from  your 2nd PC.
  3. Open reckon Database server manager on the 1st PC. Scan the folder. Make sure the company file is listed. Then close it.
  4. This will create a new .ND file.
  5. Now open the Reckon Accounts in this 1st PC.
  6. Switch to Multi user mode.
  7. Go to file menu -> utilities and make sure it says "Stop hosting Multi user access". This means that your 1st pC is hosting. Your 2nd PC should never say this, it should say "Host Multiuser access", meaning it is not currently hosting.
  8. Now go to your 2nd PC, and try open the file from this new folder.
  9. If the issue persists, try disabling the antivirus and firewall on both PC and see if that works. If it works, it means you will need to configure your firewall. Please see this guide.http://kb.reckon.com.au/issue_view.asp?ID=220 you may want to speak with your IT for this.

Regards

Shisir
Photo of Deb

Deb

  • 130 Points 100 badge 2x thumb
Why does the host PC want to Stop hosting multiuser when that is what we WANT to do?! Arent we tryingvto get PC1 to share the database....I.e. be a host to another user?