Company information is valid

  • 2
  • Question
  • Updated 4 weeks ago
  • Answered
I have been successfully uploading payroll files since inception. I have now shared with another user and gone through setting that user up to the point where they can login and get to upload point. When trying to upload the file, they get the red message Company Information is Valid then nothing. If I try to upload the same file, it works as per previous. What are we doing wrong?
Photo of richard

richard

  • 130 Points 100 badge 2x thumb

Posted 2 months ago

  • 2
Photo of Kevin Russell

Kevin Russell, Accredited Partner

  • 39,126 Points 20k badge 2x thumb
Have you spoken to the bank?
Photo of richard

richard

  • 130 Points 100 badge 2x thumb
Sorry Kevin, this is the STP file upload through Reckon Portal I'm talking about
Photo of Kevin Russell

Kevin Russell, Accredited Partner

  • 39,126 Points 20k badge 2x thumb
Well thats just confusing
Photo of Rav

Rav, Community Manager

  • 61,090 Points 50k badge 2x thumb
Hi Richard,

The 'Company information is valid' message relates to a mismatch with the branch number between GovConnect STP and your Reckon accounting software.

Can I confirm, are you using Reckon Accounts or Payroll Premier?

If you take a look at the branch number listed in your Company Information settings and ensure that it matches with what is listed in GovConnect STP it will resolve this for you.
Photo of richard

richard

  • 130 Points 100 badge 2x thumb
Hi Rav,
we're using Reckon Accounts. I can upload the file from my login but when a user I've shared to tries to upload the file it fails with the Company information message.

Photo of Rav

Rav, Community Manager

  • 59,770 Points 50k badge 2x thumb
Hmm that sounds odd. 
Was the STP entity shared with the other user using the method outlined here
Photo of richard

richard

  • 130 Points 100 badge 2x thumb
Yes, shared as per the procedure and received the success notification
Photo of Rav

Rav, Community Manager

  • 59,770 Points 50k badge 2x thumb
Hi Richard,
Can you let me know if this issue still occurs the next time this user has to perform a STP upload?
Photo of Richard Keeler

Richard Keeler

  • 120 Points 100 badge 2x thumb
Will do Rav
Photo of Richard Keeler

Richard Keeler

  • 120 Points 100 badge 2x thumb
Hi Rav,
the issue is still exactly the same. This user cannot complete the upload.
I will need to change my MFA to a new phone soon and I'm hoping I can do that without losing our ability to upload.
Thanks,
Richard
Photo of Rav

Rav, Community Manager

  • 59,770 Points 50k badge 2x thumb
Thanks for getting back to me on this Richard,

Does the shared user have more than one STP entity in their Reckon Portal account? Regardless, can you please share that STP entity with us, the user name to share with is chocolol2 and I'll ask our STP dev to take a look

In regard to MFA and upgrading to a new phone, what you'll need to do is revoke the current MFA by going into the settings menu in your Reckon Portal account. Click the settings icon in the top right corner, then scroll to the bottom of the page and you'll see the Revoke option. You'll need the code from the current MFA source in order to revoke it. 
Photo of Richard Keeler

Richard Keeler

  • 120 Points 100 badge 2x thumb
Thanks Rav.
Now I can't access STP with either the new code on the new phone neither can the other user. Both are getting 401: Unauthorised error
Photo of Rav

Rav, Community Manager

  • 59,770 Points 50k badge 2x thumb
Press Ctrl+F5 to do a hard refresh, alternatively clear your browser cache and cookies and it should get you past that. 
Photo of Richard Keeler

Richard Keeler

  • 120 Points 100 badge 2x thumb
I've done all that and still getting the same error as soon as I launch STP
Photo of Richard Keeler

Richard Keeler

  • 120 Points 100 badge 2x thumb
After several logins, I managed to get to launch and upload successfully using the new phone/authenticator. Subsequent launches have generated the 401 error again.
I have created chocolol2 as a user.
Photo of Gemma

Gemma

  • 380 Points 250 badge 2x thumb
We are having the same issue with Reckon Hosted.  I shared the company file with my colleague as per the process and he is also getting the Company file is valid message and cannot go any further. Can you please advise of a fix?