Firewall port number for Reckon 2015

  • 1
  • Problem
  • Updated 3 years ago
  • Solved

We have just had Reckon Accounts Enterprise 2015 installed and we are unable to open the file.

The IT guy needs to know what the new port number is that needs to be opened up on the firewall for this version of Reckon.

Can anyone help please?  Thank you.

Photo of Natalie

Natalie

  • 606 Points 500 badge 2x thumb

Posted 5 years ago

  • 1
Photo of Reckon FAQs

Reckon FAQs, Employee

  • 10,138 Points 10k badge 2x thumb
Hi Natalie,

Thanks for asking the Reckon Community.

The Port number for Reckon Accounts 2015 is 10178.
The number advances by 1 with each new yearly release.  

Hope this gets you accessing your files.


regards,
Photo of Reckon FAQs

Reckon FAQs, Employee

  • 10,138 Points 10k badge 2x thumb
Hi Natalie,

Thanks for asking the Reckon Community.

The Port number for Reckon Accounts 2015 is 10178.
The number advances by 1 with each new yearly release.  

Hope this gets you accessing your files.


regards,
Photo of Trevor Watson

Trevor Watson

  • 1,478 Points 1k badge 2x thumb
What are the settings for RA2016? I've allowed (QBCFMonitorService)(QBUpdate)(QBUpdate)(QBGDSPlugin)(QBDBMgrN)(FileManagement)(QBDBMgr) inbound & outbound, all profiles, any ports, any address on the windows 7 pc that hosts the datafile, but can't access from windows 10 pc. However, making no other changes simply completely disabling the Home profile firewall on the win 7 PC allows the win 10 PC to connect - completely disabling the firewall is not an acceptable solution, so what additional settings am I missing.
Photo of Shane

Shane, Employee

  • 7,448 Points 5k badge 2x thumb
Hi Trevor, 

The port number for 2016 is 10179.  Open this port for inbound and outbound traffic for domain, public, and home on the machine the company file is stored on.  One other thing to note is that for 2016 you need to install Reckon Accounts with Company File Server on the machine the file is stored on (not just Company File Server as in previous versions).  You don't need to open or run Reckon Accounts but it needs to be installed for Multi User to work.  Just delete the icon from the desktop after installation.  Also make sure the user QBDataServiceUser25 has read, write and modify permissions to the folder the company file is stored in.

That should get you going.  Let me know how you go.

Regards,
Shane.
Photo of Trevor Watson

Trevor Watson

  • 1,478 Points 1k badge 2x thumb
Thanks Shane. It appears that the problem is when the company file is already opened & in use, the remote machine can't access the company file and vice versa. The hosting PC windows 7 has RA and File Server installed, the firewall was set up to allow in & out traffic on any port for the specified reckon exe's. As per your message I gave all priveleges to QBDataServiceUser25 for the company file directory. Opened the company file on the host pc (using RA on the host PC) and switch to multi-user mode. Try to open the company file on the remote pc windows 10 - and get the firewall error message.

Finally appear to have solved the issue. Steps I took were close company file, on hosting pc stop hosting service (File\Utilities\Stop Hosting Multi User Access), restart hosting service (File\Utilities\Host Multi User Access), rescan the company file directory using Reckon Accounts Database Server Manager, open the company file using RA on the hosting PC and select Multi User Mode (File\Switch to Multi User Mode). Now able to have both hosting & remote pc logged in to company file at same time with no errors. Obviously something didn't take properly the first time.

Cheers

Trevor
Photo of Shane

Shane, Employee

  • 7,448 Points 5k badge 2x thumb

Glad to hear it worked out.  Thanks for the update Trevor.

Shane.

Photo of Trevor Watson

Trevor Watson

  • 1,478 Points 1k badge 2x thumb
Hi Shane

Is there a way to make this persistent over reboots of the hosting PC? I'm having to close the company file, stop & restart the hosting service, re-add the co file directory and rescan it, the reopen the company file in multi - user mode after a reboot of the hosting pc. If that's the way it has to be then so be it, but it would be less hassle if it were persistent.

Cheers

Trevor
Shane

Great to discover this entry.  An often overlooked setting on the HOSTING PC for say:  Reckon Accounts Premier 2016,  to allow the OTHER PCs to open and access the shared QBW file on such a hosting PC (poor man's server: peer-to-peer environment).

The default setting on a freshly built WIn7 Pro box, with latest Reckon Accounts,  requires manually enabling that all important firewall rule mentioned above.

The two highlighted lines of the 4 in total,  needed to be ENABLED as well as being set for the domain, private/home  (perhaps: public, if securely required) profiles.

On the Win7 Pro HOSTING pc:   control Panel -->  firewall -->    Advanced Settings -->   Inbound rules



Been caught by that year's ago and forgotten that extra step!  Saved the day.  Thanks Shane.


Gary