Help with "Tax code can't be entered for non-taxable items" error

  • 1
  • Question
  • Updated 4 years ago
  • Answered
  • (Edited)
Hi,

I've been getting into Reckon One, finding my way around & starting to create rules so I can easily import past bank transactions and get up to date.

I can't find a way around this problem, so far I've seen this message when trying to create a rule for payments using the Bank Charges, Repairs and Maintenance and Printing and Stationery accounts, I can create the rule, but then when I try to confirm the transaction I get the message "Tax code can't be entered for non-taxable items".

Is there a way around this? I know I can enter these items manually, but that's definitely not ideal when they're so regular like bank account fees and regular maintenance items.

Also I have tax tracking set to disabled, I don't need to track GST etc.

Cheers,

Conrad

Photo of Conrad

Conrad

  • 176 Points 100 badge 2x thumb

Posted 6 years ago

  • 1
Photo of John G

John G, Information Support Analyst

  • 27,510 Points 20k badge 2x thumb
Hi Conrad,

Sorry to hear you are having this problem.    

Unfortunately that is a problem with the software at the moment and is being worked on by our programmers.

The account being used in your Transaction Rule is an account created by the programme that has a requirement for a Tax Code.  Even though you have disabled Tax, that account still wants a tax code, so the error is generated.

For the time being the workaround is to create a new account without a tax code assigned to use instead of that account.  

I'm sorry for the inconvenience this problem is causing and we expect a fix to it in a future update to the programme.  

regards,
John


Hi there,
1 year on and this seems to still be an issue in Reckon One. This doesn't appear to have been fixed at all so would appreciate an updated response to this please.

thanks
Janolla 
Photo of Qwerty

Qwerty

  • 7,906 Points 5k badge 2x thumb

Hi guys,


This issue seems to occur for books where tax tracking is disabled & you are using an account that has a tax code associated to it. When saving the transaction/form, validation occurs which detects that tax tracking is disabled however the account has a tax code associated to it.

Note: When you create a book, the book setup wizard you ask you to choose an industry. If you choose an industry (shown in the red selection below) your book will contain some accounts that have tax codes associated. If you choose the "Other/none/prefer not to say" option (shown in the green selection below) then you will have no default chart of accounts setup.


Until this issue is fixed there is a simple work around for anyone who is experiencing this problem.


Please note: The following work around is under the assumption that your book is currently configured to not track tax & this is as per your business requirements... i.e. you are intentionally not tracking tax.


1. Review the tax settings for your book

Click the Administration menu (i.e. the cogs icon shown in the top right) > Tax settings

2. Your book should currently show tax tracking as being disabled

3. Enable tax tracking & save  

4. View the chart of accounts

Click the Administration menu (i.e. the cogs icon shown in the top right) > Chart of accounts

5. Review all the accounts shown in the Income tab & edit any accounts that show a tax code & remove the tax code

6. Review all the accounts shown in the Expense tab & edit any that show a tax code & remove the tax code

7. Review the tax settings for your book

Click the Administration menu (i.e. the cogs icon shown in the top right) > Tax settings

8. Disable tax tracking & save 


You should now be able to use these accounts successfully without seeing any tax related validation messages when saving transactions.

(Edited)

This conversation is no longer open for comments or replies.