How to set up Home & Business for GST

  • 1
  • Question
  • Updated 2 months ago
  • Answered
I recently (today!) registered for GST and now wish to set up Home & Business 2018 for the the new regime. I've enabled tax-tracking, but when I go to edit existing line items there are no tax codes in the item's tax drop-down list! Have I missed a step? All help much appreciated.
Photo of Jon

Jon

  • 886 Points 500 badge 2x thumb

Posted 2 months ago

  • 1
Photo of Jon

Jon

  • 886 Points 500 badge 2x thumb
And if I try and type in a GST code I'm told that "Transactions using a newly created tax code will not appear in the BAS report".  :-( So that's not an option.
(Edited)
Photo of Jon

Jon

  • 886 Points 500 badge 2x thumb

Image to show lack of tax codes.
Photo of Jon

Jon

  • 886 Points 500 badge 2x thumb


The Invoice and Bill Accounts are both set to track tax.
Photo of Jon

Jon

  • 886 Points 500 badge 2x thumb


Another thing... no Split button on my Transactions (Customer Invoices account)
Photo of John G

John G, Information Support Analyst

  • 25,370 Points 20k badge 2x thumb
Hi Jon,

Where did you turn on Tax Tracking?

Was it on the Bank Account? right-click Bank Account > Edit account, and select Yes to Tax-Tracking enabled.
This will create a Tax Control account in your Business module which will then show on your Account List.





If this is still a problem create a new file and check whether the tax codes are available.



Hope this helps.

regards,
John
Photo of Jon

Jon

  • 886 Points 500 badge 2x thumb
Hi John - I have responded but created new replies instead of using the 'comment' button, which may have alerted  you.
Photo of Jon

Jon

  • 886 Points 500 badge 2x thumb


All SEEMS to be in order? I enabled tax tracking on both the Customer Invoices and the Business Bills accounts. But no Tax Control acct has been created (hence no tax codes and no split button?)
I'll try creating a new acct (is that what you meant by a 'new file'?)
Photo of Jon

Jon

  • 886 Points 500 badge 2x thumb
And yes, I did turn on tax tracking as you described. Thanks for chiming in John :-)
Photo of Jon

Jon

  • 886 Points 500 badge 2x thumb
oo - my acct type above is 'invoice'... problem? And now when I create a new test acct I can't see 'invoice' as an option type!? I wonder how I selected 'invoice' in the past when creating my 'Customer Invoices' acct?

Anyway, here's a test acct screenshot. Still no Tax Control acct and no tax codes under 'edit category', but I do have a split button.
Photo of Shisir

Shisir, Employee

  • 2,378 Points 2k badge 2x thumb

Hi Jon

It is strange how it got the type as 'Invoice' for an account. I'm not quite sure how this has happened. However I would like to do some test and see if that will resolve the issue.

Can you please create a new Data file and see if the phenomenon is replicable there?

  1. Go to file menu on the top and click on new.
  2. Select new file.
  3. And follow the prompt to create a new file.

  4. See if the tax codes appears here.

This will tell us if the issue is local to your file or if in installation. If you can see the tax codes in the new file you just created, means something wrong on the file, maybe in the way it was setup. Can you please let us know how long have you been using this file for? When was it first created? From which version?

Regards

Shisir
Photo of Shisir

Shisir, Employee

  • 2,378 Points 2k badge 2x thumb
O and forgot to mention, Please make a backup of the file, before deleting anything from it.
Regards
Shisir
Photo of Jon

Jon

  • 886 Points 500 badge 2x thumb
In order to send you an empty file (I'll send the copy that I made above) is there a quick way to delete the transactions? If I shift-click a range of invoices, ctrl-D only deletes the first one.
(Edited)
Photo of Robyn Kelly

Robyn Kelly, Accredited Partner

  • 3,326 Points 3k badge 2x thumb
Try "Delete" - not Ctrl-D - on the keyboard after selecting all the transactions (next to page down on my keyboard).
(Edited)
Photo of Jon

Jon

  • 886 Points 500 badge 2x thumb
The physical delete key removes any selected text on the transaction (and I can't select a transaction without a text element such as the date, customer or memo being selected), and cutting or deleting from the right-click menu still only removes the first transaction in a selected group. Weird.
Photo of Jon

Jon

  • 886 Points 500 badge 2x thumb
The physical delete key removes any selected text on the transaction (and I can't select a transaction without a text element such as the date, customer or memo being selected), and cutting or deleting from the right-click menu still only removes the first transaction in a selected group. Weird.
Photo of Jon

Jon

  • 886 Points 500 badge 2x thumb
Robyn - yes my file was created in Nov 2007 (my first invoice :'-}  )
It was created in Quicken Premiere Home & Business 2005 :-0 In the past few days I have enabled tax tracking on this account, but no tax codes are available. And no split button either.

However, If I create a totally new data file, it has tax codes and just now I created an invoice to which I added an item to which I was able to select and apply the GST code. At that point the Tax Control account was automatically created.

So it does appear that it is my file (the descendant of the original created in 2007) that is having a mismatch with H&B 2018, or that has a corruption. New data files, or the example files supplied with the software, work fine, so the software itself is OK.
(Edited)
Photo of Jon

Jon

  • 886 Points 500 badge 2x thumb
Thanks Robyn - Yes I was trying to add GST to the Invoices acct.

The "totally new data file" that I mention, just above your most recent reply, is a "bank" account and all works as it should. I don't know the difference between the two account types (oh to have taken bookkeeping at school instead of physics :-D  ), but I'll probably go with what works. It would be nice to be able to import my client lists, transactions, items and categories from the old file but I guess I can recreate things as I encounter them.

What is " validate & super validate " and how does one carry that out?
Photo of Robyn Kelly

Robyn Kelly, Accredited Partner

  • 3,326 Points 3k badge 2x thumb

In the data file you already have can you please set up a new account as a bank account, making sure it is Tax Tracking enabled.  Then try to enter a transaction and SPLIT the transaction to see if you are able to add a tax code in the transaction.


Validate and then SuperValidate your datafile.

1.    File > File Operations > Validate

2.    To super Validate, same steps but hold down Ctrl key with Validate.


Regards, Robyn

Photo of Shisir

Shisir, Employee

  • 2,368 Points 2k badge 2x thumb

Thanks for your input Robyn.

Jon, to delete multiple transactions, Highlight them using Shift keys and right click on it.

Select Delete from the option.


Regards
Shisir
Photo of Shisir

Shisir, Employee

  • 2,368 Points 2k badge 2x thumb

Hi Jon,

I was checking your account in our system and found that your account do not have 2005 version allocated. I did further Googling and found the product you mentioned "Quicken Premiere Home & Business 2005" is actually US version product. So that explains why there is 'Invoice' type account and no tax control account

It appears, somehow the file from US version was successfully opened from our AU version product but hasn't been converted to AU version yet. The file still holds the US structure in the database.

One thing we have not tested here, yet, is a as Robyn mentioned, If you create a new 'bank account' (In your actual file), are you able to create it like a bank account? And if you can, does it create the tax control account? If yes that might solve the issue.


If it still does not create the tax control, the best solution here is, as you said, to start a new file in Reckon Home & Business and use it as we do not have any other way to convert the file to AU version.

Apologies for the inconvenience.

Regards

Shisir
Photo of Jon

Jon

  • 886 Points 500 badge 2x thumb
Neither validation routines found fault in my data file.

When I create a tax enabled bank account within that data file, no tax codes are available.



However if I create an entirely new data file containing a tax enabled bank account, tax codes are available and the first transaction creates a Tax Control account. So the fault would appear to lie in the original data file.
Photo of Jon

Jon

  • 886 Points 500 badge 2x thumb
Hi Shisir - I believe you have identified the problem; I arrived in Australia with a US version of the software and just assumed that it would 'work' in Australia. That assumption has come back to bite me! So I'll proceed with using a new data file. Should it be possible to import any info from my old file to the new one? Or should I just recreate elements (customers, items, categories, form layouts... ) as I encounter the need for them. That would not be difficult as they are few.
Photo of Shisir

Shisir, Employee

  • 2,378 Points 2k badge 2x thumb

Hi Jon,

Unfortunately, you will have to create them in new file as you go. There is no option to import or export the items, categories etc.

Regards

Shisir
Photo of Jon

Jon

  • 886 Points 500 badge 2x thumb
Thank you John, Shisir & Robyn for all your help with this mysterious behavior. In the end it made sense given the files lineage. The tax side of things is new to me so no doubt I'll be back with more questions from time-to-time :-)
(Edited)