Importing iif file for invoices, class field is not working

  • 1
  • Question
  • Updated 1 week ago
  • Answered
We have begun using 3rd party software to produce our invoices, and then import the invoices into Reckon (we are on the 2018 desktop version) by way of an IIF file. This is working fine with the exception of the Class field. We use class tracking to report on our separate branches, and although the Class field appears in the IIF file it doesn't come through on the invoices in Reckon. Any suggestions please?
Photo of Melissa Read

Melissa Read

  • 100 Points 100 badge 2x thumb
  • frustrated

Posted 3 months ago

  • 1
Photo of Kevin Russell

Kevin Russell, Accredited Partner

  • 40,760 Points 20k badge 2x thumb
Yes. Get your 3rd party software provider to fix their software. Thanks for your question
Photo of Melissa Read

Melissa Read

  • 100 Points 100 badge 2x thumb
That's not very helpful. The class field is there in the IIF file, I can't see any reason it's not working. We have sorted all the other issues with the GST and getting the invoices to go on to jobs etc, so we know what we are doing and have checked that the names of the classes are exactly the same at both ends - I'm more wondering if it's a known fault in Reckon that the class is not coming through?
Photo of Linda Putland

Linda Putland, Accredited Partner

  • 6,632 Points 5k badge 2x thumb
Hi Melissa - where in the IIF file does the Class appear - is it just on the TRNS lines or the SPL lines as well?  For you to get the reporting it sounds like you use, you would need to ensure that its repeated on all the SPL lines?  Cheers Linda
Photo of Data Rec

Data Rec, Employee

  • 4,422 Points 4k badge 2x thumb
Hi Melissa,


The example above works on a Reckon Accounts 2017 AU software.




1. Click on the menu Edit | Preferences
2. Go to Accounting section
3. Go to Company Preferences tab
4. Check if  'Use class tracking' is enabled.


Regards,

Data Recovery Team

Photo of Linda Putland

Linda Putland, Accredited Partner

  • 6,632 Points 5k badge 2x thumb
I know this sounds weird - but I have come across it before - after checking the class settings in Preferences (which I assumed would already be there if you were using Class tracking before you got the third party import happening?)... but if you get one of the import files created by the third party - and then open it in Excel...  then look at how everything lines up - there have been times in my experience, where sometimes the header and/or detail column names in the first two lines - actually have a space in front of them?  when you have it open in Excel - click in those fields and check if there is a space in front of the word CLASS.... then do the same for the Class data in the SPL lines? 
Photo of Data Rec

Data Rec, Employee

  • 4,422 Points 4k badge 2x thumb
Hi Michelle,

I've tested that scenario and Linda is correct.

Whilst the other fields are recognised, the CLASS field is ignored since it contains a space character directly after the 'tab' character delimiter.


Regards,

Data Recovery Team
Photo of Melissa Read

Melissa Read

  • 100 Points 100 badge 2x thumb
We have spent hours on this issue, tried everything we can think of. There are no space characters in the file. We have used Reckon's own sample file to create a dummy import invoice, and it will create a whole new Class that shows up in the Class List, but for neither love nor money can I get the invoice to have the Class show up. So, for every invoice I import, I have to open the invoice and choose the Class from the dropdown on the invoice screen. I really can't see that it is the iif file at fault - it seems to me that the Reckon invoice is not importing that field. Class tracking is definitely turned on, we've been using it for years. Is there some other setting that needs tweaked???

This is the file that created a new Class called "D", but the Class on the invoice was still blank...


Photo of Linda Putland

Linda Putland, Accredited Partner

  • 6,632 Points 5k badge 2x thumb
Hi Melissa - can you please check this?  with the file above - open it in Excel... go to Line 21 and 22....  click in the Cell that says CLASS - then click so your cursor is in the formula bar at the top.... now use the arrow keys to go left as far as you can.... I think you will find there is a space to the left or the word CLASS?