Inconsistency in Portfolio between transaction detail and totals

  • 1
  • Problem
  • Updated 1 week ago
I am using Personal Plus 2018.

Yesterday everything was looking fabulous and reconciled but today!!!  I will try to describe this as best I can.
I deleted a stock sale because I wanted to change it - it wasn't looking correct.  I can't remember exactly but I suspect it was the problem I'm describing here.  
  
The first time I did the stock sale I had 2 purchase dates. I sold all of one parcel and part of another parcel.  Then when I went to Portfolio View the parcels were correct but the Total for the holding was incorrect - the total didn't recognise the sale.  
So, stupidly, I tried again:  
 - Deleted the sale without nominating a lot. Problem still there.  
So I re-entered the sale.  Now my 
- bank account is correct (i.e. I need the re-entered transaction to get the bank account correct) 
- the lots have been sold again - the calculations are correct for 2 sales but I obviously only want one

- the total number of units is correct for one sale (not two) but inconsistent with the parcels, and the total cost base is a number I can't figure out at all.

So in summary I have a total which doesn't match the parcel.   And if I delete the most recent sell transaction my bank transaction isn't there and the parcel/total sizes remain inconsistent.

Original parcels
1. #=9500 cost base=$24729.95
2. #=5000 cost base=$20079.95
total 14500

1st transaction
I sold 5800, supposed to be the 5000 cost base=20079.95 +800 cost base $2082.52
Total: shares=14500; cost base 44809.90 i.e. the total didn't adjust
parcel 1: shares=8700; cost base 22647.43 correct
parcel 2: shares=0 correct
bank transaction correct

2nd: deleted the 1st transaction - 
totals correct, parcels didn't recover, bank transaction deleted

3rd: re-entered the sale
Total: shares=8700; cost base 29711.61 the shares have been sold but the cost base hasn't adjusted correctly
parcel 1: shares=2900; cost base 7549.14  correct if I wanted to do this but this is not what I want and don't match the total.


I've been back through the Q&As and have done what is recommended -i.e. validated and super validated but this hasn't found anything.

I'm quite willing to just make some adjustments to get things back into balance but I have no idea what to do.  Ongoing I need my parcels to add up to the total number of units and cost base, and I need the total cost base to be correct, and I need my bank balance to be correct.

Hopefully there's an answer.

Many thanks for any assistance that can be provided.  

Photo of Lorna

Lorna

  • 160 Points 100 badge 2x thumb
  • very confused and frustrated

Posted 2 weeks ago

  • 1
Photo of David

David

  • 360 Points 250 badge 2x thumb
Load the last backup from your backup folder and start again. You may have to re enter some transaction if there's been activity since that backup was made. If you're happy exit reckon and then rename your day to day file as a precaution. Remember there are multiple files. I suggest using the extension old. Finally copy the backup file you modified to the filename you use for your day to day work
Photo of Lorna

Lorna

  • 160 Points 100 badge 2x thumb
Thanks David, is there really no other solution?
Photo of David

David

  • 360 Points 250 badge 2x thumb
Your explanation of the problem was a little hard to follow. If you can undo all the transactions and be comfortable that reckon is in balance then just start over again with the transaction.


If however you undo all the transactions and the system still isn't in balance then there's obviously some issue. In that case you'll have to do what I suggested
(Edited)
Photo of Lorna

Lorna

  • 160 Points 100 badge 2x thumb
Thanks David.  I'm sorry it was hard to follow - I did my best.  
Undoing didn't work so I had to go back to a previous backup.  Unfortunately the problem's been there for a couple of months so it was a long trip back!  Good job the weather's awful - made it easier to put in the time.  Appreciate your help.