Invalid Company Information provided.

  • 4
  • Question
  • Updated 2 months ago

Invalid Company Information provided. Please check your ABN/WPN, Company Name and Branch number match those set in Reckon GovConnect Single Touch Payroll for your company.

This error came up and I have definitely logged in and connected to the ATO portal as required to.

Photo of Earl Pryor

Earl Pryor, Accredited Partner

  • 190 Points 100 badge 2x thumb

Posted 3 months ago

  • 4
Photo of Rav

Rav, Community Manager

  • 59,648 Points 50k badge 2x thumb
Hi Earl,
Check out the info in this KB article, in particular the legal name format (it must be written the same way as displayed in GovConnect STP & case sensitive) and branch number.

“Invalid Company Information error” in Govconnect STP when submitting pays from Reckon Accounts
Photo of Elise Yung

Elise Yung

  • 226 Points 100 badge 2x thumb
I have no address listed under my company name when I click on Company & Adviser Info, should this cause the same issue as I have tried every combination with Company Name and Address and nothing is working.
Hi Elise, Were you able to update your address at all please?  I'm having the issues and can't find a way to get the address updated/entered.   Can't send my payroll file through...  Thx!
Photo of Gary

Gary

  • 164 Points 100 badge 2x thumb
I have just wasted 2 hours... The business address is wrong, where they (RECKON) get this from Gawd only knows still getting the error for the company name etc.  Followed all the help files...
Photo of Rav

Rav, Community Manager

  • 59,332 Points 50k badge 2x thumb
The address details are pulled from the accounting software ie. Reckon Accounts Business, Reckon Accounts Hosted, Payroll Premier etc.

Go into the Company Information section in your respective software and input your address details. The address will then update in GovConnect STP on the next upload.
Bugger....  I'm on the phone to the ATO at the moment to see if they know anything to help. 
I've done that Rav - and it's all perfect in my Reckon program.
It doesn't carry over to the file. 
Photo of Gary

Gary

  • 164 Points 100 badge 2x thumb
Im the same, its been there for 5 years and hasn't changed, but the govt connect part still doesnt display it

Photo of Rav

Rav, Community Manager

  • 59,332 Points 50k badge 2x thumb
It will carry over on the next new file ie. new upload you carry out.

It won't be an instant update but if you've done that, press Ctrl+F5 to hard refresh the browser.
Photo of Gary

Gary

  • 164 Points 100 badge 2x thumb
worked this time  :) ..... do we receive a confirmation once submitted
(Edited)
Photo of Gary

Gary

  • 164 Points 100 badge 2x thumb
ERRROR  

The following error messages have been returned from the ATO and need to be reviewed. You may need to make changed in your accounting product before submitting again.

Error message

  • The requestId is valid, but the pull request is yet to be queued.
Photo of Gary

Gary

  • 164 Points 100 badge 2x thumb
the address that RECKON has is not the correct one, still  Its out by one suburb

Photo of Rav

Rav, Community Manager

  • 59,058 Points 50k badge 2x thumb
Gary, check out this thread for info on what that message means - https://bit.ly/2Np3KYV
Photo of Gary

Gary

  • 164 Points 100 badge 2x thumb
Rav, any idea on this error ?
Photo of Gary

Gary

  • 164 Points 100 badge 2x thumb
Thanks RAV, will check back tomorrow and see what has happened
Hi everyone, for those who have got this upload to work... (like I think I might have just gotten it to!), once you have uploaded it I think the green strip at the top with 'Success' or similar, but is there now anywhere it is supposed to show up?  How do I know it actually worked please?  I would have thought it might show on the 'list' or something.  Thanks guys.  K
Photo of Kali

Kali

  • 440 Points 250 badge 2x thumb
Hi,

I am having same issue - company address is entered in Payroll Premier (has been for 10+ years) but it's blank in GOV Connect? Is this why i am getting the invalid company error? I have done the company name fix as suggested in previous support note.
Make sure the Company name is EXACT in the 'legal name' box too, not just the company name field.  I think that's where I had my luck change.  It needed to match the gov connect EXACTLY including spaces, fullstops and capitals etc.  Once I did that, and then did a new stp file creation, and tried to upload then it updated my address on govconnect too. 
Photo of Kali

Kali

  • 440 Points 250 badge 2x thumb
Thanks Kylie - do you mean in Payroll Premier - where it says 'Company Name' (doesnt say "legal name") - do you think i need to change the 'Trading Name' as well to match or can i leave that as the normal trading name?
I use Accounts Premier 2018 - Company Information - The top box is Contact Information with Company name,  Then the second box is Legal Information 'Legal Name'.  
I would try the trading name too for what it's worth.    :)