Invoice not being included on the List when Getting all Invoices in Reckon One

  • 1
  • Question
  • Updated 3 years ago
Just want to ask on what might be the reason why my newly exported via Reckon One API invoice is not being included in the List of Invoices returned when I am getting all the Invoices on my cashbook.

The Invoice I am trying to get is the one show in the screenshot below.


Please note that, that invoice is not being included in the list returned when I am getting all invoices via https://api.reckon.com/R1/{cashbookid}/invoices.

Thanks for reading.
Photo of Jerwin Ollica Plaquia

Posted 3 years ago

  • 1
Photo of Simon Hutchinson

Simon Hutchinson, Employee

  • 2,502 Points 2k badge 2x thumb
Hi Jerwin,

By the looks of it, you have 81 invoices in the book is that correct? The API returns the first 50 results by default. To skip the first fifty you can use

$skip=50 on your api call

We are currently implementing full pagination into the api which will help out with this problem a lot more

Thanks
Hi Simon,

Thanks for this, not aware that it is not returning all invoices in the list.

Anyway, I have found an alternative aside from $skip parameter since, I need only one returned on the Invoice GET, so I used a "$filter" parameter so that the only invoice I need will be returned on the list, and also '$select' parameter since I only need one column returned on the GET method.

Thanks for your help.
Good day.

PS.
Also, can you help me with this one as well?
https://community.reckon.com/reckon/topics/decimal-values-accuracy-issue-on-invoices

I know it shouldn't be mentioned here, but I am kind of desperate to have it fixed because a week already passed since I post it. Hope you understand.

Thanks again.