Jobkeeper Payroll Items & tracking by class

  • 1
  • Question
  • Updated 1 month ago
We track income & expenditure items by class &  I cannot work out how to make this work for JobKeeper allowances (Topup, Start FNxx ). Thus when I run 'Profit & Loss Unclassified'- the figures appear there. My aim each reporting period is to have nothing on this report.


Photo of Emerald Community House, Finance Officer

Posted 1 month ago

  • 1
Photo of Linda Putland

Linda Putland, Accredited Partner

  • 20,376 Points 20k badge 2x thumb
Go to these payroll items and select - Track Expenses by Job on the first screen... now go back, unlock pays using these items... save them again - and the classes used on the pays will allocate to these allowances.  
Thanks Linda. I have now done this for all the entries (15 employees per F/N pay) and only resolved the pay cheques which included both ordinary hours and Jobkeeper top-up payments. We back paid JK for 2 April fortnights early in May and thus the only item for these employees is the Jobkeeper topup allowance under "Other Payroll items' in the Paycheque screen. 
Photo of Linda Putland

Linda Putland, Accredited Partner

  • 20,376 Points 20k badge 2x thumb
ok - so in these instances - you still need to make sure the topup allowance item has the box ticked for Track Expenses by Job - but then you need a default class for those employees - so that when there are no items at the top for you to allocate a class to - it picks up on the default class for the employee?
Yes, the 3 payroll items for Jobkeeper Allowance all have the box ticked for Track Expenses by Job
Yes, just checked that all employees have a default class entered (Edit employee, and on the Payroll and Compensation Info Tab filled in Class field) A couple didn't but fixed that now
Then went through and did unlock each pay then  'Saved & Close' again - hasn't made any difference....

I have a niggly thought that it may be something to do with Company Preferences in the EDIT menu. When I took over doing this job, the previous finance offices showed me that I had to pay any travel claims separately to the rest of the payroll.
Most payroll fortnights, I do a second payroll run for 1 or 2 employees who claim travel kms. Before I do it, I have to click on EDIT menu, select Preferences, select "Payroll & Employees" category, click on tab 'Company Preferences' and there is a field which has a tick in it labelled 'Job Costing & Class tracking for paycheque expenses'. 
When pay travel kms, I tick the option:  'Assign one class per Entire Pay Cheque
Usually, the default is 'Assign one class per Earnings Item.

Maybe this has something to do with it??
Photo of Linda Putland

Linda Putland, Accredited Partner

  • 20,376 Points 20k badge 2x thumb
When you unlocked the pays in question - did you check the top right hand corner where the Class dropdown is and make sure something was selected?
When you say  check 'top right hand corner' where the class dropdown is, do you mean on the Paycheque in 'Earnings' area ?
I do not have any item in this area for these employees as only paying JK topup as an allowance? When click in the Earnings area to select a class, get a Warning window saying "You must specify a payroll item"
The allowance area does not bring up a column for class just: Item Name, Rate and Quantity

I presume I can journal out the items from unclassified & put it to the correct classes - maybe this will be quicker??