mapi error 00000000at line 483 in sendemail.cpp

  • 1
  • Problem
  • Updated 1 year ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

I have recently had to replace my PC and have reloaded Reckon Accounts Premier Edition 2015.  I have Outlook 2013 and the default and only email product.  Have seen this question asked previously but the link that it refers you to for a solution does not work.  Can anyone please help?
Photo of June Patterson

June Patterson

  • 200 Points 100 badge 2x thumb

Posted 1 year ago

  • 1
Photo of John G

John G, Information Support Analyst

  • 27,360 Points 20k badge 2x thumb
Hi June,

Welcome to the Reckon Community.

When Outlook 2013 is open when you send the email from Reckon Accounts, does the error still occur?

regards,
John.
Photo of June Patterson

June Patterson

  • 200 Points 100 badge 2x thumb
Hi John

Yes it does

regards
June
Photo of John G

John G, Information Support Analyst

  • 27,360 Points 20k badge 2x thumb
Thanks June,

Go to Edit > Preferences > Online > Company Preferences,  and tick/untick the option Display each email when sending more than one.  Do emails now send?


regards,
John.
Photo of June Patterson

June Patterson

  • 200 Points 100 badge 2x thumb
Hi John 
Thanks so much for helping me.  Have tried updating this but alas it still will not work.

regards
June  
Photo of John G

John G, Information Support Analyst

  • 27,360 Points 20k badge 2x thumb
Hi June,

What is the operating system of your new PC?

regards,
John
Photo of June Patterson

June Patterson

  • 200 Points 100 badge 2x thumb
Hi John
It is Windows 7
regards
June
Photo of John G

John G, Information Support Analyst

  • 27,360 Points 20k badge 2x thumb
Thanks June,

Give your User and the QBDataServiceUser24 user Full Control permissions
  1. Close Reckon Accounts
  2. Right click the launch icon and select Properties > Security > Edit
  3. Highlight the user
  4. In the box Permissions for <your User>, tick the Allow box for Full Control.
  5. repeat for QBDataServiceUser24
  6. Click OK > OK to save and close.

A couple of other adjustments to make/check:
  • Make sure that the QBDataServiceUser24 also has Full control permissions to the folder in which the datafile is stored.
  • User Access Control - drop it one notch.  Its best not to have it any higher than one lower from 100% (Always Notify).

If those aspects do not fix the issue then consider the issue here:
MAPI error at line 947 in sendemail.ccp when emailing from QuickBooks through Outlook 2010.


Finally, adjust the QBW.ini file for simpleMAPI:
  1. Close Reckon Accounts
  2. Open the QBW.ini file in your installation directory (C:\Program Files (x86)\Intuit\Reckon Accounts 2015) with Notepad, scroll to the bottom and add the 2 lines:
  3.      [DEBUGGING]
  4.      SIMPLEMAPI=1
  5. Launch Reckon Accounts and in Online Preferences, untick the box Display each email when sending more than one.



regards,
John
Photo of June Patterson

June Patterson

  • 200 Points 100 badge 2x thumb
Hi John
Thanks so much for putting the time in to help me.  Have updated the User permissions but I am unable to locate QBDataServiceUser24 at all. 
Any further suggestions?


Photo of John G

John G, Information Support Analyst

  • 27,360 Points 20k badge 2x thumb
Thanks June,

Lets now be concerned with QBDataService User24 for the time being.  

Test emailing with running both Reckon Accounts and Outlook in Administrator Mode.

To run Reckon Accounts as Administrator:
  1. Right-click your Reckon Accounts launch icon and select Properties > Compatibility
  2. In the Settings section tick the box Run this program as an administrator
  3. Click Apply and then OK.
To run Outlook as Administrator:
  1. Click the Start button 
  2. Type Outlook into the Search box
  3. Hold down the Ctrl + Shift keys and in the List that opens, click the Outlook program
  4. In the popping up User Account Control dialog box, click the Yes button.

Is there any difference in emailing?


regards,
John
(Edited)
Photo of June Patterson

June Patterson

  • 200 Points 100 badge 2x thumb
Hi John
We have some progress.  I now get a line 921 error (but at least it is different) :)
regards
June
Photo of John G

John G, Information Support Analyst

  • 27,360 Points 20k badge 2x thumb
Good to hear June.

Were there any other messages?
At what point of the process did the message appear?
Did the email get to Outlook - to the Outbox where it is sitting and not sending?

regards,
John.
Photo of June Patterson

June Patterson

  • 200 Points 100 badge 2x thumb
Hi John
It happens the instant I hit the "Email" button. It is not getting the Outbox at all.

regards
June
Photo of John G

John G, Information Support Analyst

  • 27,360 Points 20k badge 2x thumb
Thanks June,

Are you able to create a PDF document through Save As PDF?
If not, what are the error messages? Screen shots will be good.  


regards,
John
Photo of June Patterson

June Patterson

  • 200 Points 100 badge 2x thumb
Hi John

Sorry but I had to go away for a few days.  Have tried saving as a PDF.  It's preferred option to save to Documents did not work (see screenshot) but it did let me save it elsewhere.  Hope that's helpful.

kind regards
June
Photo of John G

John G, Information Support Analyst

  • 27,360 Points 20k badge 2x thumb
Thanks June, that was useful.

We are looking at a permissioning issue here.  

The problem rests with the emailing end of the process as the PDF production is OK.  You should check with your IT professional why you cannot save this PDF to your own Documents folder but can to other folders.  Or is it to another drive, like a server drive?  Are you able to save other non-Reckon Accounts files to the Documents folder?

You should identify the machine (PC or Server - is it a Terminal Server?) that holds the company file and follow the steps to give QBDataServiceUser24 full permissions.  That is:
  1. Close Reckon Accounts
  2. Right click the launch icon and select Properties > Security > Edit
  3. Highlight the user: QBDataServiceUser24
  4. In the box Permissions for <QBDataServiceUser24>, tick the Allow box for Full Control.
  5. Click OK > OK to save and close.

It is possible that without that permission you cannot save that PDF to your Documents folder.  It also may have an impact on the emailing side of the process.


Hope this makes a difference.


regards,
John
(Edited)
Photo of June Patterson

June Patterson

  • 200 Points 100 badge 2x thumb
Hi John

I have a separate drive D: for saving my documents to and the C/: is solely for programs.  This may be the reason for that.

I have tried again with the Properties edit but there is no entry at all in Properties>Security>Edit for QBDataServiceUser24.  I wonder if I should uninstal the program altogether and reinstal?

Kind regards
June
(Edited)
Photo of John G

John G, Information Support Analyst

  • 27,360 Points 20k badge 2x thumb
Hi June,

Yes, that will explain why you cannot save to C:\Documents.  

I assume that with Premier you are not the only user of Reckon Accounts. 
How many users are there?
Do other users have the same problem?
On which PC or server is your company file saved?

You can add the QBDataServiceUser24 to your user list for the folder containing the company file:
  1. right-click > Properties > Security > Edit > Add
  2. in the Enter the object names to select, type in QBDataServiceUser24 and click Check Names
  3. click on Locations and select where Reckon Accounts is installed, then OK
  4. Click OK - the user should appear with a line under it to show it has been found;
  5. click OK to Save and return to the Permissions > Security screen
  6. Highlight QBDataServiceUser24 in Group or user names and then in Permissions for QBData... tick the Allow box for Full Control.  

regards,
John
Photo of June Patterson

June Patterson

  • 200 Points 100 badge 2x thumb
Hi John

I am the only user. I do use the back up to create a 2nd copy for reference only but all updates are done on my PC and the company file is saved on my PC.

I am not having a lot of luck with this at all.  I followed your instructions to the letter and get the following message.

"An object named "QBDataServiceUser24" cannot be found. Check the selected object types and location for accuracy and ensure that you typed the object name correctly, or remove this object from the selection."

Do you think that this may be something to do with my programs being on one drive and my documents and Reckon Accounts file being on another?

regards
June
(Edited)
Photo of John G

John G, Information Support Analyst

  • 27,360 Points 20k badge 2x thumb
Thanks June,

We do not need to worry about QBDataServiceUser24 while you are working in single-user mode.

Before continuing can you reboot your PC if you have not done so recently.  The test emailing again
Are you getting the same error message?
Are you able to click OK/Continue on a message and the process continues?

If the problem persists then consider the suggestions in this guide on the issue.  You may want to consult your IT professional on some of the items.  


regards,
John
Photo of June Patterson

June Patterson

  • 200 Points 100 badge 2x thumb
Hi John

Okay so tried all that and still getting the 921 error.  When I press on OK it just goes back to the Invoice I am trying to email.  Starting to think that this may be something to do with the program itself being on one drive and the Company File being on the other.  I am going to Uninstall the whole thing and reinstall it all on one drive.  Will let you know how I get on once that is done.

Thank you so, so much for all your help.  I really appreciate everything you have done and all the time you have put into trying to help me solve it.

Kindest regards
June
Photo of John G

John G, Information Support Analyst

  • 27,360 Points 20k badge 2x thumb
OK June,

Do look at this guide on the issue as in some instances addressing the email client itself is needed.  

regards,
John.
Photo of June Patterson

June Patterson

  • 200 Points 100 badge 2x thumb
Hi John

Spent nearly 3 hours today with a Tech Support guy who checked all the stuff that you had already had me do above.  He finally located the problem which was my Antivirus software.  It had blocked Reckon Accounts completely.  Ridiculous that something so simple could cause so much trouble. He located it when he was checking the Printer Controls in Reckon Accounts.  Though I would let you know so you can check that with the next poor person who has this issue.

Thank you so, so much for all your help

Kindest Regards
June
Photo of John G

John G, Information Support Analyst

  • 27,360 Points 20k badge 2x thumb
Thanks for the update June and glad to hear you are fully functional again.


regards,
John.

This conversation is no longer open for comments or replies.