My Windows 10 has done an update and now I get printer error 30 when trying to email invoice from Reckon Plus 2017

  • 1
  • Question
  • Updated 1 year ago
  • Answered
I am using Reckon Plus 2017 with Windows 10 which has been working beautifully for many months.  This morning my Windows did an update and now I can't send an invoice by email.  I am able to print and save it and manually send it from Outlook - but how frustrating!!
Photo of Tricia Dobson

Tricia Dobson

  • 102 Points 100 badge 2x thumb
  • frustrated

Posted 1 year ago

  • 1
Photo of Kevin Russell

Kevin Russell, Accredited Partner

  • 40,800 Points 20k badge 2x thumb
Are you getting an error message?
Photo of Tricia Dobson

Tricia Dobson

  • 102 Points 100 badge 2x thumb
Yes  Printer error code 30
Photo of Jay Jay

Jay Jay, Employee

  • 978 Points 500 badge 2x thumb
Hi Tricia, 

Welcome to the Reckon community, I would suggest check out the FAQ below and follow those insctructions and see if this might help you fix the problem. 
http://kb.reckon.com.au/issue_view.asp?ID=5338
Photo of Tricia Dobson

Tricia Dobson

  • 102 Points 100 badge 2x thumb
Hi Jay Jay
I had tried that but went back and went over it again.  I can now send to Outlook but it doesn't finish it off.  I have to manually go into Outlook Outbox, send it from there.  Then back to Reckon where it come up with "This action cannot be completed because the other program is busy.  Choose "Switch To" to activate the busy program and connect the problem.  It won't accept either of those two actions and after a bit comes back with this error - An internal error occurred while preparing your message.  It has not been sent.  (MAPI error code 00000000 (0) at line 947 in sendemail.cpp)
(Edited)
Photo of Luke

Luke, Technical Support Team Leader

  • 3,674 Points 3k badge 2x thumb
Hi Tricia,

Please try the following:
1. Close Reckon Accounts and Outlook
2. Set Outlook to be the default mail client in the Windows Control Panel
3. Open Outlook first then open Reckon Accounts
4. Try emailing again

If the problem persists:
1. Close Reckon Accounts and Outlook
2. Go to this location: C:\Users\Public\Documents\Intuit and open the file QBW.ini in Notepad
3. Add the below two lines at the very bottom:
    [DEBUGGING]
    SIMPLEMAPI=1
4. Save the file and close out of it
5. Open Outlook first then open Reckon Accounts
6. Try emailing again

If the problem persists:
1. In Reckon Accounts go to Edit > Preferences > Online > The box that says 'Display each email when sending more than one' please do the opposite of what it is set to (i.e. if it's ticked, untick it, if it's unticked, tick it).
2. Try emailing again.

If the problem persists, modify the Microsoft Outlook Trust Centre

Warning:  turning off this security feature may make your PC vulnerable to sending emails from unauthorized programmes. Users should check with their IT professionals and company policy on the advisability of making this configuration adjustment. 


1. Close Reckon Accounts
2. In Microsoft Outlook, click on Tools > Trust Centre > Programmatic Access
3. Click 'Never warn me about suspicious activity
4. Open Reckon Accounts and try emailing again.


Hope this helps.

Luke.
Photo of Kevin Russell

Kevin Russell, Accredited Partner

  • 40,456 Points 20k badge 2x thumb
Ordinary users shoukd never be messing around with registry entries. Is it simply beyond Reckon to make a patch to automate this process? Or maybe just fix the bug. Its been around for nigh on to ten years.
Photo of Luke

Luke, Technical Support Team Leader

  • 3,674 Points 3k badge 2x thumb
Hi Kevin,

I'm a little confused, none of the instructions above are asking the user to touch the windows registry? Modifying the Outlook Trust Centre can be risky, but this is why I have put a warning.

Also, this problem is not a bug. I can understand that you may think this is a bug because it comes up often, however, if it was a bug it would be happening to every single user.

As Tricia stated, the function was working until a Windows update was completed. Therefore, it's most likely that this update has for whatever reason altered something with Outlook's settings and therefore Reckon Accounts is unable to communicate with it sufficiently to send an email on it's behalf. You have to remember emailing from Reckon Accounts is a two way street between two different programs, so it fails it's not always our fault.

Hope this clears things up :)

Luke.
Photo of Kevin Russell

Kevin Russell, Accredited Partner

  • 40,456 Points 20k badge 2x thumb
Nevertheless Luke, the issue has been around for a while. It should be possible to fix it for good. And not to have it crop up again when the software or operating system is updated.
Photo of Tricia Dobson

Tricia Dobson

  • 102 Points 100 badge 2x thumb
Hi Luke. I tried what you suggested and it didn't work after doing the first two options but it will now email after "going to the online preference and unticking 'view each email'.  I have to wait until a box comes up for me to 'Allow' which slows things down but at least I am now emailing.  Thank you.
Photo of Luke

Luke, Technical Support Team Leader

  • 3,674 Points 3k badge 2x thumb
Hi Tricia,

That 'Allow' box is coming from Outlook.

If you want this to be turned off, then you would need to modify the Trust Centre within Outlook. Those instructions are the last ones provided in my previous post. Please read the warning before following those instructions. 

Luke.