Payroll Premier 17/18 error - cannot find C:\QPROLLV26\DATA\

  • 1
  • Problem
  • Updated 11 months ago
  • Solved
Have just upgraded to Payroll Premier 17/18. After setting the network path to a folder on the S drive (a mapped network drive), I can open the data file. Next time I open Payroll, it tells me that "Payroll Premier cannot find C:\QPROLLV26\DATA\<payroll_file>. Possible solutions are...etc, etc."

If I click "Yes" on that message, it takes me straight to the folder in the S drive that I've set.

Is there are way to stop the application from looking in the C drive first (and prevent that error)?
Photo of CoreDesktop

CoreDesktop

  • 142 Points 100 badge 2x thumb

Posted 11 months ago

  • 1
Photo of CoreDesktop

CoreDesktop

  • 142 Points 100 badge 2x thumb
A bit of info, the qpv26.ini file in C:\Payroll Premier does have the [SERVER] path value set to the network path (S:\Payroll).
Photo of John G

John G, Information Support Analyst

  • 25,360 Points 20k badge 2x thumb
Hello CoreDesktop

Welcome to the Reckon Community.

The error you are getting is related to permissions issues to the folder.  

Although not directly related to your setup this article may be of help.

Otherwise, bring back all files to one local PC and do the Set Network Path process again.  


regards,
John
Photo of Sally McIntosh, Accredited Consultant

Sally McIntosh, Accredited Consultant, Accredited Partner

  • 13,022 Points 10k badge 2x thumb
Hi John,

I am having the exact same issue with a client of mine in a multi user environment.....

Sally
Photo of CoreDesktop

CoreDesktop

  • 142 Points 100 badge 2x thumb
Hi John,

Thanks for your response. PP is already installed in C:\QPROLLV26. And I'm an admin of that server, so it won't be permissions. I can also create, delete files, etc in that folder to confirm admin status.

Note that I don't want the data files in the C drive. I want them on the network share, because that gets backed up.

Regards,
Simon
Photo of Shisir

Shisir, Employee

  • 2,368 Points 2k badge 2x thumb

Hi CoreDesktop

It looks like you are having issue as explained in this KB http://kb.reckon.com.au/issue_view.asp?ID=5331

Where you have mentioned that you have already mapped the S-Drive, but it is not clear if you have kept the payroll files in the root directory of S drive.

Given my recent own experience with this issue, I could resolve it by Mapping the S: Drive first and creating the subfolder within and storing the file in that folder.

Could you please try the same, create a subfolder in your S drive and store the file there and setup the network data path to see this new folder.

Hope this helps

Regards

Shisir

Photo of Shisir

Shisir, Employee

  • 2,368 Points 2k badge 2x thumb

Hi CoreDesktop,

Thanks for the update.

Could you try one more step for me, Check if your Payroll Premier is running as Admin or not. If it is Can you untick the option to run as admin and see if that helps.

If the issue persists, can you try to move the file to a different folder in the different mapped drive and see if that helps?

Also, can you confirm if this is Multi-user or single user version of Payroll Premier?

Regards

Shisir

Photo of CoreDesktop

CoreDesktop

  • 142 Points 100 badge 2x thumb
Hi Shisir,

I'm an admin on the server I'm running PP on. Therefore there is no option to run as admin. And it's multi-user.

Part of the issue is that PP cannot handle long folder names (anything over 8 characters, which is the limit back in the 90's). If your folder name is longer, it will replace the remaining chars with a ~ and number equalling the length of the folder name subtract 8.

This causes PP to throw an error after saving, because there is no such folder named PAYROLL~3 (in my case). If you go to set a network path again, the actual folder name will appear.

Next, if I change the folder path to the new location, it will still throw the original error, but it's looking in a different location now (in my case, the K drive). Basically I'm going around and around trying to see what combination of "setting network paths" will eventually land me on the right location.

Shisir, to make this simple - please ask your developers the following question. When you open up PP, the application will look for a particular file in a particular location. Where are these values set and how can I change them?

Regards,
Simon
(Edited)
Photo of Shisir

Shisir, Employee

  • 2,368 Points 2k badge 2x thumb

Thanks for your patience, Simon and I apologise for the inconvenience.

I have checked with our product managers and they have specified the QCompany.TPS is the file that directs the file path to the program. This file would be sitting on both your network data path and on the default Data path in the C drive of the installation folder, i.e (C:\QProllV26\Data)

So please delete both of the files, it will recreate itself when you reopen.

However, if you were not able to set the path again could you please try below recovery wizard from the start menu.

1)      Go to Start menu and navigate to Payroll Premier 2017/18 folder.

2)      Click on Payroll Premier Recovery.

3)      Select the first option ‘I am Unable to start payroll premier Up’ and next

4)      

5)      Press OK to the Prompt and Finish.

6)      

This will reset the path to default location to C drive. Now follow the steps to setup network data path back to your mapped drive and see if that helps.

If the problem persist Please try 3rd option on step 3, ‘I would like Payroll Premier to remember the last company opened’

If the issue persists, Please email your customer ID and contact details to Community@reckon.com so we can talk it through.

I sincerely apologise for this inconvenience and trust me I had the same issue myself, which was resolved by doing all those steps. And I hope to resolve this for you too. However please note mine was in Windows 10 not in Server. As you are running Multi-user, does this happen to you for all user PC or just one PC?

Regards

Shisir
Photo of CoreDesktop

CoreDesktop

  • 142 Points 100 badge 2x thumb
Hi Shisir,

Yes, that got me somewhere. These QCompany.TPS files aren't fully readable in Notepad, but the string of the network data path is recognisable.

To start, I deleted all instances of the QCompany.TPS files. Then opened up PP (I still got the error) and set the network data path. This created the QCompany.TPS file in the network path folder. After opening up PP it opened the correct file.

Thanks for your help Shisir, your persistance was appreciated.

Regards,
Simon
Photo of Shisir

Shisir, Employee

  • 2,368 Points 2k badge 2x thumb
That is great news, Simon

Thanks For the update.

Regards

Shisir