Profit and Loss by Job, single job won't show

  • 1
  • Question
  • Updated 1 month ago
We are running Reckon Accounts Premier: Contract Edition 2019.

When running the Profit and Loss by Job, we filter down to one customer/job, however nothing is coming up on the report. When we don't filter, all of the company's jobs for the selected period appears. 



Am I missing another filter somewhere?

Thank you
Belinda
Photo of Belinda

Belinda

  • 110 Points 100 badge 2x thumb

Posted 1 month ago

  • 1
Photo of Linda Putland

Linda Putland, Accredited Partner

  • 16,026 Points 10k badge 2x thumb
There could be any number of reasons this is happening?  Are you certain that there are transactions for this Customer:Job for the date period you have selected?   When you dont filter the report - do you then find the particular customer:job you are looking for?
Photo of Belinda

Belinda

  • 110 Points 100 badge 2x thumb
Hi Linda,

Yes when the full report is run all jobs are showing including the one I am looking for. I would like to run these reports for one job at a time.

Belinda
Photo of Linda Putland

Linda Putland, Accredited Partner

  • 16,026 Points 10k badge 2x thumb
ok- if it works when you have all the jobs showing - then I wonder if your filtering is correct?  make sure the name you are selecting includes the JOB and the Customer as well (and check that you havent inadvertently selected a supplier instead)?  Also try filtering for ALL accounts?
Photo of Belinda

Belinda

  • 110 Points 100 badge 2x thumb
Hi Linda,

I have selected the JOB and the Customer, if I filter to all accounts I don't get anything showing either. I find it strange that the full report works but the filtering does not, there must be an addition to the job somewhere which isn't picking up my selection.

Photo of Linda Putland

Linda Putland, Accredited Partner

  • 16,026 Points 10k badge 2x thumb
Yes, that does seem strange - if you want to email me linda@abcomputing.com.au - we can either setup a teamviewer session or you can give me access to login to the file and take a look?  cheers Linda
Hi Belinda

I would suggest it is your date range 'custom', a P&L by job should be 'all' dates to get all income & expenses no matter what date incurred.

When you do the report for all jobs, the job name would come up, but can you see any income & exp applied to the job?  Is the all jobs report coming up with all dates?

I run this report all the time, it is memorised, and not one of mine has date: custom, mine only have Accounts & Name on the filter.
Photo of Belinda

Belinda

  • 110 Points 100 badge 2x thumb
Morning, 

I can see all the jobs on the report with a custom date range and the associated expenses/income. It is just when I try and filter to one job that the report goes blank. We have tried having no date range and the one job but that didn't work either. 

Check the accounts the costs are in by drilling into the multi vendor report, maybe the costs aren't in expense accounts, and are in costs of goods?

Or email me a portable backup of the file so I can have a look for you.

Kim@kwikbook.com.au
Photo of Belinda

Belinda

  • 110 Points 100 badge 2x thumb

Thank you, as you can see by the above snippet, the COGS accounts are showing along with the other expense accounts on the multi vendor report (the expense accounts just aren't showing on the snippet).  It is quite frustrating as we have just started using Fishbowl, therefore we need to know if we can continue to use job costing or find another way to get details for each job without having to modify the report each time.
Belinda this is a P&L on all income/expense Gogs other income/expense accounts are shown in a full P&L.

However, you are talking vendor/job this is different, it only shows the income & expense accounts by default (see your first screenshot), as I said if your vendor/job costs are in COGS they will not come up on the vendor/job report unless you change the filter to include them.

When you were talking a report for all vendors/jobs this is called a multi vendor/job report and again only shows inc/exp by default unless filtered to all or selected accounts.

If you have vendor costs in accounts other than inc/exp you have to filter the accounts to say all or Multi & choose your accounts.   Once one is done, memorise the report then all you have to do is change the vendor name next time.

You can do a P&L by job report for multi vendors or individual.