RA2016 crashes after IIF import

  • 1
  • Problem
  • Updated 3 years ago

Reckon Accounts Premier 2016. Standalone single computer, fully updated
Windows 10 Professional fully updated
MS Office 2016 fully updated

I have a large item list around 6000 items. Updated weekly by importing IIF file. This has worked perfectly last 3 years

The IIF imports correctly, but RA crashes after the import is complete
There is no message to say "import successful", just the crash as below

The QBImport log file shows successful import, no errors

After re-opening Reckon Accounts, the new item list data is correct
This is consistent, every time I do IIF import

This entry in the Windows Application Event log:

I have tried the following:
Verify and Rebuild company file - same problem
Create a new test company file - same problem
Repair RA2016 - same problem
Remove and Re-Install RA2016 - same problem

Issue commenced approx 2-3 weeks ago. No changes to computer environment or software

I am guessing maybe a recent Windows or Office update may be the culprit

Because the import still works correctly, I can live with it, just a nuisance

Out of ideas, any suggestion ?

Photo of Steve Cook

Steve Cook

  • 3,340 Points 3k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Linda Putland

Linda Putland, Accredited Partner

  • 15,650 Points 10k badge 2x thumb
Have you resorted the item list before you do the import?  just something to try next time to see if its happier importing when the list is in its original order?
Photo of Rav

Rav, Community Manager

  • 89,608 Points 50k badge 2x thumb
Hi Steve,

Just a suggestion, maybe check the IIF for any illegal characters.

There's a KB here on finding 'hidden' illegal characters too which might be worth a look. The KB itself is related to POS but the principle remains the same.
http://kb.reckon.com.au/issue_view.asp?ID=5505
Photo of Steve Cook

Steve Cook

  • 3,340 Points 3k badge 2x thumb

Thanks for the help. I found the illegal character. One entry in the IIF file had a "CR" (Return) where there should be a comma. Took some searching through 6000 lines in the IIF file. Edited the offending line, then it imported correctly

Source of the error was in the download from supplier.

Interesting that the QBImport log file does not show an error ? An error here would have made it much easier to isolate the problem

Photo of Andrew

Andrew

  • 22,222 Points 20k badge 2x thumb
If only Reckon could do some 'testing' of the import file and report the error back, rather than crashing!

But glad you got it fixed in the end!
(Edited)