Reckon Accounts Personal Plus 2015 with Windows 8.1 64 bit

  • 2
  • Problem
  • Updated 5 years ago
  • In Progress
A month ago I transferred my Reckon Accounts personal plus 2015 to a new laptop running Win 8.1 64 bit.   

The program will not open as it used to in Win 7.  It always opens at the Get started window and have to tick I am already a Reckon user, and I have to pick what file I want.

I have also noticed that the the program does not run as fast as it used to on my old laptop in Win 7.

I have used all the Compatibility tools in Win 8.1.

Can anyone suggest a solution. How can I get the program to open directly at the the last account I was working on?  Also any ideas on the speed problems?  

Everything else is so much faster on my new laptop.

Photo of Alex Reid

Alex Reid

  • 226 Points 100 badge 2x thumb

Posted 5 years ago

  • 2
Photo of Diver Dave

Diver Dave

  • 6,082 Points 5k badge 2x thumb
Alex, for some unexplained reason, from Reckon, the program sometimes has troubles with long file names - greater than 8 characters.

Do you have a long file name?  If so re-name it and the problem should go away.  You'll have to re-name it manually as part of the problem is Reckon won't recognise the long file name in it's renaming menu!

There's an associated problem with the program freezing on stock price uploads.

The problem is random - I have just re-installed Reckon on two new 64 bit machines operating 8.1.  On one I can open long file names but the other not!  Go figure. 
Photo of Kevin Chamberlain

Kevin Chamberlain

  • 418 Points 250 badge 2x thumb
Hey Alex,
Had a similar problem opening the data file. I did a copy of the data  file, new name <= 8 chars, fixed. I also moved the data file to a directory on C: drive. Not sure if that helped but all good now.

Cheers,
Kevin
Photo of John Campbell

John Campbell

  • 4,092 Points 4k badge 2x thumb

As well as the local file name length, there might also be a tree name length. You could shift the database to a directory which has a shorter total name length.

Another possibility is access rights for the directory you are using. Make sure it is not a special directory name, such as c:\  c:\windows c:\users or c:\Program Files.  If you create a directory c:\quicken and place all your files as, say c:\quicken\aaa\qdata.xxx for group aaa this should work. I would keep the group name "aaa" very short with no blanks or unusual characters.

Failing these, you could try validate or super validate and check the files. ( why is super validate a hidden option ? I always forget the keys to press !!)

Photo of Diver Dave

Diver Dave

  • 6,082 Points 5k badge 2x thumb
I've not experienced a problem with the Folder name.  My files are held in D:\Quicken Files\.

Tried validating and Super Validating (CTL-ALT-SHIFT) but didn't make any difference.
Photo of Alex Reid

Alex Reid

  • 226 Points 100 badge 2x thumb
Thank you all for your help. The short file name seems to be the answer and I have persevered with having my files in D:
And guess what, after 28 years of using Quicken/Reckon I am no longer being asked if I am new to Reckon.  
Mind you I had never heard of super validate before.
Regards
Alex

 
Photo of Diver Dave

Diver Dave

  • 6,082 Points 5k badge 2x thumb
They hide Super Validating!  I haven't actually found a problem in the database using it for many years, though.

Glad you are now "accepted" as an existing user.  Now all we need is Reckon to explain what's going on and why we've reverted to DOS file length limitations.

So far no one from Reckon has said anything.
Photo of LS

LS

  • 240 Points 100 badge 2x thumb
There is more than one thread complaining that the stock update is not working.  And I certainly can confirm it is not.  I am using Windows 8 to and recently re-installed Quicken.  I have been reading some of these threads and just like myself I noticed that this problem has been acknowledged for a number of months with no response or interest from the owners.  Fortunately I am using another software in parallel for my investments and they have recently offered the use of bank accounts with their portfolio management.  I am seriously investigating this alternative and I am not interstd mentioning this software name in this forum.  I am disappointed to have to say this as I have been a very long-time user of this product but when an organisation ignores its malfunctions and fails to deliver to what was working, you have to concede...  I only wish that I can be proven wrong.
Photo of Diver Dave

Diver Dave

  • 6,082 Points 5k badge 2x thumb
Why not mention the alternative product?  Like you I'm a long time user of Quicken 9from DOS version) through Reckon and am quite frustrated at the problems, and more significantly the apparent lack of interest from Reckon.

I'm wondering if they are going to drop the product and focus on commercial software.
Photo of Alex Reid

Alex Reid

  • 226 Points 100 badge 2x thumb
I am back to square one.  After three days.Suddenly my shortened File names dropped all my stock prices and manually entered Fund prices for years gone by.
A big scare as I manage my own Super using Personal plus 2015. And have done for over 20 years.
I have recovered the data by going back to the backups of the long file names.  I need those prices.
Of course that means I now have to answer the question about being new or old to Reckon each time I open the program.
Additionally every time I close the program it asks me to backup.  It does but each time an unexpected error shows up Code 7085.  I send the messages though.

I really doubt if Personal Plus 2015 is compatible with Win 8.1 64 bit.
Please, if you have have Win 8.1 would you do the Troubleshoot Compatibility test?  Just right click on the program and you will see it there.
Attached is my Windows Screen shot report that says it is NOTcompatible.
I hope someone will prove me wrong.
Alex Reid

Photo of Diver Dave

Diver Dave

  • 5,998 Points 5k badge 2x thumb
Sounds really worrying, Alex.

So far, touch wood, haven't experienced that problem.  I saved my long file names into a separate folder before reducing it.

Have you tried renaming your recovered version?  Would be worth Validating then Super Validating (you have to Validate before Super Validating) to make sure there isn't a problem in the database itself.
Photo of John Campbell

John Campbell

  • 4,062 Points 4k badge 2x thumb

Does anyone know what "Validating" and "Super Validating" does ?

I have used it for years and it always reports that everything is OK.

It would have been better if it reported some statistics, but any change is unlikely now.

Photo of Diver Dave

Diver Dave

  • 5,998 Points 5k badge 2x thumb
I think it checks the integrity of the database.  Over  the years I've had the odd fault reported, so it is worth doing, particularly if you're experiencing problems.
Photo of Michael

Michael

  • 820 Points 500 badge 2x thumb

Hi Alex,

As, it appears, have many of the others on this site, I have 20 years of data in Quicken/Reckon, and abhor the shite service from the company, and similarly dismal product.

I was in your shoes last week, with typically no help from reckon (have you tried mortgaging the house to phone the $5/minute help line???).

I had the same problem as you on a new computer running Windows 8.1 with a new install of RPP 2013. The share data (not the banking) was missing. As you are aware, it's due to an empty .qph file. Some of my backups had .qph files of 840kb, and they worked. The others were only 1 kb, and the data obviously, was missing. So first of all, you'll need to restore from a backup with a loaded qph.

I was in the same situation as you, with RPP on the c: drive, and the functioning data files on another, my E: drive. That seems to be the problem. Shortening the data file name didn't help. I am also running it in compatability mode with Win 7.

The problem appears to be that when the program first opens, it searches for a data file within RPP, so if it is installed on the c: drive, that's where it looks. If your qdata file is somewhere else eg your d drive, it can't locate it, and brings up the introductory screen, asking if you are new to RPP, if you have a data file etc. Similarly, when it attempts to backup, it can't write to your USB (in my case), because it looks in the C: drive to find the data file, and it isn't there. I even tried copying working qdata files into the c:RPP directory but it still couldn't find them.

The way I got around this was to save a functioning copy of qdata onto my e drive, which I then backed up onto a usb stick. I then restored this file into RPP from the USB. It worked. From then on I was able to open RPP at the home screen, and restore, as it had restored the file to whatever directory it hides it's qdata files in.

Best of luck.

Michael

PS Why the f&% do the reckon mediators offer one or two (or sometimes none), opinions, then ignore any subsequent problems??? Is servicing a shonky product against their mantra?

I give them two, maybe three years before MYOB and Xero force them into bankruptcy.



Photo of John Campbell

John Campbell

  • 4,092 Points 4k badge 2x thumb

Alex,

I am actually still using RPP 2013, so don't have the problems you are having with the Australian built 2015 ! I am running RPP 2013 on Windows 8.1 64-bit, so I don't think it is the operating system.

When you say you have lost all your stock price info; could you explain a bit more.

All share price information is in a file named qdata*.qph.

 Does the qdata.qph file not exist ? ( how could it be deleted ??)

 Does it exist but is much smaller than past backups ? ( how could it possibly shrink ??)

 Or is RPP2015 not able to openthe file or recover prices ? 

( RPP could corrupt the record pointers in the .qph file; This would be a major bug in RPP 2015 that would require urgent attention by Reckon. But wait, there are no bugs in RPP !! and as we have seen, don't bother waiting for Reckon to do anything with RPP except send out the annual invoice. )

To investigate what information might be available, you could try "Investing > Security Detail View"

In the top left drop-down, select a company which you expect should have some info.

Then select "Update > Edit Price History"  This should give a pop-up window, listing the most recent prices available. If nothing is shown, then try other companies. ... Let me know what you find.

Alternatively, have you tried the utility at http://www.reltan.com/pages_main/qph_main.html and see what information is in the qdata.qph file, assuming you can find it.

If you could let us know what you find from these tests, me or some one else may be able to help further.

regards,

John


(Edited)
Photo of LS

LS

  • 240 Points 100 badge 2x thumb

See the screen below, there was a compatibility problem, but I cannot see how this compatibility problem could relate to the update.  After fixing the compatibility problem, the share update worked... the portfolios values agrees with my other product... Let's hope it will continue working.


Photo of Narky One

Narky One

  • 1,252 Points 1k badge 2x thumb
Just to help you avoid bad assumptions...

I am running RPP2015 on 64bit OS Windows 8.1 Pro with Media Center, without start up or price history issues. I do NOT have ANY of the Compatibility settings turned on for "C:\Program Files (x86)\Reckon Accounts Personal\qw.exe". I run it using a Windows Administrator account, which shows Full Control permissions in the Properties Security tab for the program. SO it is possible, at least for some, to get the result you seek.

I "upgraded" from RPP2013 (so as to get price history) to RPP2015 quite soon after it became available; my RPP2013 was in that same Win8.1Pro, also without these issues. There were a few oddities during that upgrade (there always are), but nothing major. I can't remember the details (other nightmares are more pleasant, so I tend to forget RPP ones!) - sorry.

[I gave up trying to get Home Inventory to work a few years back - it is always such a huge battle, although always possible.]

My system's  "My Documents" is not on C: (the Windows install) drive. Rather it is on "D:\Documents". The full pathname of my RPP datafile is "D:\Documents\FINANCIAL\Quicken\XXXXX.QDF". BUT I do have other RPP datafiles that are not so simply named, all of which work properly. The potentially most obstreperous is "D:\Documents\FINANCIAL\Quicken\YYYYYYY Yyyyyy YYY Yyyy\XXXXXXX Xxxxx.QDF" [spaces and caps as indicated]. The 8.3 filename of that one is "D:\DOCUME~1\FINANC~1\Quicken\YYYYYY~1\XXXXXX~1.QDF".
Photo of John Campbell

John Campbell

  • 4,092 Points 4k badge 2x thumb

Narky One,

What might help is changing your database file names from:

"D:\Documents\FINANCIAL\Quicken\YYYYYYY Yyyyyy YYY Yyyy\XXXXXXX Xxxxx.QDF"

to

"D:\Documents\FINANCIAL\Quicken\YYYYYYY Yyyyyy YYY Yyyy\qdataXx.QDF"

and all other file names (eg qdataXx.QPH) in the directory:

D:\Documents\FINANCIAL\Quicken\YYYYYYY Yyyyyy YYY Yyyy\


This would address the issue of the "file" name length, as apposed to the "tree" name length.

Using a file name of "XXXXXXX Xxxxx.QDF" has been identified as a likely problem.


John


( I looked in this thread, but could not find your latest problem)

Photo of Narky One

Narky One

  • 1,252 Points 1k badge 2x thumb
I was trying to say that I **don't** have a problem (with startup or price history) and I am using Windows 8.1. My point was to give hope to others using 8.1 that they too can/will get it working.
Photo of LS

LS

  • 240 Points 100 badge 2x thumb
My share updates are still working.  My file names are long with "&", spaces and letters included.
Photo of Diver Dave

Diver Dave

  • 6,082 Points 5k badge 2x thumb
It's bizarre, LS. I have two new 64 bit machines running 8.1 - one works fine withe Long File Names, the other won't ! I just wish Reckon would make some acknowledgement of this problem, which seems random. What are they going to do about it?