Reckon Accounts Premier Edition 2018 on terminal server (Multi-user mode) crashing in customer centre

  • 1
  • Problem
  • Updated 4 months ago
  • (Edited)
I have a problem with Reckon Accounts Premier Edition 2018 on terminal server crashing in customer centre. When it crashes, it appeared to be with two particular customer records. All I try do is view the customer by clicking on the customer record from the list. The crash doesn't happen every time, only some of the times and only with one user (User A).
If another user tries to access the same records using their login, it doesn't seem to be an issue.
I have called support three or four times now to get this resolved, but it's still an issue. Here's what's been done so far:

1. Re-build the company file.
From within the Customer Centre:
     2. Re-sort customer list.
     3. Reset Customised columns to default.
4. Created new user (User B) login with full access (Current user already had full access)

Re-build - Didn't show any errors in the data

Re-sort - Can't say if this helped at all. Problem can't be replicated each time consistently.

Reset Customised Columns - Didn't seem to help. Error eventually got reproduced.

Created new user (User B) with full access - This looked like it was going to fix the issue, but eventually a similar, but different error came up. Error was still with two records, but the records had changed. Now the records were the first and last records in the list. Like the original error, this would not happen all the time, only some times, but it would always be the first and last records that would trigger the crash.

When logged in as User A the records that crash Reckon are not the first and last records.
When logged in as User A the records that crashed Reckon were always the same records.
When logged in as User B the records would always be the first and last that caused the crash.
When logged in as any other user previously create, no crashes on any customer records.

I don't want to uninstall Reckon as it is working for all users with the exception of User A and the newly create User B accounts.

Has anyone had a similar problem or idea on what the issue could be?
It takes a good hour on hold to get Reckon support and then after they try something, it looks to be working. But because the error doesn't happen all the time or straight away, can't tell and end up getting off the phone, only for the problem to re-surface some time after.

Photo of GITech

GITech

  • 80 Points 75 badge 2x thumb

Posted 4 months ago

  • 1
Photo of Linda Putland

Linda Putland, Accredited Partner

  • 15,606 Points 10k badge 2x thumb
Howdy... please try this:
Open a Write Cheque window - click on the Payee Field - press Ctrl+L on the keyboard - this opens a list of all names - click the Names button at bottom left and choose Resort List from here...  
now open the Item List - Resort this list
now open the Accounts List - Resort this list
Now Rebuild the file 3 times - dont ask why, but 3 times is the magic number
now open the file and press Ctrl+1 on the keyboard - then Ctrl +2
Go to the Open tab
Click on QBWIN.log
Go to the end of the text... and start searching upwards and reading what was done during the build process... look for words such as "duplicate" and "corrected

if you know the names of the offending customers - you could also try renaming them before running the rebuilds.. eg put a full stop at the end of the name or some other notation.

I suspect the first rebuild did not fix because the list wasnt sorted fully like it is with my first step above... and if it still occurs then its probably because the customer centre shows all the transactions when you click on a customer name... try click another customer - then choosing to show say just last years entries... then try clicking the offending customer - if that works - then the problem will be corruption in a transaction that isnt in the last year period - so you could use trial and error to narrow it down to which transaction is causing the corruption.

good luck!
Photo of GITech

GITech

  • 80 Points 75 badge 2x thumb
Hi Linda,
Thank you for you help.
I tried the suggested fix and we are still getting the same error.
I made sure to follow each instruction and did the rebuild 3 times.
The error log didn't show any "duplicate" or "correct" entries.
Here is the log file output:
########################################START LOG FILE############################################################

QBWINDLL.c (255) :  MESSAGE: Sat Jun 22 16:18:46 LVL_ERROR--Returning NULL QBWinInstance Handle
QBWINDLL.c (255) :  MESSAGE: Sat Jun 22 16:18:46 LVL_ERROR--Returning NULL QBWinInstance Handle
QBWINDLL.c (115) :  CHECKPOINT: Sat Jun 22 16:18:46 CQBWinApp::InitInstance -- Initializing QBWinInstance Handle
QBWINDLL.c (145) :  CHECKPOINT: Sat Jun 22 16:18:46 CQBWinApp::InitInstance completed
QBW.c (221) :  CHECKPOINT: Sat Jun 22 16:18:46 CQuickBooksApp::InitInstance Initializing Quickbooks (AfxOLE)
QBW.c (225) :  CHECKPOINT: Sat Jun 22 16:18:46 Operations Started
QBW.c (443) :  CHECKPOINT: Sat Jun 22 16:18:46 Calling MauiMain for further initialization
fsd.cpp (93) :  MESSAGE: Sat Jun 22 16:18:46 LVL_ERROR--FSDInitMod ServiceManager.SetCurrentChannel HRESULT = -2147467259
DBManager.cpp (3863) :  CHECKPOINT: Sat Jun 22 16:18:47 Database Server cache size = 64M
DBManager.cpp (3865) :  CHECKPOINT: Sat Jun 22 16:18:47 Database Server initial cache size = 32M
DBManager.cpp (3659) :  CHECKPOINT: Sat Jun 22 16:18:47 Database Server starting. Startup String = C:\PROGRA~2\Intuit\RECKON~3\QBDBMgr.exe -n QB_ReadOnly_engine_27 -qs -gd ALL -gk all -gp 4096 -gu all -ch 16M -ti 0 -c 4M -x none -ct- -qi -qw  -tl 120 -oe "C:\Users\cheryl\AppData\Local\Intuit\QuickBooks\Log\27.0\DBStartup.log" -r 
QBW.c (450) :  CHECKPOINT: Sat Jun 22 16:18:54 MauiMain finished successfully
QBW.c (632) :  CHECKPOINT: Sat Jun 22 16:18:54 Initializing Add-Ins
QBW.c (471) :  CHECKPOINT: Sat Jun 22 16:18:54 Initializing COM-dependent components
QBW.c (498) :  CHECKPOINT: Sat Jun 22 16:18:54 CQuickBooksApp::InitInstance exiting
QBW.c (568) :  CHECKPOINT: Sat Jun 22 16:18:54 QuickBooksApp::Run
load.c (2268) :  CHECKPOINT: Sat Jun 22 16:18:54 InitSystem
load.c (10507) :  CHECKPOINT: Sat Jun 22 16:18:54 Won't be using database server on local machine - no hosting change needed.
load.c (2426) :  CHECKPOINT: Sat Jun 22 16:18:54 InitSystem Check file location and move
load.c (2497) :  CHECKPOINT: Sat Jun 22 16:18:54 InitSystem Open DB Session[4]
formwin.c (2520) :  CHECKPOINT: Sat Jun 22 16:18:54 Creating form: formID=15920, itID=0
formmgr.c (604) :  CHECKPOINT: Sat Jun 22 16:18:54 Creating a MODAL form: formID=15920, itID=0
DBManager.cpp (3863) :  CHECKPOINT: Sat Jun 22 16:19:00 Database Server cache size = 64M
DBManager.cpp (3865) :  CHECKPOINT: Sat Jun 22 16:19:00 Database Server initial cache size = 32M
DBManager.cpp (3659) :  CHECKPOINT: Sat Jun 22 16:19:00 Database Server starting. Startup String = C:\PROGRA~2\Intuit\RECKON~3\QBDBMgr.exe -n QB_ReadOnly_engine_27 -qs -gd ALL -gk all -gp 4096 -gu all -ch 16M -ti 0 -c 4M -x none -ct- -qi -qw  -tl 120 -oe "C:\Users\cheryl\AppData\Local\Intuit\QuickBooks\Log\27.0\DBStartup.log" -r 
filepath.cpp (223) :  MESSAGE: Sat Jun 22 16:19:07 LVL_ERROR--Got unexpected error 5 in call to NetShareGetInfo for path \\servername\Quickbooks\Quickbooks\Quickbooks 2018\Database11.qbw
load.c (8950) :  CHECKPOINT: Sat Jun 22 16:19:08 Max users was set from SKU publisher and the value is = 5
DBManager.cpp (3375) :  CHECKPOINT: Sat Jun 22 16:19:08 Current Database Server version = 9.0.2.3267
FileMgr.cpp (274) :  CHECKPOINT: Sat Jun 22 16:19:08 Company file Q:\Quickbooks\Quickbooks 2018\Database11.qbw is open using database server:QB_server_27.
load.c (2504) :  CHECKPOINT: Sat Jun 22 16:19:08 InitSystem Open DB Session[4] Succeeded
QBPRINT.c (2522) :  CHECKPOINT: Sat Jun 22 16:19:08 Detecting if Terminal Service is running.
QBPRINT.c (2533) :  CHECKPOINT: Sat Jun 22 16:19:08 Terminal Service is running
PermissionManager.cpp (4294) :  CHECKPOINT: Sat Jun 22 16:19:11 A new permission context is added for QuickBooks
load.c (4062) :  CHECKPOINT: Sat Jun 22 16:19:13 InitSystem: Open System
load.c (4070) :  CHECKPOINT: Sat Jun 22 16:19:13 InitSystem: Open System succeeded
MemoryManagerWin32.cpp (578) :  CHECKPOINT: Sat Jun 22 16:19:13 Shrinking by realloc ptr(0x0a57f530), oldSize(16), newSize(4)
MemoryManagerWin32.cpp (578) :  CHECKPOINT: Sat Jun 22 16:19:13 Shrinking by realloc ptr(0x0a57f650), oldSize(16), newSize(4)
SBRPaymentSummary.c (138) :  CHECKPOINT: Sat Jun 22 16:19:13 GetAppSetting (GOVCON_PS) = (ON)
load.c (4415) :  CHECKPOINT: Sat Jun 22 16:19:13 InitSystem: successful completion
formwin.c (2520) :  CHECKPOINT: Sat Jun 22 16:19:13 Creating form: formID=13600, itID=1
formmgr.c (604) :  CHECKPOINT: Sat Jun 22 16:19:14 Creating a MODAL form: formID=13600, itID=1
SBRPaymentSummary.c (138) :  CHECKPOINT: Sat Jun 22 16:19:14 GetAppSetting (GOVCON_PS) = (ON)
SBRPaymentSummary.c (138) :  CHECKPOINT: Sat Jun 22 16:19:23 GetAppSetting (GOVCON_PS) = (ON)
formwin.c (2520) :  CHECKPOINT: Sat Jun 22 16:19:23 Creating form: formID=2551, itID=2
oaerror.c (110) :  CHECKPOINT: Sat Jun 22 16:19:24 OAstdMethodRet (80040600)
oaerror.c (110) :  CHECKPOINT: Sat Jun 22 16:19:24 OAstdMethodRet (80040600)
filepath.cpp (223) :  MESSAGE: Sat Jun 22 16:19:24 LVL_ERROR--Got unexpected error 5 in call to NetShareGetInfo for path \\servername\Quickbooks\Quickbooks\Quickbooks 2018\Database11.qbw
SBRPaymentSummary.c (138) :  CHECKPOINT: Sat Jun 22 16:19:24 GetAppSetting (GOVCON_PS) = (ON)
formwin.c (2520) :  CHECKPOINT: Sat Jun 22 16:19:32 Creating form: formID=28300, itID=3
formmgr.c (604) :  CHECKPOINT: Sat Jun 22 16:19:32 Creating a MODAL form: formID=28300, itID=2

#########################################END LOG FILE#############################################################

Any other idea's on what could be cause the issue?
Thank you for your help.

Photo of Linda Putland

Linda Putland, Accredited Partner

  • 15,606 Points 10k badge 2x thumb
ok - so some other questions to try and narrow this down.. 
1.  Has this worked fine for User A at any time in the past?  if yes, then can you pin down when it started to go wrong?  
2.  Does User A have the same Network/TS permissions/rights as other users on the network? (not Reckon permissions)
3.  Thinking it could be corrupt records - if you run a Trial Balance Report for ALL dates - do the debits and credits match exactly?  if not, then possibly a corrupt transaction that needs to be fixed/deleted/reentered?
4.  Have you tried - making a copy of the file, then moving that copy to a different location (either on the server or even on another machine - then open the file with user A and see if it still crashes?

I am no expert on Terminal Services but it seems you need to narrow down whether its a TS specific issue or just a datafile issue?