Reckon GovConnect MFA not working

  • 2
  • Question
  • Updated 1 month ago
Hi,

I've just signed up for an online account and have been trying to set up the Reckon GovConnect. However, the MFA code is always coming up with the error "Please type correct code".

I've successfully connected it to the android version and tried a few of the codes there which didn't work and also tried the chrome extension just in case it had somehow scanned incorrectly on my mobile. I've attached an image which shows the issue.

Is there a workaround for setting it up without MFA?
Photo of Ben

Ben

  • 260 Points 250 badge 2x thumb

Posted 5 months ago

  • 2
Photo of Rav

Rav, Community Manager

  • 63,388 Points 50k badge 2x thumb
Hi Ben,
Thanks for raising this and sorry to see you're having some trouble in getting set up.

Is this the first time you're logging into Reckon GovConnect STP to get setup or have you tried previously?
I know this might sound a bit left field but is your PC's timezone setup correctly? This can have an impact on MFA being accepted.

Have you previously set up a MFA code to this Portal account or is it the first time you're attempting it?
(Edited)
Photo of Ben

Ben

  • 260 Points 250 badge 2x thumb
Hi Rav,

Thanks for the quick reply!

This is my first time trying Reckon GovConnect. I can confirm my PC's time zone is set correctly (as is my mobile's).

This is also the first time I'm setting up MFA for this account.
Photo of Rav

Rav, Community Manager

  • 62,284 Points 50k badge 2x thumb
Danielle,
If you're using the Google Authenticatior app on your phone, go into the Settings > Time Correction for codes > Sync Now

This is the most common cause for issues as the time settings on your device is not matching with Google's servers which generate the code and as such is not being recognised.

Can you please try the above and see how you go.
Photo of Daneille Gittoes

Daneille Gittoes

  • 124 Points 100 badge 2x thumb
I have fixed this - thanks
Photo of Wendy

Wendy

  • 330 Points 250 badge 2x thumb
I am having the same problem but with my pc. Keeps telling me the code is incorrect
(Edited)
Photo of Susan Ahern

Susan Ahern

  • 60 Points
Hi, I have a new phone so had to reinstall authenticator. Finally have it working but the code will not be accepted by Reckon GovConnect? Is this because maybe it was setup originally with my work email and the google auth.. is setup now with my private email?
(Edited)
Photo of Rav

Rav, Community Manager

  • 62,284 Points 50k badge 2x thumb
Susan,
Did you revoke the original MFA that was registered before setting up MFA on your new phone?
Photo of KristianWenckowski

KristianWenckowski

  • 182 Points 100 badge 2x thumb
Hi Rav,

I'm having exactly the same problem.

Regards,

Kristian
Photo of Leshelle

Leshelle

  • 452 Points 250 badge 2x thumb
I had this problem too. I had only set up MFA on my phone at that stage. Once I set it up on my computer as well, it worked! 
Photo of KristianWenckowski

KristianWenckowski

  • 182 Points 100 badge 2x thumb
Thanks Leshelle, unfortunately I can't set this up on my phone either.
Photo of Jay Jay Li

Jay Jay Li, Employee

  • 280 Points 250 badge 2x thumb
Hi All,
For everyone who is having this issue where you enter a valid code but the MFA saying its incorrect please make sure your android/apple device is up to date and make sure the time is sync to your local time before try again. and if you are on google chrome, please remove the authenticator and delete all history and cached page and reset the browser and reinstall authenticator and try again. 
Photo of KristianWenckowski

KristianWenckowski

  • 182 Points 100 badge 2x thumb
Hi jay jay, tried on my phone, surface pro and desktop still with no luck. Not sure what to do?
Photo of Rav

Rav, Community Manager

  • 59,078 Points 50k badge 2x thumb
Hi Kristian,
Can you please shoot me an email with your Reckon One user name/email address to community@reckon.com. I'll ask our devs to take a look to see if there's anything wrong on Monday. 
Photo of Alisha Burns

Alisha Burns

  • 60 Points

I am also having the same problem, setting up for the first time and have tried google authenticator on a couple of devices and checked time zones but no luck.


Photo of margaret

margaret

  • 240 Points 100 badge 2x thumb

I am having problems with MFA authenticator, I went through the whole process and set it all up through my android phone and it was all working, but I accidently deleted the app from my phone and now have lost all the details for our account. I have reinstalled the app but cannot get reckon portal services back. Cause in the portal services it is asking me to verify MFA but I cant.   


Try going into the settings in the Authenticator and synching with google chrome.  I did that and it worked.
Photo of KristianWenckowski

KristianWenckowski

  • 182 Points 100 badge 2x thumb
Thanks, this worked also for me.
Photo of Karina Clarke

Karina Clarke

  • 162 Points 100 badge 2x thumb
I have also accidently deleted the Reckon Portal Services account from Iphone Authenticator and I cannot reset up with out the Bar Code for my MFA code, I can do a manual entry but it keeps asking for key number...Any help please
Photo of Rav

Rav, Community Manager

  • 57,754 Points 50k badge 2x thumb
Hi Karina,
Thanks for getting in touch,
If you've deleted the app for any reason then you cannot reset or remove the MFA.
As there are stringent requirements around MFA as set by the ATO for Single Touch Payroll, you will need to contact our support team so that you can be verified as the account owner and MFA revoked.
Photo of stef

stef

  • 90 Points 75 badge 2x thumb

Hi I am having the same problem with authenticator as I deleted the app and I also having the issue when I upload the stp file it says company details don't match . I have checked everything and the only difference I can see is that my reckon portal company details doesn't have an address. I cant edit this. I was on hold with support for 4 hours yesterday and am still on hold this morning. Very stressful

Photo of Jovie Gianotti

Jovie Gianotti

  • 112 Points 100 badge 2x thumb
I also encounter the same problem. I end up deleting MFA from my Iphone. When I redo resetting up MFA from my phone it will asked  me a barcode. Dont know how to get new barcode.
Photo of stef

stef

  • 90 Points 75 badge 2x thumb

Ok so unfortunately the only way around this is to get support to revoke mfa off the reckon portal and go through set up your MFA again this gives you the QR bar code again

(Edited)
Photo of Sari

Sari

  • 304 Points 250 badge 2x thumb
Hi Rav, you've been kept busy with this!
I have STP all set and working ! So my next step was to share with my manager so she can do this while I am on leave. We've downloaded the app to her Apple phone and I've added her as admin on the reckon portal. 
The problem now is the authenticator wants a 7 digit code which we don't have? The QR code is not there for her.

Sari'
Photo of Sari

Sari

  • 304 Points 250 badge 2x thumb
Yes she has. I am the admin and I have added her and shared. She has her own account and can log in. The issue has arisen, I believe, because when the QR Code came up we used MY phone and app to register her. I'll be away soon so have installed the app on her phone and deleted the account off mine - bad move I know! So now she cant get an MFA code up to complete login.
Photo of Rav

Rav, Community Manager

  • 62,622 Points 50k badge 2x thumb
Thanks for that, makes it a lot clearer, I'm guessing you didn't revoke the MFA from her Reckon Portal account BEFORE deleting the MFA entry from YOUR Google Authenticator right? :( 

If that's the case, then the MFA that has been set on her Reckon Portal account needs to be removed so that she can set up her own MFA.
Usually removing/revoking MFA can be done through the Reckon Portal settings provided that you have the original authenticator, but it doesn't sound like its the case anymore unfortunately since you removed it from your app.

From here, our support team will need to remove the MFA from her Portal account instead. There are some pretty strict security controls around this and its not instantaneous so she'll need to call our Support team ASAP to get this process started.
Photo of Sari

Sari

  • 304 Points 250 badge 2x thumb
Thanks Rav, you are correct. Sadly I removed the account from my phone for her. I see now how it all works and was trying to avert a lengthy call to Support as I know that can take hours. Is there a better phone number to try for this?
Photo of Rav

Rav, Community Manager

  • 62,622 Points 50k badge 2x thumb
Apologies for that, I know its been a bit of a struggle over the last couple of weeks or so to get in touch with the Support team but its looking a lot better now. I just checked the board and the wait times right now (11:20am) are all pretty reasonable, there is a bit of a wait on the Reckon One line but all others are looking ok. 
Photo of Sari

Sari

  • 304 Points 250 badge 2x thumb
Thanks for your help Rav, I'll give it a go
Sari