Reckon GovConnect - STP Upload - Company Information Valid then nothing.

  • 2
  • Problem
  • Updated 2 months ago
  • (Edited)
After fixing the "Please check your ABN/WPN, Company Name and Branch number" error I was getting by modifying my STPEXPORT file to have the [PayerCompanyDetails]->[CompanyName] to match the Entity Name listed on my ABN lookup. I have also made this correction in my [Company Information]->[Company Name] field in Payroll Premier.

Upon uploading the corrected file I am now receiving the message "Company information is valid" in place of the previous error message. (This message is being received by the web browser at the top of the page contained in a div with type="error").

The Reckon GovConnect STP system is not proceeding to load the uploaded pay event into the pay event table as was demonstrated in the Single Touch Payroll Webinar.
Photo of Tobias K

Tobias K

  • 184 Points 100 badge 2x thumb

Posted 3 months ago

  • 2
Photo of Rav

Rav, Community Manager

  • 59,770 Points 50k badge 2x thumb
Hi Tobias,
Apologies for the delay in getting back to you.

Has this been sorted for you as yet?
Photo of Isabel Noeth

Isabel Noeth

  • 82 Points 75 badge 2x thumb
I am struggling with this too.
Photo of Tobias K

Tobias K

  • 184 Points 100 badge 2x thumb
As of 11:07 am on 03/07/2018 I am still having this issue and as such am unable to complete the STP process.
(Edited)
Photo of Isabel Noeth

Isabel Noeth

  • 82 Points 75 badge 2x thumb
I have been on the phone with Reckon and he had me check and re-enter company details in Reckon and on GovConnect, Still the same error!!! 
Photo of Rav

Rav, Community Manager

  • 59,770 Points 50k badge 2x thumb
Hi guys,
Can I please get you to send me your JSON export files to me in an email and I'll get our STP expert to take a look. 
community@reckon.com
(Edited)
Photo of Rav

Rav, Community Manager

  • 59,770 Points 50k badge 2x thumb
Hi guys,
Thanks for sending those through

Isabel -
It looks like you don't have a branch code set in GovConnect STP, can you please remove any branch codes that appear in Preference settings in your Reckon product so that it matches.

Tobias -
I've just sent you an email reply, apologies but just need one further piece of info.

Thanks guys
Photo of Tobias K

Tobias K

  • 184 Points 100 badge 2x thumb
Issue is resolved. Branch was left blank during setup of Reckon GovConnect.

My Payroll Premier was setup with a branch number of 001. 
(This can be found in Payroll Premier  by opening [Preferences] and going to the [Files] tab. The Branch No. is listed int he section titled Empdupe & SAFF.

Corrected by creating a new company with GST branch as 1.
(Click Buy Now->Reckon GovConnect to setup additional company)
Photo of Brooke

Brooke

  • 204 Points 100 badge 2x thumb
I tried to fix this issue by following the instructions above "(Click Buy Now->Reckon GovConnect to setup additional company)" but got an error message "unable to create subscription with Stp). I think I need to delete my Reckon portal account completely and start again but I'm not sure how!
Photo of Peta Lane

Peta Lane

  • 170 Points 100 badge 2x thumb
I am getting the invalid ABN Company name message.  I have checked in payroll premier and the company name and ABN are correct.  I was set up with a branch 001 but deleted that however no it says 000.  what can i do next?  Also it seems to be creating to STPEXPORT files, one with a series of numbers and one without.  which is the correct one to upload?  i've tried both
Photo of Nicky Wray

Nicky Wray

  • 902 Points 500 badge 2x thumb
After making changes in the company info file (case sensitive) how can I recreate the STP report to export? 
(tried deleting all the pays and re-entering them, the report that was created only picked up one)
Photo of jenny

jenny

  • 70 Points
After making changes to my company file I have successfully uploaded 1 file (most recent) but have 2 older files to submit.  How can I do this?
Photo of Nicky Wray

Nicky Wray

  • 902 Points 500 badge 2x thumb
HI, I am now getting "access denied" error messages in payroll premier 2018/2019.
We also have Accounts Premier accounting which has a payroll module but it doesn't appear to be STP usable. Is this correct? Thank you
Photo of jenny

jenny

  • 70 Points

perseverance... I have resaved my STP company file, saving over the top of the original and have now been able to transmit them both ... Woohoo

Photo of Sylvia Daniels

Sylvia Daniels

  • 110 Points 100 badge 2x thumb
I am having the same problem. After fixing an email issue I now receive an error message "Company Information is valid" and the nothing else.  I have checked Payroll Premier and the information is correct, except that the GovConnect site does not have an address noted.
We do not have the option for a branch number in the Company Info panel.  Any help greatly appreciated.
When exporting my files I also end up with two files not one.
(Edited)
Photo of Sylvia Daniels

Sylvia Daniels

  • 110 Points 100 badge 2x thumb
All sorted - deleted branch number
Photo of Peta Lane

Peta Lane

  • 170 Points 100 badge 2x thumb
Email issue?  I can't email payslips, is that the issue you had?  if so PLEASE tell me how you fixed it?
Photo of Sabrina

Sabrina

  • 70 Points
Hi, I have also received this error message when trying to load file, but the ABN and company names appear to match.  How do I check the branch number on the Reckon site?
Photo of Isabel Noeth

Isabel Noeth

  • 82 Points 75 badge 2x thumb
This is what I had to do to fix ours. 

Go into reckon, check under Company and then Company information. In here you will have your legal name ABN and next to your ABN a box with 3 numbers in. ours was 001. I had to delete these numbers. Re- download the STP file out off Reckon and then tried to upload it again into GovConnect. It worked ! Just keep trying!
Photo of Annabelle Tanzmann

Annabelle Tanzmann

  • 92 Points 75 badge 2x thumb
Isabel I had this problem too.I removed the batch number and was able to process successfully. I then went back into the company information and the batch number was there again,Does anyone know how to remove it permanently ?
(Edited)
Photo of Nicky Wray

Nicky Wray

  • 902 Points 500 badge 2x thumb
Reckon have advised me that you have to change it manually every time you go into Payroll Premier and that the GovConnect portal will be updated (when?) to address the issue
Photo of Nicky Wray

Nicky Wray

  • 902 Points 500 badge 2x thumb
Here is another issue with the branch number. I opened the payroll premier program, changed the branch to 000, entered the pays, processed the pays, exported the file. When I checked the branch - its has defaulted back to 001 which must have happened in the process pays?? Tried to upload to the portal and of course it doesn't work. Now have to wait for the 45 mins it takes to get the STP report back because that's how long Payroll Premier takes to change itself to date paid!!!!!!!
Photo of Annabelle Tanzmann

Annabelle Tanzmann

  • 92 Points 75 badge 2x thumb
Thank you Nicky that is exactly the issues i have had today and had to do the same process. I hope that GovConnect rectify this soon .
Photo of Peta Lane

Peta Lane

  • 170 Points 100 badge 2x thumb
Make sure the company name is EXACTLY the same as the company is registered.  Check ABN lookup to confirm.  it is also case sensitive, so it needs to be exactly the same.  I also had to delete the branch number. Delete the previous STP file and re-download.  it took me a couple of times to check, recheck but i got it in the end.  
Photo of Sabrina

Sabrina

  • 70 Points
Thanks for that Peta, found that the case sensitive was the issue
Photo of JANE

JANE

  • 80 Points 75 badge 2x thumb
Please can you advise where we can see the branch number that everybody is referring to? All I can see is the company name and ABN- do you have to put the address in ? thank you
Photo of Brooke

Brooke

  • 204 Points 100 badge 2x thumb
Hi Jane - you can't see the branch number in Reckon Portal, only in the Reckon company information in your file. It seems that if you didn't choose a branch number when you set up your Reckon portal, you will need to delete the branch number in the Reckon company information in your file (in Reckon Accounts Enterprise:Professional Services Edition 2018 Desktop version you go to Company / Company Information - the 3 digits following the ABN are the ones you need to delete). Apparently it will work then - at least it seems to for other people - it didn't for me so something else must still be going on! I only got ours to work using someone else's portal log in.
Photo of Peta Lane

Peta Lane

  • 170 Points 100 badge 2x thumb
Agreed, if you didn't set one up in the portal it wont show there.  in my case, payroll premier, the number 001 was put in as the branch number and i had to delete that and save in premier.  i did this a couple of times but finally...
Photo of luise lonsdale

luise lonsdale

  • 70 Points
Hi All, also having the same issue..
I have checked preferences, deleted the branch number, checked the company name in Payroll Premier to match the ABN lookup and GovConnect (including same uppercase/lowercase letters).
i have exported the file again and and tried to upload but still getting the same error. 

Anyone know of anything else to try?
Photo of Brooke

Brooke

  • 204 Points 100 badge 2x thumb
Maybe try using a different web browser? I'm not sure which of the below things ended up being the magic bullet but these were all the conditions that ended up getting ours to work :
  1. ensured our software number (accessed via the portal under company & advisor info) was registered with ATO Access Manager
  2. logged on to the Reckon portal using internet explorer
  3. logged on as a different user who had set up the branch number so it matched the company information in our Reckon file (I didn't set one up and deleting it in the Reckon file didn't work)
  4. ensured that the legal name in our Reckon file matched EXACTLY the ABN lookup information for our company including being case sensitive
  5. logged on on a computer with a registered Auskey (I'm not sure if this makes any difference at all!)
Photo of luise lonsdale

luise lonsdale

  • 70 Points
Hi Brooke,
Thanks - i hadn't registered it with ATO access manager and have now done so. I've tried again but still coming up with the same error. 
I am using google chrome which may be the issue?
I tried using internet explorer but when I click on the login in GovConnect portal it just comes up with a blank page. It makes sense that it would work on internet explorer as this is the only browser which i can login to ATO Business Portal using my Auskey.
Not sure why the GovConnect portal login isn't loading though... 
Photo of Peta Lane

Peta Lane

  • 170 Points 100 badge 2x thumb
I also had to make sure that in my preferences on the printing tab the print by says Date Paid not Pay end date.  May be ?
Photo of Kylie K

Kylie K

  • 100 Points 100 badge 2x thumb
Hi Brooke thank you!  I was having trouble and all it was was that the legal name was not in capital letters - your post resolved this for me.
(Edited)

This conversation is no longer open for comments or replies.