Reckon One STP pay file not showing correcting payment from and payment to dates and gross is $0

  • 4
  • Question
  • Updated 3 weeks ago
I am new to Reckon One STP reporting and am doing my first pay run today.  I have successfully created a pay run but when selecting the pay run in the single touch payroll tab (in order to sent to GovConnect) the Payment From and Payment To dates are both showing as today's date only and the Gross(YTD) is $0 for all staff.  The PAYG(YTD) is correct.  I have entered the pay from and to dates correctly in the original pay run as 25/6/19 to 8/7/19.  
Photo of Helen Harding

Helen Harding

  • 100 Points 100 badge 2x thumb

Posted 2 months ago

  • 4
Photo of Keith

Keith

  • 188 Points 100 badge 2x thumb
I've just checked our submission yesterday and can also confirm Gross payments is showing as 0.00 through mygov on an employee account.

Is this happening because the pay period is up to 30/6 Sunday, but pay is not being deposited until 1/7. Under ATO rules that payment falls into this financial year 19/20.

https://www.ato.gov.au/business/payg-withholding/payg-payment-summaries/

Is this an issue with the STP submission highlighted because the FYE was on a Sunday?
(Edited)
Photo of Keith

Keith

  • 188 Points 100 badge 2x thumb
Is this forum being moderated as there seem to be lots of questions being asked and not many responses.

Tried again to get the first payrun Gross Amounts to go through to STP but it still reports 0 as YTD figure despite the pay date being 1/7, and all payroll associated journals are dated 1/7.
(Edited)
Photo of Peter Walton

Peter Walton

  • 298 Points 250 badge 2x thumb
I have the same problem. The first pay end date 30/6/19 pay date 1/7/19 shows zero gross but other deductions correct, but the summary at the top shows the correct gross but it is not allocated to the employees.  I have now done the second payrun and the super and PAYG YTD figures are correct but the gross figure is still only the latest pay. The payslips show the correct YTD figures.
(Edited)
Photo of Ken Lee

Ken Lee

  • 230 Points 100 badge 2x thumb
Hi Keith,
I had the same problem and managed to find a workaround. This was confirmed by Reckon Technical support only today.

There appears to be a problem when this scenario exist. 
Pay Ending Date: 30-June-2019 (Sunday)
Payment Date : 1-Jul-2019 (Monday)

Not sure if it works for your scenario... The Pay Ending Date and Payment date must be in the new FY

Solution:

I undo the pay run and did an Unscheduled Pay run with the following parameter

Pay Ending Date: 1-Jul-2019

Payment Date : 2-Jul-2019

I just verified in GovConnect that my Gross (YTD) is now correct. 

(Edited)
Photo of Keith

Keith

  • 188 Points 100 badge 2x thumb
Yeah I found the same thing, I was able use pay period up to 30/6 with a Paid Date of 2/7 and it worked fine, not good really.

Thanks for posting back. It would be good if reckon could provide some support huh.

Have since done 2nd payroll for next week and that seems to be back to normal so it just didn't seem to like this first payrun being from 1/7 - 1/7 (shown in STP), that's what made me think to try a paydate of the 2nd...
(Edited)
Photo of Peter Walton

Peter Walton

  • 298 Points 250 badge 2x thumb
surely they could do a patch to make STP reporting consistent with payslips. I don't really want to undo past payruns to change dates, as last time I did that I ran into more problems.
(Edited)
Photo of Keith

Keith

  • 188 Points 100 badge 2x thumb
Totally agree we shouldn't be using work arounds on important topics like Payroll. There could be a lot of folks not even noticing the Gross is 0, I missed it at first!
Photo of Mandy Bonavita

Mandy Bonavita

  • 90 Points 75 badge 2x thumb
I just tried changing the date parameters and I am still getting a 0.00 amount
Photo of Peter Walton

Peter Walton

  • 298 Points 250 badge 2x thumb
would be good to get a response from Reckon representative!
Photo of Rav

Rav, Community Manager

  • 84,560 Points 50k badge 2x thumb
Hi guys,
Really sorry this one went under my radar.
Can I just confirm, do you all have the pay date set as 1 July 2019 when you encounter this?
Based on some of the discussion above, it seems so but I just want to confirm to establish the recurring pattern among everyone.
Photo of Keith

Keith

  • 188 Points 100 badge 2x thumb
Hi Rav,
Yes the $0 Gross figure was reported (STP) when the Payment Date was set to 1.7.2019, although the Super and PAYG was reported (non-zero) through STP.
(Edited)
Photo of Peter Walton

Peter Walton

  • 298 Points 250 badge 2x thumb
pay week ended 30/6/19 date of payment 1/7/19. Payslips show correct YTD amounts but STP shows zero for the gross payments, but correct amounts for PAYG and Super. Have done the second pay for the financial year and still missing the first pays gross but all other amounts correct.
Photo of Mandy Bonavita

Mandy Bonavita

  • 90 Points 75 badge 2x thumb
I am having quite a few problems - Is there a phone number I can call to speak to someone
Photo of Karen F

Karen F

  • 166 Points 100 badge 2x thumb
Same problem here as the pay period ended 30 June and payment was made 1 July. Is it possible to fix it for a future pay period submission as I have now entered 5 pay periods and YTD gross is incorrect, but PAYG and Super is ok.  I do not want to have to undo the payroll from 1 July now that I am at the end of the month and ready to submit SG data to SBSCH.
Photo of Ken Lee

Ken Lee

  • 230 Points 100 badge 2x thumb
Rav... to your question if this happens when the pay date is set to 1July 2019. Answer is YES
Photo of Peter Walton

Peter Walton

  • 298 Points 250 badge 2x thumb
do we have any answers on this problem yet? It should be simple to make the data sent to STP to match the data on the payslips.
(Edited)