Reckon POS2015 Customer Transfer issue

  • 1
  • Problem
  • Updated 3 years ago
  • Acknowledged
  • (Edited)
So another day, ​another new bug found in Reckon POS 2015.

When editing a customer ​using the POS​2015​ clien​t and then doing a POST the customer details are updated as expected​ in Reckon Accounts.​ This​ part​ is working fine, ​​BUT it also changes the customers​ "Preferred Send Form Method"​ setting as well and sets ​it to EMAIL​, ignoring what it was set to before the POST.

We send out statements based on this setting, some clients get statements via email, the rest are printed. We use the ​Preferred Send Form Method​ field to set email or​ mail send method to keep track of this​, as is the Reckon way to do this.

But​ we have noticed whenever we edit a ​customer details ​from the POS2015 client​,​ which can be​​​​ anything ​as simple as a phone number ​change, Once we do a ​POST transfer that customer we edited​ send method is changed to email.

Seems the POS transfer just squ​​ashes the ​preferred send method ​setting​ in Reckon Accounts​. This now means we can no longer edit customers on the POS2015 clients!

Anyhow, I dropped a email to the Advantage support email, lets see if anything happens.
Photo of Andrew

Andrew

  • 22,202 Points 20k badge 2x thumb

Posted 3 years ago

  • 1
Photo of TamNguyen

TamNguyen

  • 552 Points 500 badge 2x thumb
Are you using POS professional Andrew? I was setting up the interface for POS lite and show the initial stage of designing to my boss and he said it look not good if you cannot have multi layers to choose from. :)) 
Photo of Mustafa

Mustafa, Alum

  • 1,158 Points 1k badge 2x thumb
Hi Andrew,


Thank you for your feedback, I was able to replicate the issue and it's being escalated to developers.

Cheers
Mustafa

Photo of Andrew

Andrew

  • 22,202 Points 20k badge 2x thumb
For those playing along at home, Reckon stance is they have confirmed this bug and it may or may not be fixed in a later version of the product.

Now hows that for customer service when you pay over $1.2k in licencing fees every year to Reckon! Can't even correct the bugs found! What hope do we have on getting new features added! :(
Photo of Reckon FAQs

Reckon FAQs, Employee

  • 10,138 Points 10k badge 2x thumb
Hi Andrew,

Thanks for highlighting this problem.  Our product developers have included this issue for consideration for the next release.  

regards,
John
Photo of Andrew

Andrew

  • 22,202 Points 20k badge 2x thumb
Way to poke the bear there John!! So its been considered, but may not make it into the next release. Nice.... just real nice.

Clearly you missed the sarcasm in my previous message. This is not how you treat customers who report defects with your software!

This is a software defect with your product, Reckon acknowledged the issue, yet in true Reckon style, fails to commit to fixing it.

So John, Why can't Reckon commit to fixing software defects in products? I mean you want me to commit to yearly licence fees, its a two way street!
Photo of Andrew

Andrew

  • 22,202 Points 20k badge 2x thumb
Hey John...... Any comments?
Andrew.

Your opening request.....      "   But​ we have noticed whenever we edit a ​customer details ​from the POS2015 client​,​ which can be​​​​ anything ​as simple as a phone number ​change, Once we do a ​POST transfer that customer we edited​ send method is changed to email. "

Tell me,  that EDIT  (BEFORE doing the subsequent POST)....  is the 'Send Method" field already corrupted at the Reckon ACCOUNTS end?   Or is it only when the POST goes through?

Is it a 100% situation, this defect?   And.... Does the defect occur from various POS clients?

Are there other activities occurring at the same time?

Have you observed any values amiss on the client POS database prior to the end result that you see as the corruption of the 'Send Method' field on the target RA database?

WIth POS2016 just about to be released in NOV,   has your customer noticed this issue on POS2015 prior to the raising of this issue 4 weeks ago?  Seems that 9 months has transpired depending on when POS2015 was installed by your customer.   Be interesting to quickly isolate if other users are in the same predicament with the same LAN setup as your customer is today.

What operating systems and setup are involved in this client's situation?

Gary
(Edited)
Photo of Andrew

Andrew

  • 22,202 Points 20k badge 2x thumb
Hi Gary,

Yep its a software defect. If you check Reckons first reply to this thread, you'll see "Mustafa" has confirmed it

Thank you for your feedback, I was able to replicate the issue and it's being escalated to developers.
I'll also include the very excellent email reply I got from Mustafa as well, when dealing with them via email regarding this 'bug' while Mustafa was validating the results on their end at Reckon.


I have escalated the below issue and waiting for a response:
 
 
Issue: When you edit customer details in POS 2015 like for example adding contact number after that you perform end of the day which in turn updates the customer preferred send form method to email in RA.
 
 
1.      Created a new file in RA 2015 R2 and new database in POS 2015
 
2.      Set preferred send form method to email for customer 1
 
 
cidimage003png01D0F129D3075290
 
 
3.      Set preferred send form method to mail for customer 2
 
cidimage004png01D0F129D3075290
 
 
4.      Set preferred send form method to none for customer 3
 
 
cidimage005png01D0F129D3075290
 
 
5.      Transferred all this information to POS
6.      In  POS performed couple of transactions for customer 1/2/3
7.      Also edited these above customer with adding contact number and alternative phone which was not there
 
cidimage008jpg01D0F12BCFFD0DE0
 
 
 
cidimage010jpg01D0F12BCFFD0DE0
 
 
cidimage012jpg01D0F12BCFFD0DE0
 
 
8.      Now performed end of day – posted back to RA
9.      Now when I go to customer centre > double click on the customer > the preferred send form method for customer 2 changed from mail to email
 
cidimage015png01D0F12AE6DB5A40
 
 
 
10.   The preferred send form method for customer 3 changed from none to email
 
cidimage016png01D0F12B6724FF30
 
 
 
Thanks
Kind regards,
Mustafa Irfan
Technical Support


Sadly the next response from Mustafa, was the devs replied with 

Please let customer know that it will be investigated for future release. The issue has been replicated on our end too.

Which as we all know is Reckon code for not going to happen.

I've since express my dissatisfaction with this response, requesting a firmer resolution plan at correcting the software defect that has been reported. If the 'future release' is going to be POS2016, then that will be fine. But if its not, then the next update will be POS2017, which is totally unacceptable to me.

POS2016 is 5 months away from release, a simple import bug like this can be included in the release. It shouldn't be rocket science to fix.

I'm still waiting for a reply.
(Edited)
Photo of Andrew

Andrew

  • 22,202 Points 20k badge 2x thumb
WIth POS2016 just about to be released in NOV,   has your customer noticed this issue on POS2015 prior to the raising of this issue 4 weeks ago?  
Where did you get this timeline from? POS and RA are linked together as part of the upgrade cycle, so this would mean the RA update will be released as well in Nov.

I don't see any reason for Reckon to break from the yearly upgrade cycle, and I'm pretty sure Reckon have been saying in these forums that RA 2016 is coming in early 2016, which falls in line with the yearly upgrade cycle of the past.

Seems that 9 months has transpired depending on when POS2015 was installed by your customer.  
We recently only moved to a 'mix' email/print for statements, so the bug was picked up then. We are using the 'Reckon' way of doing this mixed sending method, by using the send field for customer selection.

It also took us a while to work out what was happening. The first few months we thought it was user error, the poor accounts lady was blaming herself and pulling her hair out!

Its a strange bug and if you don't edit clients details on the POS machines, you would never find it. I'm guessing this bug has been around for decades in the software. We are the 0.1% use case, I'm sure. But still not the way to treat customers.

Just asking for the software we paid for, to work correctly ;)

BTW We have reported lots of POS bugs over the years! Everything from imports not working, due to special chars like ", to receipts not printing, to EFTPOS machines bugs.

We even had a really wonky one that sent POS in a spin when a customer did a refund, and then a customer account charge in the same transaction! ie return item A, buy item B, pay the difference. 

Its a special kind of love we have for Reckon.
(Edited)
Photo of Rav

Rav, Community Manager

  • 67,824 Points 50k badge 2x thumb
Hi Andrew,

We value your feedback and understand the frustration you're experiencing.

We've taken on board your comments and our developers will examine the issue on their next development cycle with the aim of including a fix in the next release.

With this commitment we are closing this thread as we cannot add anything further to this matter.

Thanks.

This conversation is no longer open for comments or replies.