Report taking too long to build

  • 1
  • Question
  • Updated 1 year ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

I have just upgraded to 2017 R2 and have successfully created a report that I wanted to email to myself in excel (easier that exporting), whilst the green bar has gone to the end it is still telling me it is building and it's over 900 seconds (15 mins).  Sometimes it has taken some time but never this long before.  Any ideas?
Photo of Kerrie H

Kerrie H

  • 2,732 Points 2k badge 2x thumb

Posted 1 year ago

  • 1
Photo of Kerrie H

Kerrie H

  • 2,732 Points 2k badge 2x thumb
Okay so I had to log myself out in the control panel, then log back in.  Just repeated the process of emailing the report which worked quickly except that the clipboard popped up twice which I had to cancel before I was able to enter the email address.  Clipboard problems again!
Photo of John Graetz

John Graetz

  • 17,536 Points 10k badge 2x thumb
Kerrie.  I would suggest that the original issue that you talked about has probably been "lost" because the thread immediately went onto the subject of problems with copying within Hosted.
Secondly, the issue of reports taking a long time to run centred on a particular one some 12-24 months ago, Super Report by Fund.  At that time I did extensive testing under a range of scenarios, including running the report after 7:00pm.  Those results were reported back to this forum and I think it might have been Rav who was involved.  There has not been any noticeable change in the amount of time it takes to run this particular report.  Even with only some 10 employees, it takes generally at least 5 minutes to run.
Thirdly, I would suggest that Reckon is having some extreme server issues today, which is not allowing users to work efficiently.  I say this because, as a test, I just ran the Super Report by Fund for June, with 11 employees.  It took just under 1200 seconds to complete, which is totally ridiculous.  I wouldn't mind betting that yours is still running.  To sum up, today it seems apparent that the servers cannot cope.  As to the reason for that, we will probably never know.
Apart from that, there is something seriously wrong when, what appears to be simple reports, take so long to run.  I also add that the problem with the Super Report by Fund was no better, in the past when running it under the desktop version.  Either nobody knows what the problem is or how to fix it, or it is not regarded as a priority to fix.  And that comes some two years ago since it was extensively covered in this forum.
John L G
Photo of John Graetz

John Graetz

  • 17,536 Points 10k badge 2x thumb
Further to what I stated above and in light of Rav's comments, I advise that during the time that I ran the above report, I was in single user mode, using Hosted.  A test of the internet speed showed a download speed of 8.37 Mbps and an upload speed of 10.81 Mbps.
John L G
Photo of Rav

Rav, Community Manager

  • 54,574 Points 50k badge 2x thumb
Hi John,
There have not been any server "issues" today. However, in the last week we have experienced the highest load through the Hosted network than ever before.
On the flipside, server capacity has been increased in order to meet this increased traffic.

John - in regard to your report tests, what is the "usual/acceptable" timeframe you experienced this report to generate in the past prior to noticing this increased duration in generation?
Photo of Kerrie H

Kerrie H

  • 2,732 Points 2k badge 2x thumb
Thank you Rav and John for your comments, I actually already had the report open and it didn't require refreshing.  I just wanted to email it to myself because it is too difficult and problematic to export in Reckon.

When I hit the email button, it immediately bought up the copy/paste clipboard, which makes no sense, then goes into the running the report again which is never ending.  After waiting some time I have to go to the dashboard to log myself out then log in again, I open the report again (in less than 30 seconds) and press email and it brings up the email address box.  Why do I need to go through this process every week?  We are in multi user but we certainly pay for it and expect it to work in both single and multi user, it is not practical for us to log out one user.

As far as phoning support well I've spent a lot of time on that in the past.
Photo of John Graetz

John Graetz

  • 17,536 Points 10k badge 2x thumb
Rav.  From memory, I would be expecting the report to be taking anywhere between 200 and 300 seconds to generate, based on 10 employees.  But that is from memory.  I do know that it takes what is an excessive amount of time compared to other reports.  When we looked at this a couple of years ago, there were a couple of other options suggested to possibly shorten the time e.g.close down Hosted, delete the tab, start from a fresh tab and try again, and hopefully end up on a different server.  The only problem though is that it seems to be impossible to stop the report running after it has been started.  Hence the alternatives aren't much help.  One thing for sure though that I do know, is that it takes much longer running in multi user mode, which I make sure I never do anymore.
John L G
(Edited)

This conversation is no longer open for comments or replies.