Serious errors in records of moneys spent

  • 1
  • Problem
  • Updated 1 month ago
  • (Edited)
20190812_RECKON COMMUNITY_SUBMITTED Software corruption issues
• Attached images from file of screenshots
• RECKON BIG BAD ERRORS 20181211
https://community.reckon.com/reckon/topics/new/add_details?topic%5Bsubject%5D=Serious+errors+in+reco...
Hi to the forum.
Two problems: RECKON Personal Plus
These ERRORS and or problems have been occurring for 4 versions of software...
Why have I taken so long to complain?  That's what I ask myself.
I keep thinking that I will move over to different brand, but I think laziness and the fact that I want to keep all my spending history that is in the files.  
VERY DISAPPOINTED when I realised that the ARRANGEMENT of the software USE is now suddenly locked into a REQUIRED NEW VERSION PURCHASE EVERY YEAR... Very cunning business decision...

ERROR #1:
Amounts $ entered in TRANSACTION records are being somehow offset by an amount DOUBLE the SPENDING ENTERED.  
*  Not happening ALL the time, but possibly 10% of records are corrupted.  
*  ERRORS show up when looking back to expenditures or
*  ERRORS show up as UNCATEGORISED amounts without ANY entry in the line for Category, TAG or MEMO
* Actual transaction record may be CORRUPTED after re-opening item record and saving an EDIT or reading WITHOUT a change
* ERRORS are seen as UNCATEGORISED items on a generated SPENDING REPORT.

ERROR #2:
Category information is dropping off when saving a transaction record.
*  Not happening ALL the time, but possibly 5% of records are corrupted.  
*  ERRORS show up when SAVING TRANSACTION
*  ERRORS show up as message “ UNCATEGORISED amounts in transaction ...” save or clear “   or somesuch thing
*Generally ONLY CATEGORY entry has been missed

What to do...
My records are useless for spending analysis and account balancing...
• SEE ATTACHED screenshots (6)

SO...
How may I keep a COPY of my spending and deposit history...

Maybe it IS time for a change of software, given that this problem has existed for so long... Surely it is not just me.  The software has had new versions purchased and I have had 3 different windows versions and 3 different PC’s...

Looking forward to comments and action plan
Thanks
Keith







Photo of Keith Dickson

Keith Dickson

  • 126 Points 100 badge 2x thumb

Posted 2 months ago

  • 1
Photo of Andrew Christie

Andrew Christie

  • 1,636 Points 1k badge 2x thumb
Dear Keith
My first question is why are you putting a negative amount against an expense category? This turns the transaction into a double negative, which PP then tries to balance with a corresponding credit which, as you observe is twice the amount of the original entry. This is normal, particularly the double credit entry showing on a new line without a category. Likewise the error message pop-up in your #2 is normal as PP is warning that a line in the transaction is uncategorised.

Solution: Enter the line item without the negative sign. Problem solved

kind regards

Andrew
Photo of Keith Dickson

Keith Dickson

  • 126 Points 100 badge 2x thumb

Andrew...  Thanks for your input AND your QUESTION:
Not sure how I might make my problem clearer...THAT [MINUS 2x$] LINE  IS THE PROBLEM I am concerned for: THAT DOUBLED DEBIT amount makes all the reports AND the whole shebang operation worthless. 
I DID QUESTION my data entry abilities for a long while...  (Late nights at the PC   hmmm...)  But monitoring of the data on my file and noting all the “mistakes” found as I attempted to reconcile my accounts was so frustrating... 
So:
NOTE PLEASE *** I did not enter those amounts... There are hundreds of examples of where the SOFTWARE is generating that DEBIT.  
I am careful, indeed I say very CAREFULLY noting all my operations and INPUTS for my transactions.

Sadly my continuing this dialog about my anxieties over this issue might simply be ignored from this sentence onwards...
JUST READ THE TOP LINES again, please. WHY after 5 versions of this software AND where there is an installation of “RPA+” on 3 different PCs does the problem occur I ask?

THE  problems cited have bugged me all along...
AS STATED, in surveying my figures (which obviously didn’t reflect the true status of my financial position, and taking those entries FOUND in the "UNCATEGORISED transactions" list as a guide for backtracking and then very VERY CAREFULLY correcting, in fact REMOVING the MINUS x2 $ amount for each occurance I thought that the extreme waste of my time was surely going to reinforce some “stay in the moment- Keith” accounting practices... IMAGINE how I felt when I found that the errors were re-generated here and there... 
AND those pesky uncategorized lines taunted me again and again...
SUDDENLY ar at least FINALLY,  I realised that all these errors in transaction s showed that it HAD TO BE  ***a generated glitchy error*** and NOT by me, THE OPERATOR 
I gave UP and neglected to use the software for a while... But finding that the software did fit my needs for accounting and RECORD of Payees and amounts so I decided to BUY a new version thinking that would be the MAGIC... AND a new PC at this stage... I MUST have spent HOURS going back through my accounts and CORRECTING those DOUBLE DIBITS...  
So:
NOTE*** I did not enter those amounts... There are hundreds of examples of where the SOFTWARE is generating that DEBIT.  
Let’s just recapitulate the problem: That double-figure JUST PHYSICALLY APPEARS AFTER SAVING THE CORRECT AMOUNT, OR at some point when the transaction is RE-OPENED by me, to view, or edit, and saved. It may have been OK at first, but then somehow THAT PESKY MINUS 2x debit is implanted on THAT transaction record

PROBLEM # 2.  The categories DISAPPEAR AFTER I HAVE ENTERED THEM and SAVED the completed transaction... Too many glitches in the software.  This problem (2), is not AS FREQUENT but still happening.

Looking forward to any (hopefully/respectfully) furthering commentary and hopefully sensible remedies for the errors.

Disappointed really because I have been trying to produce some spendings reports for a financial advisor...
Remember, I have subsequently  “upgraded” to NEW versions of Personal PLUS 2x and now 3x with my recent 2019 version...  all beginning with  “my investment” in Quicken Personal Plus 2011...  PLUS the recent “Free” upgrade that essentially locked me into an EVERY YEAR renewal... I can't even simply keep the records that I have meticulously made all these years as a reference...

...and to think I used to do it all in excel... :-/)

Kind regards
Keith


Photo of Andrew Christie

Andrew Christie

  • 1,636 Points 1k badge 2x thumb
Hi Keith
If you would be good enough to go back to the absolute beginning of these 'errors'. The example you gave was an expense (?) of $38.95 entered in a savings account '5_Jills...' against an expense category of '... consumables:Repair Items'. Is that correct? Is this category defined as an expense?

How are you entering the transaction, directly in the register with the 38.95 (with no + or - sign) entered into the 'dr' (Payment) column?
When you 'enter' the transaction is that when the program decides to 'split' the transaction?
regards
Andrew

(Edited)
Photo of David M

David M

  • 470 Points 250 badge 2x thumb
Hi Keith
Let me give you another version of what Andrew has said.
It appears that when you entered the transaction to purchase the lipstick for 38.95,
*you first entered it in the bank account as a payment of 38.95, and then
*you went into the split transaction screen, and entered it as a negative 38.95. 
The split transaction screen is designed to always balance in total with the entry in the bank account. It achieves this design outcome, by either inserting a balancing number, or you can hit the "adjust" button in the bottom right hand corner, and it will change the balance in the bank account.
You did not hit the "adjust" button and so you were left with the Reckon generated adjustment of 77.90. Reckon does not know how to allocate this adjustment, and you did not allocate it before you pressed "OK" and posted the entry, so it remained as a $ 77.90 uncategorised item.
The simple solution would be to enter the payment in the split screen as a positive not a negative. This is consistent with the Reckon logic, that when you split a transaction - payment or receipt - the splits are not specific to a 'payment' or a 'receipt', they are specific to that individual transaction. 
You should then see that the uncategorised transaction will disappear.
If that works for you, I would go back and look at the split transaction screen from one of the multitude of uncategorised transactions, and see if the same corrective action also achieves success.
I would expect if it works for this one, it will also fix some if not all the others.
Good luck
David
Photo of David Hunt

David Hunt

  • 470 Points 250 badge 2x thumb
Hi Keith - you have spent a long time trying to document what is wrong - but we are all users here too & not as easy to follow someone else's setup once the transactions already exist. As the fault occurs when you enter them.

Let's try to find a solution from a different angle. By process of elimination. One way uncategorised amounts can propagate is with split transactions. This occurs when you enter an amount on the transaction line but all the line items you enter on the split lines do not add up to the amount you enter on the transaction line. In the split dialog quicken will show the uncategorise amount as the remainder. ie. The split lines add up to $300 but the transaction amount entered as $400, this creates uncategorised amount of $100. Sometimes it's best not to enter any amount on the transaction line and just enter in the split window.


These can propagate when using memorised transactions which are turned on by default. Next time you enter first few characters and it picks up the last time you entered this transaction - if you hit enter without editing - you now have 2 split transactions with uncategorised items etc...

To correct uncategorised split items highlight the rows that contain no category (line with 77.90) and hit Ctrl-D to delete the lines - Then hit the "Adjust' button which makes the transaction amount match the split amount.

Last - make sure you validate your file - selected the menu File, File Operations, hold down Ctrl+ Shift, then select Validate on the menu. Select your file in the dialog that pops up. This will reindex everything and fix corrupted links.

Try this first then if that does not help we have to think of the next thing. 
(Edited)
Photo of Keith Dickson

Keith Dickson

  • 126 Points 100 badge 2x thumb
Thanks to you David (and of course regards to Andrew)
You have obviously been expending some energy on my behalf... I do appreciate your time and efforts to help me.  

I have noted TWO very helpful points that you suggest, namely the CTR_D and Validation of the FILE

These points I shall take to task.
Since I am way behind in my entries for transactions I should be able to report back soon with my fresh understanding of your point of error seeking  

Hopefully with full resolution.
IF YOU WOULD LIKE TO REVIEW MY METHOD USED:   
I have just created a list of the actions which I would be fairly sure to repeat EVERY time I make an entry... I guess that I have become very conscious or confused in my efforts to self-correct this problem that I have encountered over the years...l I HAVE been convinced that it is operator-induced, and have done everything I can to ensure that I don’t make the error somehow.
The problem of having a FRESH transaction entry page has long interested me.... 
In fact I ask myself  (EVERY TIME)  “Why is there no clear the page BUTTON, effectively stating a new transaction page?

LOVE THAT CTR_D action... How did  I miss that?

Yes, I am aware of the NEGATIVE $ AMOUNT that automatically appears after a new entry and amount...
In fact as I go along I will often/ SOMETIMES  Click on ADJUST just to get rid of it... 
Is this a PROBLEM?

Surely this is not just a problem for little old me...?
OK, so I must be vigilant (I tell myself)...
So:
In my quest to solve the problem, I am meticulous now with the following ENTRY METHOD...
I will not deviate...
Where I have in fact pondered the problem of the SUBTRACTION from the memorised amount

I thank you for your patience guys...

Here is a point-form “Flow chart” if you like of the steps that I have followeded since  discovering and attempts for resolution in my own way are as follows:
1. On the HOME PAGE, Select ADD BILL
2. Type in Payee
3. Select Payee I prefer and it comes up with that Transaction LIST or whatever from that particular entry/date for that particular PAYEE name.
4. TYPE IN MEMO description
5. Select ACCOUNT TO USE
6. SELECT METHOD  i.e.  PAYMENT
7. ENTER DATE

NOTE: I DO NOT INPUT ANY $ amount at this stage

8. Click on SPLIT
9. BEFORE ANYTHING ELSE, I commence to REMOVE ALL THE ENTRY LINES one by one, then
10. ZERO AND REMOVE ALL THE $ AMOUNTS one by one, THEN...
11. Click on ADJUST 
12. In fact... Let's do it again and again and again just to make sure ( OCD) (Not kidding  )

13. CHECK VISUALLY  that the AMOUNT is ZERO to begin the task of entering a transaction record


14. Commence to INPUT the new item lines and amounts $
15. Commence to INPUT the TAGS for new item lines and amounts $
16. Commence to INPUT the CATEGORY  for each line item 
17. Click on ADJUST again just to make that a TOTAL is “sensible “ and verifiable

18. VISUALLY NOTE that the total amount on that ADD BILL is a correct figure


19. VISUALLY NOTE that THERE IS NO OPPOSING DOUBLE DOLLAR AMOUNT entered on the SPLIT

20. Click on OK

21. RETURNING to the ADD BILL (front)  page, Visually check: Memo, Account to use, Payment and AMOUNT and Date for entry  on the Transaction page


22. Click on OK
23. Hope that there is no immediate error message that there is NOT an uncategorized item present
NOTE: YES, when this has occurred, the fact remains that somehow the category has NOT been saved, but the memo and $ amount is seen to have been retained...
24. In this case, REPLACE the category need and OK > OK again with a prayer...

25. Sometimes when I'm particularly anxious and over-thinking the problem,  I will go back into EDIT and Just check...
26. OK maybe relax and go on to the next transaction entry...
Occasionally I shall check on a TRANSACTION along the way, and sometimes the DOUBLE $$ amount will be evident, maybe not...
Sort of like Russian roulette it seems...

Mostly I will wait till I have time and patience and correct the errors in a block... Not often enough it seems...

So:  after all this compulsiveness, the errors are still in abundance.
Thanks to both of you, for the view  from outside my skull
Looking forward to your assessments, comments and further analysis which is very appreciated
Thanks again
Keith
Photo of Andrew Christie

Andrew Christie

  • 1,490 Points 1k badge 2x thumb
Hi Keith,
Just a short note from me. I followed your steps and could not replicate the error :-(

However I do refer to your actions in step 9. I have found that merely removing the entries in each line did not sometimes actually 'delete' them and the program at times would retain the original amount for that line and I would receive an uncategorised line error message when trying to save. I suggest that you actually use the the 'delete' option to remove a line.

.
I enter transactions via the register as I find it more flexible in viewing/reviewing and managing my transactions. Anyway, I suppose whatever works the best for you.

I do however suggest that you 'delete' any split lines which you do not require.
regards
Andrew
Photo of David Hunt

David Hunt

  • 470 Points 250 badge 2x thumb
Keith Your method outlined is fine, however it will obviously enter a new transaction it will not fix the old ones. You have to go back to correct or Delete/reenter the historical transactions. Also If your system is picking up a memorised transaction (default) it will automatically fill in the $ total. 


To prevent the system entering any previous $ amounts or memo text etc you can uncheck the following setting. That way in the register or add bill dialog it will just give you a drop down arrow to match the payee but no other field will be pulled in from historic transactions - it will be a blank form.

It's on the menu Edit, Preferences, Program, register/autofill - clear the tick on "Complete Fields..."
 



(Edited)
Photo of Keith Dickson

Keith Dickson

  • 126 Points 100 badge 2x thumb

Thanks for the very prompt replies.  This is getting to be an extraordinary journey. Thanks for the suggestions David, and yes I will try that last tip. I have spent a day and a night almost,  going over this year's entries and surveying the problem after entering and re-checking more transactions.

Let me say this.  I have printed out the list of erroneous entries from Jan 1 2019... Counted 213  errors total that appear as “Un-categorised entries.  In fact, obviously, they also show as a deposit if I scan the calendar page and check every transaction.

I was happy to go along with the tack for the problem being a transmitted glitch if that can be the term for carrying over the amounts on old memorised transactions.... But I don’t think that this is the problem: Why?  This is my survey for the last 8 months, to date:

Transactions recorded

591

un categorised* transactions

213

36%

of total

Of those * were NEW payees

47

8% of total

or 22% of affected entries

THAT IS 22% of all ERRORS were totally NEW Payees with no previous record involved in the transaction recorded.   (Fair sample Andrew?)

In fact this count is AFTER several occasions of corrections and some entries were found to be either “re-instated” with double deposits OR simply changed to a deposit for the intended amount $

This, all after VERY CAREFUL inspection of each instance found, and correction of the transaction type and totals and that annoying mis-calculation.

This is a vicious time-wasting practice I am sure that you will agree.  Happy to concede to "operator errors... But hey... What does it say about the porogramming code design or flow?  User friendly?

So, as per your suggestions David, now I have set up the preferences and no old transactions will be memorised and every transaction will be a fresh transaction by record.

The instances MAY be fewer but I am not convinced that this is the complete resolution of the problem, given the occurrences found for new payees shown in the above numbers.

We’ll see... I have another pile of accounts to enter and scheduled payment to enter...

He smiles...

Not sure what you mean Andrew by entering transactions “via the register”. Can this be explained?

Anything that will make the job easier

Thanks

Keith

Photo of Andrew Christie

Andrew Christie

  • 1,626 Points 1k badge 2x thumb
Hi Keith,
Instead of accessing 'Add Bill or Deposit' from the "Home' page, open an account to show its 'register' into which you can enter the transaction directly.

You can access an account via the menu path ...


or the at-a-glance tool bar along left or right side


regards

Andrew
Photo of Keith Dickson

Keith Dickson

  • 126 Points 100 badge 2x thumb
Different... Thanks Andrew: I will assess the ease of inputs which at first shot (a dozen test inputs) seems clumsy.  Surely though it would not make any difference to my problem?

I have "corrected" quite a few payments that have seemingly converted themselves to DEPOSITS after CORRECTION of the too frequent double deposit summing... RAP+ doesn't like me editing any transactions it seems... As soon as I close the corrected payment record it pops back as a deposit.
Photo of Andrew Christie

Andrew Christie

  • 1,626 Points 1k badge 2x thumb
Hi Keith,

It would be very handy to see first hand what is happening when you either enter or attempt to correct a problem transaction.

Do you use Skype as you then just share your screen (not allow access!) and we could talk while you show how you go about everything.

regards
Andrew