Something went wrong error message: Single Touch Payroll

  • 1
  • Question
  • Updated 4 months ago
We're having a problem with STP. 

I have shared the STP file with my colleague and he can login no problem, but an error message of "Something went wrong" appears 3 x times on the screen after he has selected:

ReckonGovConnect, then 
Open 

I have cleared the cookies and cache on his computer as recommended on another forum post but still the error message appears.

Does anyone know what the problem is here?

Thank you 
Photo of Gemma

Gemma

  • 420 Points 250 badge 2x thumb

Posted 5 months ago

  • 1
Photo of Rav

Rav, Community Manager

  • 64,790 Points 50k badge 2x thumb
Hi Gemma,
From what I understand, this error occurs when you've added another person as 'Staff' in the Reckon Portal rather than sharing the STP entity using the 'Share' process.

Can you confirm if that has occurred?
Photo of Gemma

Gemma

  • 420 Points 250 badge 2x thumb
Hi Rav,

I shared the file using the share process (click the three dots and share with user).


Photo of Rav

Rav, Community Manager

  • 64,790 Points 50k badge 2x thumb
Thanks for getting back to me Gemma, sounds like you've done everything right which is good.

Ok just found there's another potential cause for this and its related to firewall/antivirus security. Essentially, your firewall could be blocking the following URL https://stp-api.reckonapi.com and needs to be added to the exception list. This varies depending on your security setup but I'd recommend checking that out.
Photo of Gemma

Gemma

  • 420 Points 250 badge 2x thumb
Hi Rav, we called our IT provider who went through everything related to the Firewall and the problem is still occurring.

Our IT provider believes it is a Reckon issue, not something on our end.
Photo of Gemma

Gemma

  • 420 Points 250 badge 2x thumb
Hi, does anyone have a solution to this yet?  The error is still occurring. 
Photo of Carmel Matheson

Carmel Matheson

  • 120 Points 100 badge 2x thumb
Hi Gemma, I have got a little further, but still have an issue, but thought I'd share this with you, as you might be able to get solve the final bit for both of us...

Athough the portal allowed us our 2nd user to access the GovConnect Portal using his Reckon Hosted log in credentials, we also had 4 error notifications that were coming up, and we were unable to verify his the email address when we were trying to share the file with him as advised. Rather than logging in, we registered him for the free Reckon Portal Account (the link is above the log in window), and it generated an email that was sent to his email address which we have had to validate. Once validated, our original user was able to share access to the GovConnect STP. So even though we do not have the 4 error messages anymore, and have been able  share access with him, when we click on the shared with me tab (while logged in as him), the portal says we do not have any shared subscriptions. I am hoping between us, we can nail this before the end of the day... lol. Appreciate any info you can throw my way. Thanks.
Photo of Carmel Matheson

Carmel Matheson

  • 120 Points 100 badge 2x thumb
I'm in... yay!!! Log out of the portal and log back in, taking care to use new log in details you set up when you created the new user account.. ours was our 2nd users\'s email address and his password. ... Good luck, hope this helps.

Photo of Len Hill

Len Hill

  • 130 Points 100 badge 2x thumb
I am still unable to progress with my STP Lodgment  process as the error continues to appear, sometimes 4 notifications come up then suddenly disappear ! 
Does anybody have this problem, if so how have you rectified it ?
Photo of Carmel Matheson

Carmel Matheson

  • 120 Points 100 badge 2x thumb
I'm in... yay!!! Log out of the portal and log back in, taking care to use new log in details you set up when you created the new user account.. ours was our 2nd users\'s email address and his password. ... Good luck, hope this helps.
Hi Len, I am experience same problem can't log in to the reckon Gov Connect with my authenticator . I can't submit STP to ATO.  I have update my iphone and got  authenticator from my icloud  store , after this I can't log in anymore. Please help . Violeta 
Photo of Rav

Rav, Community Manager

  • 64,790 Points 50k badge 2x thumb
Hi Violeta,
Did you delete your authenticator app at some point since setting up the MFA on your GovConnect STP service?
Hi Rav, I got on both iphone's at the moment  but only now I find out that is working with my old phone. I can log n to the reckon gov connect. But how can I delete from my old phone and have on my new iphone only. Thanks for your help. Violeta
Hi Rav, I would like to ask you if I can get training with reckon hosted, I am new to this job  and to payroll trying to find videos on You-Tube to help me out to do same work .EOFY etc, but not much information about Reckon accounts hosted on You-Tube. I need to learn how to terminate an employee in accounts business . Thanks. Violeta
Photo of Felicity Van

Felicity Van

  • 1,116 Points 1k badge 2x thumb
I am having this same issue.  I have two companies that I need to lodge STP data for. I was able to do the first one fine, but when I log back in to do the 2nd company I get the "something went wrong" error message 3 times & then it's lost all previous data for this company.

Can anyone assist?

I had no issues a fortnight ago when I did both companies.
Photo of Rav

Rav, Community Manager

  • 64,790 Points 50k badge 2x thumb
Hi Felicity,
I'd recommend checking out this KB article for potential causes of that message and how to resolve it -

Error ‘Something went wrong’, when trying to open GovConnect
Photo of Felicity Van

Felicity Van

  • 1,116 Points 1k badge 2x thumb
thanks Rav,
that didn't work, but i cleared browser history & that worked.