STP - ABN plus a branch

  • 1
  • Question
  • Updated 4 months ago
  • Answered
We have one ABN for 2 locations. The first location does not have a branch number and the 2nd has the branch number 002.
When we set up GovConnect we put in the ABN and clicked on branch to add the 002.
We can upload successfully for branch 002.
When we upload for the first location it says - Company Information is Valid - and then does not upload the file. This response is received when using no branch number in the company file as well as 000.
What do we need to change to get the first location to upload?
Photo of Michele Hicks

Michele Hicks

  • 100 Points 100 badge 2x thumb

Posted 4 months ago

  • 1
Photo of Michelle Denton

Michelle Denton

  • 80 Points 75 badge 2x thumb

Hi Michele,

Try using 001, it should work.

Photo of Michele Hicks

Michele Hicks

  • 100 Points 100 badge 2x thumb
No branch numbers - Company information - valid with no upload happening
000 - Company information valid - with no upload happening
001 - Invalid company information

Using the desktop version.

When we setup the GovConnect we only put in the branch details for 002, was there something else we should have done at that stage like perhaps also put in a branch 001?

Any help from someone at Reckon would be greatly appreciated as I have spent over an hour on the phone with support yesterday with no outcome and we are still waiting for a call back today.
Photo of Rav

Rav, Community Manager

  • 63,114 Points 50k badge 2x thumb
Hi Michele,
Do you have two STP 'tiles' set up? ie. One for each specific branch

It sounds like you've already set up a STP service for branch 002 which is great, you'll need to add another for the first branch.

Click the 'Buy Now' button in the top right corner to add another STP service (there is no cost).

(Edited)
Photo of Michele Hicks

Michele Hicks

  • 100 Points 100 badge 2x thumb
Hi Rav

We do have two tiles but as we could not add Reckon twice through Access Manager we thought we could only have one tile for the ABN and all the branches. A phone call to the ATO has solved this now as they could add the second software ID for us. Thanks for your help with this. However the next issue is - Failed to save event pay run data - how do we correct this.
Photo of Rav

Rav, Community Manager

  • 63,114 Points 50k badge 2x thumb
Check out 11.) in the FAQs -
Single Touch Payroll FAQ's

Essentially, there is an invalid character(s) in the file you uploaded to GovConnect STP and as such the submission is being rejected. The invalid characters need to be corrected before it will go through successfully.
Photo of Michele Hicks

Michele Hicks

  • 100 Points 100 badge 2x thumb
Hi Rav

There are no invalid characters in the company information, where else do we look?
We have 5 entities, 4 of which loaded up with no issue and the company information is the same except for the name which has been copied and pasted from GovConnect.
Photo of Rav

Rav, Community Manager

  • 63,114 Points 50k badge 2x thumb
Hi Michele,
Its probably best that you get in touch with our Support team so a technician can validate your JSON file and pinpoint the corrupt element.