STP App - Errors that actually went to ATO - How to fix?

  • 1
  • Question
  • Updated 1 month ago
Reckon STP app 1-4 employees first time user. Used STP app for last pay run of the year, to get a practice run in for 19/20 FY. Had 4 errors, declined by ATO, please amend. 5th time it worked. Checked my personal mygov account and to my horror, the first 4 "error" had actually been accepted by ATO. I tried to do a negative amendment on for myself to take away the 4 extra payments from last week (to see if it worked), it actually added it on! Now my employees, including me have "tax ready" income statement in mygov that are incorrect. ATO can't fix, Reckon STP app has no contact with users. How do I bloody fix this???
Photo of Cate

Cate

  • 100 Points 100 badge 2x thumb

Posted 2 months ago

  • 1
Photo of Rav

Rav, Community Manager

  • 84,100 Points 50k badge 2x thumb
Hi Cate,
What was the error message you received for those first 4 pay events?
For those 4 that returned an error, were there multiple employees in that particular pay event OR just a single employee? If there were multiple employees in the pay event, did data for all the employees get sent or just the ones that the error did not pertain to?
Photo of Cate

Cate

  • 100 Points 100 badge 2x thumb
Hi Rav, there were 4 employees in that particular pay event. I can only see my personal mygov account, so can only assume that all four employees (including mine) were affected. I attempted a negative amended for myself on one of the existing error/please amend files, but this actually added it on to my personal figures in mygov. Apparently the '-' symbol does not work? So now my personal mygov account is reflecting 9 x my actual last pay run totals included in FY income.  statement.
Photo of Rav

Rav, Community Manager

  • 80,134 Points 50k badge 2x thumb
Hi Cate,
Can I grab the ABN that you've registered to the app please. I want to get some checks on this by our payroll or app team just to make sure of a few things.
Photo of Cate

Cate

  • 100 Points 100 badge 2x thumb
Hi Rav, it's 95 074 425 406. While you're at it, it also appears that the FY figures for employees that were NOT paid in the final pay run for 18/19 have not transferred to MyGov, but have in fact rolled in STP into the current 19/20 FY.
Photo of Diane Kent

Diane Kent

  • 102 Points 100 badge 2x thumb
Hi Rav
I have a similar problem with my final pay.  I entered YTD and did one pay run at end of 2018/9 year.  It was rejected

".ATO sent the poll response but the service failed to deserialize it.."
Image
I did an adjustment and put all figures in again which was accepted.  I then finalised pays for the end of year.  I have checked my final 2018/19 figure and it is over stated by the same amount as the last pay run.  i.e. last pay run went in twice so error pay run worked!!  ABN 84063755680.


Photo of Cate

Cate

  • 100 Points 100 badge 2x thumb
Good luck Diane, I still haven't had a response. I'm sick of it and have sent manual group certificates to ATO and employees with letters explaining that mygov figures may be incorrect due to STP software problems.
Photo of Diane Kent

Diane Kent

  • 102 Points 100 badge 2x thumb
Yes I'm hearing you Cate.  I was on the phone to the tax office and I told them if I didn't get a response today from reckon that i was just going to let it be incorrect and give my employees the correct information and that I would send in the normal end of year reconciliation to ATO.  They have said they wont fine us and I'm not sure what else we can do when the software doesn't work as it should!!
Photo of Bruce Bowen

Bruce Bowen

  • 100 Points 100 badge 2x thumb
Seems I have a similar issue, wiped out mygov figures for fy18/19 and replaced it with the FINAL 2019 payroll run figures, and the STP app has the FY19 final $ listed in the summary as FY19/20...  luckily I'm both a director & employee of my company, but I've been unable to work out how to fix the figures.
Photo of Bruce Bowen

Bruce Bowen

  • 100 Points 100 badge 2x thumb
I've played around with this, and personally having been in IT for over 40 years, I'd be embarrassed to release a product like this to the public. But, getting back to my stuff, I've discovered that even though I backdated the pay run into June 2019, it uses the submission date (ie July), and thus it puts the values in the APP figures for July, but in the mygov it seems to get messed up, and wipes out 2019 figures and treated it as my FINAL pay for 2020. So, I did an adjustment to reverse that out, and it reset my APP to $0 for 2020, and my gov back to 2019. I then did another adjustment (I had a $0) from early June, entered in the $ figures I wanted to ADD to the mygov accumulations, and now it's correct. I've been reluctant to FINALISE 2019 by using a $0 adjustment, but for 2020, I'll ensure I put in a couple of $0 pay runs in June 2020, so that I can submit adjustments if needed that are in July 2020 but for dates in June 2020. It would be nice if the APP rejected dates or told you it was going to overlay your backdated dates.