STP App is not working coming up with error submitting pay run

  • 6
  • Problem
  • Updated 3 weeks ago
  • (Edited)
This software has been working up until last month, i have reinstalled the app/updated to the latest build. Error codes come up when i submit to the tax office is "The value specified for an item does not match the item type (value = "6809.6000000001", item type = Decimal, uniqueID = http://www.sbr.gov.au/ato/payevntemp:EmployerContributionsSuperannuationGuaranteeA) Hint: The TotalDigits constraint failed.. 

Thank you
Photo of Sandra Price

Sandra Price

  • 282 Points 250 badge 2x thumb

Posted 2 months ago

  • 6
Photo of Joseph Li

Joseph Li

  • 3,602 Points 3k badge 2x thumb
Is the erroneous pay run in Business Portal?
Photo of Sandra Price

Sandra Price

  • 282 Points 250 badge 2x thumb
When I spoke to the ATO recently they said the error entries had not come through their end.  None of the pay runs I create are getting through to the ATO at all.  Is it a software issue?  Since mid April this has been happening.  I had noticed the app had changed.
Photo of Sandra Price

Sandra Price

  • 282 Points 250 badge 2x thumb
Nadia submitted successfully, I assume this has fixed the problem and I will try a normal payrun.  Keep you informed.
Photo of Nadia

Nadia

  • 852 Points 500 badge 2x thumb

I'm glad that worked for you too.


After I got it working correctly...I checked the ATO business portal & phoned the ATO to clarify whether any of my "Error" message payruns had gone through. None of them had. Then I created new payruns and entered them all again.  So the ATO has the correct amounts for my employee Gross Pay & Tax.   


However, In the Reckon STP if I click Employee, then Pay Summary the Year-to-date figures are all overstated. These figures include the amounts that were entered in the "Error Payruns".  


The ATO said the ATO has the correct amounts, and I got the impression the Reckon year-to-date figures being wrong isn't a problem for the ATO.  I am still hoping Reckon will fix this though. It would be nice if everything reconciled before 30th June.


Photo of Sandra Price

Sandra Price

  • 282 Points 250 badge 2x thumb
Hi Nadia, yes I got this far and will take the next step today.  By fixing this error future payruns should work, fingers crossed.  Yes it is frustrating the YTD in Reckon is so incorrect.  I wish also this was looked at by Reckon, it has been very confusing for you and others out there going through the same issues.
Photo of Sandra Price

Sandra Price

  • 282 Points 250 badge 2x thumb
Hi Nadia, thank you again, payrun submitted successfully.  Any issues I know to contact you.
Photo of Nadia

Nadia

  • 852 Points 500 badge 2x thumb
Glad its working.  Hopefully you won't have any more issues, but if you have issues the same as mine I'm happy to help !!
Photo of Joseph Li

Joseph Li

  • 3,602 Points 3k badge 2x thumb
Were pay runs submitted prior to mid April successful? Is there anything in employee myGov income statement?
Photo of Sandra Price

Sandra Price

  • 282 Points 250 badge 2x thumb
Yes my last successful payrun to the ATO was submitted 14/4, all payruns since this date have been errors, ATO has no record since this date.  I have not checked with the employee, I believe the employee sees the same information as the ATO.
Photo of Jay Jay Li

Jay Jay Li, Employee

  • 384 Points 250 badge 2x thumb
The message you got is a rejection from ATO saying there is a value that has too many digits after decimal points. you need to look up and find where is this 6809.6000000001 entered in the system and round it up to 2 decimal points and try again. 
Photo of Julie Bowd

Julie Bowd

  • 220 Points 100 badge 2x thumb
Thanks jay i have been in contact with the ATO they cannot see there is a problem and we have two employees so that figure would not be relevant 
Photo of Nadia

Nadia

  • 852 Points 500 badge 2x thumb
Julie, You said you don't have access to YTD. Not sure if this is what you mean but...Click Employee, Click on an employee. At the top you should have 2 tabs - Profile & Pay summary.  Click on Pay summary to see YTD figure.
Photo of Julie Bowd

Julie Bowd

  • 220 Points 100 badge 2x thumb
thanks for that all looks good to me cannot see any oddities
Photo of Marina Fedeli

Marina Fedeli

  • 64 Points
Having same problem. Anyone been enlightened yet.?
Photo of Julie Bowd

Julie Bowd

  • 220 Points 100 badge 2x thumb
not yet
Photo of Nadia

Nadia

  • 852 Points 500 badge 2x thumb
I fixed this problem.  You need to get rid of the 1 at the end of the strange decimal number.  My error was 5529.00000000001.  I entered a payrun with Wages $0, Tax $0, Superannuation $-00000000001.  The next error message had the number 5528.99999999991 I entered a payrun with Wages $0, Tax $0, Superannuation $0.00000000009 and it lodged correctly.  I then entered the payrun with the correct Wages,Tax & Superannuation (No decimals in super just in case !!) and it lodged correctly.  Hope this helps.