STP app loop. Can’t log on

  • 1
  • Problem
  • Updated 2 weeks ago
Downloaded the STP app,
Set up the business, added employees... went to log in again and I can’t!

I ‘sign in’, then it tells me to search the business, I do and then it says ‘business already registered please log in’.
So I press ‘log in’ and we start the loop all over again...

Please help!
Photo of danni

danni

  • 70 Points

Posted 4 months ago

  • 1
Photo of Rav

Rav, Community Manager

  • 90,850 Points 50k badge 2x thumb
Hi Danni,
The most common explanation of this I've seen in similar situations is due to the app account first being created with a typo in the email address. So now that you're trying to login with your correct email address it won't register the ABN because its already in another account.

What's the ABN you've registered to the app?
Also, can you confirm that the email address you used on the app is the same email address registered to this Reckon Community account?

If there have been no payruns submitted (I can delete the ABN from the app so that you can register it again correct. If there have been any submissions (successful or not), I won't be able to but first things first, lets check it out.
Photo of Rose

Rose

  • 70 Points
Hi I have exactly the same problem with the mobile STP software, was set up a few weeks ago with employees, and year to date payroll information. Goes round and round.Wasted a lot of time over weekend, trying to get it to work, and have set up a Reckon Gov Connect, so now confused. If I can't get the STP mobile app up and running again, can you please delete all the information stored in the mobile app and the Gov Connect. Don't believe have submitted any data to ATO - is currently blank. Email used to register is the same as email address for this Community Account.
(Edited)
Photo of Rav

Rav, Community Manager

  • 90,020 Points 50k badge 2x thumb
Rose,
Is this more about the app opening and loading or is it an issue with your sign-in?
Also sorry just a tad confused, why did you sign up to the GovConnect service?

What is the ABN you've registered to the app?
Photo of Rose

Rose

  • 70 Points
Rav, I sign in, select the company, says already registered, select please log in - back to the sign in screen. Re the GovConnect confused myself as well, didn't know what I was doing? ABN is 21077634710 Rose
Photo of Rav

Rav, Community Manager

  • 90,020 Points 50k badge 2x thumb
Hi Rose,
I've had a look and I can see what's happened.
When you first registered the ABN to the app, it looks as though you've made a small typo in the email address when you signed up. This is why when you attempt to login to the app now with your correct email address, it can't find your ABN because its already registered to a different app account.

I've deleted the erroneous account now so all you need to do is login to the app with your correct email address and the app will ask you to register the ABN and this time it will work.

I've also deleted the ABN from GovConnect as its not required in this instance.
Photo of Amelia Morrison

Amelia Morrison

  • 90 Points 75 badge 2x thumb
Hi Rav
Can you help me as this is what I think I may have done also - eg entered incorrect email address accidentally or password.  Do you need ABN?
Thanks (feeling silly) Di
Photo of Rav

Rav, Community Manager

  • 90,020 Points 50k badge 2x thumb
Yes please Di.
And also can you confirm that the (intended) email address for your app account is the same email address for your Community account.
Photo of Amelia Morrison

Amelia Morrison

  • 90 Points 75 badge 2x thumb
Yes email address is the same for the App (or should be??? :))

Do I list ABN here?
Cheers,  Di
(Edited)
Photo of Rav

Rav, Community Manager

  • 90,020 Points 50k badge 2x thumb
I've removed your Reckon Customer ID from the post above. Yes please, I just need the ABN you've registered to the app.
Photo of Amelia Morrison

Amelia Morrison

  • 90 Points 75 badge 2x thumb
Thanks
ABN 48976527450
Appreciate this...
Photo of Rav

Rav, Community Manager

  • 90,020 Points 50k badge 2x thumb
Thanks for that. Yes, there was a small typo in the email address for the app account when it was created.

I've deleted it now so what you need to do is log out of the app if you haven't already and then sign in with your correct email address ie. the one that this Community account is under. The app will ask you to register the ABN, you can go ahead and pop it in & it will go through this time.
Photo of Amelia Morrison

Amelia Morrison

  • 90 Points 75 badge 2x thumb
ALL GOOD - pay run processed accurately.
THANK YOU FOR YOUR HELP WITH THIS.
(Edited)
Photo of Ann

Ann

  • 60 Points
I have the same problem - please help. The ABN is 42120895758

Photo of Rav

Rav, Community Manager

  • 90,020 Points 50k badge 2x thumb
Hi Ann,
This should be sorted now for you. You'll need to logout of the app if you haven't done so already.
Close the app in full ie. swipe it away from your running apps and then reopen after a couple of minutes.
Sign up for a NEW account and go through the prompts to setup.