STP Error 'AddressDetailsPostal'

  • 1
  • Question
  • Updated 2 months ago
Hi, I'm getting an error in my STP Portal 'AddressDetailsPostal', I know there have been lots of posts on this already, and I have tried everything with no success, error is as below.

The element 'AddressDetailsPostal' in namespace 'http://www.sbr.gov.au/ato/payevnt' has invalid child element 'CountryC' in namespace 'http://www.sbr.gov.au/ato/payevnt'. List of possible elements expected: 'Line1T' in namespace 'http://www.sbr.gov.au/ato/payevnt'. Hint: while processing parent element [AddressDetailsPostal] child mandatory element [Line1T] was expected but not found

The thing that sticks out to me is Address Details Postal, there seems to be no Input in Reckon one for a "Postal Address", any help would be appreciated.  Thanks, Ron.
Photo of Ron

Ron

  • 270 Points 250 badge 2x thumb

Posted 2 months ago

  • 1
Photo of Rav

Rav, Community Manager

  • 104,618 Points 100k badge 2x thumb
Hi Ron,
Not sure if you might have seen this one already but we've got info on this error and how to resolve it in this Help article here -
Common ATO STP Errors in Reckon GovConnect
Photo of Ron

Ron

  • 270 Points 250 badge 2x thumb
I've seen it, there was nothing helpful in that article, I have tried everything, uppercase, lowercase, there is nothing wrong with the employee details, there is only one employee, there are no special characters, the company details are correct in the profile, and I have submitted the STP over 50 times, and I still get the same error.