STP Error - Text character must be...

  • 1
  • Question
  • Updated 9 months ago
  • Answered
I've just lodged my usual STP lodgement and it's come back with the error: 

Error message

  • A text character must be one of the following: A to Z a to z 0 to 9 ! @ $ % & * ( ) - = [ ] ; : ' " , . ? / or a space character
I had a look at the previous lodgement and it looks like that one had the same error as well. When I compare the employee names between the lodgements that failed and the last lodgement that succeeded, there was only one additional name which had no special characters and the rest of the employees remained the same.

I've attempted removing special characters from names and resubmitting, but it's still showing the same error. Is it possible to pinpoint which line is causing this error, or what would be the next steps in order to get this resolved.

Photo of Ben


  • 362 Points 250 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Rav

Rav, Community Manager

  • 104,728 Points 100k badge 2x thumb
Hi Ben,
Were you able to check other fields as well for any invalid characters eg. employee address fields etc.

If you can't see anything there, it might be worth giving our technical support team a buzz as they may potentially be able to validate the JSON file which hopefully isolates where the problem is.
Photo of Ben


  • 362 Points 250 badge 2x thumb
That did the trick! I didn't realise the addresses pulled through too.
Photo of Stephanie


  • 184 Points 100 badge 2x thumb
Hi Rav. Is there a quick way to check other employee details? It's very time consuming when you have 300+ employees/week?