STP reporting issues ( Incorrect amount on employee's portal)

  • 1
  • Problem
  • Updated 3 weeks ago
I recently downloaded the STP app ( free version). My business is under company structure and I pay myself wages. I have submitted 3 x pay run so far and all successful. However when I checked on my personal Mygov account, it shows that the wage I received from my company is incorrect ( double of amount I reported) . I checked on the reporting history on both STP app and Business portal, they both showing correct amount. Its only incorrect on my personal Tax portal Mygov. I called ATO, they said it must be the software problem and ask me to contact Reckon.  And I realised that the GST branch on STP app is showing number 1, however on the company business portal it says branch 2? I am not sure if they are related or it may be the cause of the issue. Can anyone please help. Thanks
Photo of Vincent Pang

Vincent Pang

  • 100 Points 100 badge 2x thumb
  • fustrated

Posted 3 weeks ago

  • 1
Photo of Robyn Kelly (Partner)

Robyn Kelly (Partner), Accredited Partner

  • 7,404 Points 5k badge 2x thumb
Did you enter year to date amounts on the STP App when starting Vincent?  You can Can you do a pay summary report on the App and see what the figures are there?  Go to the employee to do the pay summary.
Photo of Vincent Pang

Vincent Pang

  • 100 Points 100 badge 2x thumb
Hi Robyn,
Thanks for your reply.
I believe I did put in the YTD when I setting up the employee (myself).
I did the negative adjustment on the pay run and it seems all looks good now.
Thanks