Unable to find default mail provider in Windows Registry.

  • 8
  • Problem
  • Updated 3 years ago
  • Solved

I have recently installed Reckon Accounts EasyStart: First Business Edition 2013 on my Windows 8.1 64-bit notebook.

I cannot email an invoice.  I keep getting the message "QB was unable to find your default mail provider in Windows Registry.  Your form will not be emailed" and "An internal error occurred while preparing your message.  It has not bee sent.  (MAPI error code 00000000 (0) at line 468 in sendemail.cpp)".

I searched the knowledge base and tried the suggestions there (set and reset the default email including making sure the relevant registry entries are correct) but I continually get the above error.  I have tried changing to Mozilla Thunderbird and Windows Live Mail.

And to top it all off Reckon support won't help unless I pay $4.90 per minute.  I do not see why I should have to pay for a bug with their software.

Has anyone has the same issue and found a solution?

Photo of Upyou

Upyou

  • 200 Points 100 badge 2x thumb
  • frustrated

Posted 5 years ago

  • 8
Photo of Hoang

Hoang, Alum

  • 922 Points 500 badge 2x thumb
Hi Heidi,

Welcome to the Reckon Community.

If you still cannot email you can try modifying the QBW.INI file located at C:\Users\Public\Documents\Intuit\QBW.ini and add the following lines at the bottom of the  file.  To open it, right click, select Open With and choose Notepad:  Scroll to the bottom of the file and add:

[DEBUGGING]
SIMPLEMAPI=1

Close & Save the file then restart Reckon Accounts and try again. 

Regards,
Hoang
Photo of Sandra

Sandra

  • 64 Points
hI, how do I save the file in .ini format and where do I save it?
Photo of Upyou

Upyou

  • 200 Points 100 badge 2x thumb

Thanks Hoang but I tried that also with no effect.
Photo of Hoang

Hoang, Alum

  • 922 Points 500 badge 2x thumb
Hi Heidi,

Thanks for getting back to me, just want to let you know that we have limited support with thunderbird and windows live mail.

We only support Microsoft Outlook as the mail client excluding Outlook 365. However, I will try my best to help you out.

Please try the following instructions;

1.   
From the Windows Control Panel > Select View By Category View > Programs > Default Programs > Set your default programs;

2.    Select Windows Live Mail in the Programs table;

3.    Click on Set this program as default and click OK;

4
.    From the Start menu type regedit in the Start search field;

5.    Click regedit.exe in the Programs list
Create a backup of your Registry by File > Export > Export Range > All;

6. Locate HKEY_CURRENT_USER > Software > Clients > Mail (The data field will now be called Windows Live Mail);

7. Now locate HKEY_LOCAL_MACHINE > Software > Clients > Mail. The data file does not automatically update, so you will be required to manually modify it;

Double click on the (Default) string to edit it and replace the text with Windows Live Mail

8. Click OK and Close the Registry window;

Open Reckon Accounts and send an email to confirm proper operation. Please let me know how it goes.

 

Regards,

Hoang

Photo of Tapps

Tapps

  • 100 Points 100 badge 2x thumb
I'm running Win7 SP1 with Small Business 2014 and Mozilla Thunderbird (substituted for Live Mail as below) as my email. I upgraded from 2008 to 2010 years ago and rolled it back to 2008 when I couldn't resolve the email issue way back then. Nothing has changed. 
Using the steps above I have managed to get QB to email an invoice but it is being sent as a generically name moz.mapi file. My client needs to be educated to save it as a *.pdf file every time. This is OK (but not ideal) for my regular customers but completely useless with new customers. Any advice to resolve this would be fantastic.
Photo of Mike Maltby

Mike Maltby

  • 350 Points 250 badge 2x thumb

Has anyone got this to work on Windows10? A customer of mine upgraded last  week & was then unable to send forms from Reckon Accounts 2013 via Live Mail. The post above got her working for a few days but then it broke again. Now get the “This action cannot be completed because the other program is busy” error, followed by “An internal error occurred while preparing your message. It has not been sent. (MAPI error code 00000000 (0) at line 921 in sendemail.cpp”.

Photo of John G

John G, Information Support Analyst

  • 27,450 Points 20k badge 2x thumb
Hi Mike,

Nice to hear form you again.  

Please see our statement on Windows 10 at: Reckon Accounts and Windows 10.

Reckon Accounts is configured to work with Microsoft Outlook.  If you are using Windows Live Mail you may need to make some configuration adjustments to make it work.  Some ideas are contained here , although this article is a bit old.  


Hope this helps,


regards,
John
Photo of Mike Maltby

Mike Maltby

  • 350 Points 250 badge 2x thumb
Thanks John. I had seen those articles & they certainly helped to resolve the initial -20 printer not activated error, & I did manage to get WLM working for a while. Unfortunately the "Server busy" error that now pops-up is not benign. After a number of clicks on the switch to button the "An internal error.." message appears bringing the process to a halt. I think my trick is to understand what has caused these two errors to reappear several days after RA & WLM were working ok. I know WLM isn't supported on RA, but it would be useful to be able to get it to work for people that don't have Outlook.
Photo of Upyou

Upyou

  • 200 Points 100 badge 2x thumb

Thanks for trying to help, however I tried this and it still doesn't work.
Photo of Hoang

Hoang, Alum

  • 922 Points 500 badge 2x thumb
Hi Heidi,

One last thing you can try is by running Reckon Accounts in Windows 7 compatibility mode.

Right click on Reckon Accounts icon on your desktop > Properties > Compatibility > Tick both options "Run this program in compatibility mode for Windows 7" and as well as "Run this program as an administrator".

Also make sure the port for QuickBooks V4 PDF converter under devices and printers is set to NUL not LPT1.

If this still doesn't work then unfortunately you will need to use Microsoft Outlook as the mailing program.

Regards,
Hoang
Photo of Denis Stanes

Denis Stanes

  • 60 Points
Hello Heidi........I have been reading your comments about your problem, if you still have it. I have just encountered the same problem for the second time, and to me, this is a 'bug' in the programming which should be fixed. I to, was not going to pay $4.90 p/m for a problem that clearly belongs to Reckon. I managed to fix the problem myself following the directions directly above.

Regards

Denis Stanes
Wonthaggi, Victoria 
Photo of John G

John G, Information Support Analyst

  • 27,450 Points 20k badge 2x thumb
Hi Dennis,

Thanks for sharing your experience.

Great to hear your issue has been resolved.  

cheers,
John
Photo of Sabrina

Sabrina

  • 110 Points 100 badge 2x thumb
Hello, I am having a similar problem.  I have Easystart and I cannot e-mail any invoices.  I have windows 7 and I also have Outlook 2007 but I am still unable to e-mail any invoices.  Could someone please help me?  Thanks Sabrina
Photo of Mirko

Mirko, Alum

  • 34,812 Points 20k badge 2x thumb
Hi Sabrina, welcome to the Reckon Community. So we know where you are at, can you confirm to me if you have tried the above steps suggest by Hoang? Thanks, Mirko
Photo of Sabrina

Sabrina

  • 110 Points 100 badge 2x thumb
Hello Mirko,  yes I tried the above suggestions before I posted so I wasn't wasting anyone's time.  I have the invoice up and click on the e-mail drop down and click on e-mail invoice, it sits there and thinks about it and comes up not responding and I have to manually close the whole program down and open it up again for it to do anything.  I left it sitting there waiting for a response for a couple of hours the other day and it still did nothing except say at the top 'Not Responding'.  Please help.  Thanks Sabrina.
Photo of Mirko

Mirko, Alum

  • 34,812 Points 20k badge 2x thumb
Hey Sabrina, sounds like your PC is not allowing Reckon Accounts access to your email client. Try to run as Win XP SP2 by right clicking on accounts and selecting properties> compatibility tab> run in compatibility mode for Win XP Service Pack 2.

If this does not work for you, try to re-setup MS Outlook as your primary email client.
To set this up go into Control Panel > Default programs > Set default programs. Then select Outlook on the left hand side and click on 'Set this program as default' (see image below).

 

Thanks, Mirko
Photo of Sabrina

Sabrina

  • 110 Points 100 badge 2x thumb
Hello Mirko,  Thank you for your reply.  I have tried both suggestions above, the first suggestion did nothing by itself but when I combined it with the second suggestion it worked.  It let me e-mail an invoice and then the next invoice I needed to send, it froze the program and said not responding.  I had to shut the program down twice until it would let me send another e-mail.  I double checked that all settings that were changed stayed changed and I even shut down the computer and started it up again.  Easystart is not letting me e-mail more than one e-mail in one session.  Any more help would be grateful.  Thanks Sabrina
Photo of Ifti

Ifti, Product Manager

  • 6,524 Points 5k badge 2x thumb
Hi Sabrina,

Thanks for the update.

I'd like you to try below KB Article which just helped another customer yesterday.

http://kb.reckon.com.au/issue_view.asp?ID=5101

Please let us know the outcome to see if it fixes for you too.

Thanks

Ifti
Photo of Sabrina

Sabrina

  • 110 Points 100 badge 2x thumb
Hello, Thank you to all who tried to help me with my problem.  None of the above suggestions helped to solve whatever problem I had with the Reckon Easystart not e-mailing from my PC, so I loaded the Reckon Easystart onto my laptop and it all works perfectly.  I think I will get an expert to look at my PC and find out what is wrong with it.  Again I thank everyone for there patients and suggestions.

Thank you
Kind Regards
Sabrina
Photo of Greg Skinner

Greg Skinner

  • 60 Points

H thanks this change as well as previous one listed ALWAYS works for me, I have finally printed it off so next time my pc updates and looses the settings that work for quickbooks, I wont have to waste half a day googling answer! thanks so much


Photo of Margaret Sleigh

Margaret Sleigh

  • 370 Points 250 badge 2x thumb
I already use Outlook and I still get those problems. My solution will be to find another accounting program.Reckon has got to get it into their heads that if business people can't send out invoices and get money in then the program is useless. They can only spend a short while wasting time looking for a solution. They must migrate to another program or go broke. The Accounting program is there to serve the business needs not the other way round.
 
Photo of David Cashmore

David Cashmore

  • 110 Points 100 badge 2x thumb
In case anyone wants to try something else that worked for me. Note that this does sacrifice security but at least it worked.

I have Windows 7 64bit , Office 2013 64bit & Reckon Accounts Premier 2014

Added the following to the bottom of QBW.ini (may not be required but added as per Hoang post above.)
[DEBUGGING]
SIMPLEMAPI=1

Then I disabled Outlook security for SimpleMAPI
Edit the registry and add 3 DWORDS each with a value of 2 (use whatever version of Office you have installed)
HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\15.0\Outlook\Security
PromptSimpleMAPISend
PromptSimpleMAPINameResolve
PromptSimpleMAPIOpenMessage
Regards
Dave
(Edited)
Photo of Suzanne Osborne

Suzanne Osborne

  • 70 Points
We have Windows 8.1 64bit and Reckon Accounts Plus 2014.
We tried everything to try and make it work with Thunderbird, and finally succeeded by using the instructions Haong above but substituted Mozilla Thunderbird where necessary, as below. Hope this helps someone else as even phone support could not help.

1.    From the Windows Control Panel > Select View By Category View > Programs > Default Programs > Set your default programs;

2.    Select Mozilla Thunderbird in the Programs table;

3.    Click on Set this program as default and click OK;

4.    From the Start menu type regedit in the Start search field;

5.    Click regedit.exe in the Programs list
Create a backup of your Registry by File > Export > Export Range > All;

6. Locate HKEY_CURRENT_USER > Software > Clients > Mail (The data field will now be called Mozilla Thunderbird);

7. Now locate HKEY_LOCAL_MACHINE > Software > Clients > Mail. The data file does not automatically update, so you will be required to manually modify it;

Double click on the (Default) string to edit it and replace the text with Mozilla Thunderbird

8. Click OK and Close the Registry window;

Photo of Tapps

Tapps

  • 100 Points 100 badge 2x thumb
I'm running Win7 SP1 with Small Business 2014 and Mozilla as my email. I upgraded from 2008 to 2010 years ago and rolled it back to 2008 when I couldn't resolve the email issue way back then. Nothing has changed. 
Using the steps above I have managed to get QB to email an invoice but it is being sent as a generically name moz.mapi file. My client needs to be educated to save it as a *.pdf file every time. This is OK (but not ideal) for my regular customers but completely useless with new customers. Any advice to resolve this would be fantastic.
Photo of Christine Price

Christine Price

  • 102 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled
I have just tried to email and it states it cant find my default email in the windows registery..


I have just installed my reckon accounts onto my new laptop. I have finally managed to get everything working now. I have just tried to email and it states it cant find my default email in the windows registery. I know there is something that I have to do but not sure as this has happened before. Any help would be appreciated. Thanks
Photo of Grant Brydon

Grant Brydon

  • 80 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled Reckon was unable to find your default mail provider in the windows registry. You....

This is the message I get when trying to email an invoice to a customer. I use a gmail account. How can I fix this problem?

This conversation is no longer open for comments or replies.