Upgraded to 2017 and now cannot email from quickbooks. The Mapi error from previous versions is back

  • 2
  • Question
  • Updated 1 month ago
  • Answered
Just upgraded to Reckon Accounts 2017 (from 2016) and am having the same issues with emails since going to win 10. Previous versions I have been able to use the workaround of Running both Outlook and QB32 as administrator and emails have been working fine but with 2017 it appears to be a dead end. Trying to run as administrator I get the message that file couldn't be found and wont open but running as std user and the file opens fine. It just cannot email invoices, quotes etc. Anyone encountered this and have any idea how to overcome this ? It looks like I will need to run all systems back on 2016 for now until we can get 2017 working.
Photo of Orkun Evren

Orkun Evren

  • 1,244 Points 1k badge 2x thumb

Posted 1 year ago

  • 2
Photo of Phil Dodds

Phil Dodds

  • 150 Points 100 badge 2x thumb
I had an issue with 2016 Premier and outlook not working together and the work around was to change the Outlook email settings to plain text rather than Rich or HTML. Still have issues with people opening their payslip with an apple device finding the attachment changed form PDF to Win.Dat
Photo of Orkun Evren

Orkun Evren

  • 1,244 Points 1k badge 2x thumb
it looks like after 3 versions, 2015, 2016 & now 2017 the email issue is not a priority with the Reckon development team. They are aware of the issue and it is the same workaround except this time right click quickbooks icon and in compatibility tab check " Run as administrator " Still not a fix but another patch up for 3rd year running on the same issue. Now emails work again albeit still have to click " switch to " with every email if you don't press send within a few seconds. Not ideal for someone using the enterprise version with 10 users.
Photo of John G

John G, Information Support Analyst

  • 27,360 Points 20k badge 2x thumb
Hi Orkun & Phil,

Here are a couple of other steps to try if you continue getting MAPI errors...

from KB5397:
Attempts to email may still fail if the user emailing does not have full permissions to the Reckon Accounts Business 2017 application, so give the user Full Control permissions
  1. Close Reckon Accounts Business 2017
  2. Right click the launch icon and select Properties > Security > Edit
  3. Highlight the user
  4. In the box Permissions for <User>, tick the Allow box for Full Control.
  5. Click OK > OK to save and close.

Another step to try is to adjust the .ini file (KB5411)

Close Reckon Accounts
Open the QBW.ini file in your installation directory (C:\Program Files (x86)\Intuit\Reckon Accounts 2015) with Notepad, scroll to the bottom and add:
[DEBUGGING]
SIMPLEMAPI=1
Launch Reckon Accounts and in Online Preferences, untick the box Display each email when sending more than one.


Hope these steps help.


regards,
John
Photo of John G

John G, Information Support Analyst

  • 27,360 Points 20k badge 2x thumb
Hello Phil,

Regarding the win.dat issue - or is it a winmail.dat?

This is an Outlook issue, and more to do with the recipient and not the sender or the programme being sent from.  

Microsoft have an article on this issue and what your receiver can do about it at:
http://support.microsoft.com/en-us/kb/138053

They say:
When an end user sends mail to the Internet from an Exchange Windows or Outlook client, a file attachment called Winmail.dat may be automatically added to the end of the message if the recipient's client cannot receive messages in Rich Text Format (RTF). The Winmail.dat file contains Exchange Server RTF information for the message, and may appear to the recipient as a binary file. It is not useful to non-Exchange Server recipients. 

Slipstick Systems, a US company that specialises in researching and solving problems with Microsoft Outlook and Microsoft Exchange Server, has an article on the issue which does include directions for Outlook 2016:  Outlook is sending winmail.dat attachments.


Hope these articles help you and your recipients get around this issue.  

Our KB on the issue, now a little dated, is at:  Winmail.dat rather than invoice or statement attachment is received by some email recipients.



regards,

John
Photo of kevmeister68

kevmeister68

  • 60 Points
I have spent several days trying numerous options to overcome a similar problem on Windows 7 running Reckon Accounts 2018. Two machines: both running Reckon Accounts 2018 Premier, both running Outlook 2013. Same user logged into both (at different times). Same business-grade anti-virus software. One system can send emails without any prompts appearing, and one gets prompts appearing.

The first thing I'd like to note is that I don't believe this is purely a QuickBooks/Reckon problem. Outlook deliberately has these security mechanisms in place to avoid malware sending emails through MAPI (which is the API that QuickBooks uses to send emails via Outlook).


The usual "first step" in trying to resolve this issue is to run Outlook as an Administrator, choose File->Options, go into the Trust Center Settings area, and set the Programmatic Access option to "Never Warn". In our case that did nothing -- the messages were still appearing.

One of the suggested fixes by reckon is to modify the QBW.INI file and add the [Debugging]SIMPLEMAPI=1 lines to that file file. With the Trust Center Settings set to Never Warn as described above, the Outlook prompt still appears with or without these lines in QBW.INI.

The solution that I found did work is described on the following link:

http://noexcusenow.blogspot.com/2010/04/disabling-programmatic-access-security.html

this involves applying some registry settings to the Logged In User's policies.

I still cannot explain why one machine has the problem and one does not (I looked for the registry settings on the "working" machine and they are not there), but the above changes eliminated the Outlook popup prompts. I hope this solution helps others.