Workstation seems to be trying to open company in single user mode even though it's set to multi user.

  • 1
  • Question
  • Updated 4 years ago
  • Answered
A business I'm dealing with has 2 PCs that access the same company file. One of them hosts the file (call it PC1) and the other accesses it across the network (call it PC2). Both are set to open the company file in multi user mode.
If PC1 opens the company file first, PC2 can't connect. However if PC2 opens the file first, PC1 reports that the file is open in single user mode. In order to connect PC1 I then have to switch to single user mode on PC2 and then back to multi user mode. If PC2 exits Reckon and then reopens it, it cannot reconnect as long as PC1 has it open.
Photo of Jason Thornton

Jason Thornton

  • 200 Points 100 badge 2x thumb

Posted 4 years ago

  • 1
Jason

Which product and which version are you running?
AND:  How many version of Reckon are you running on each PC?
AND:  what operating system are you running on each PC?

There can be confusion depending on which machine thinks it is the 'host' of the 'shared' file on the network.


Gary Pope
m: 0408994799 
An Accredited Partner- Consultant (VIC. Aust)
http://www.alchester.com.au/reckon-ac...
"Working with Accountants/Bookkeepers PPs/APs, as an
independent IT Professional and retired FCPA Accountant"
Photo of Jason Thornton

Jason Thornton

  • 200 Points 100 badge 2x thumb
G'day Gary,
It's Reckon Accounts Premier 2013 21.1. Both PCs are running the same version.
Both PCs are running Windows 7.
And is there only the ONE version of Reckon on each machine?  (the 2nd question of the three)?

If only the one version on each,  then ensure that there is only ONE of the two machines acting as the hosting SERVER,  and that the other machine was only setup as a workstation (which depends on the main PC as a the server).

Gary
Photo of Jason Thornton

Jason Thornton

  • 200 Points 100 badge 2x thumb
I uninstalled all versions of Reckon off both machines and reinstalled. Only PC1 is hosting. The issue remains. Ran Quickbooks File Doctor and Quickbooks Network Diagnostics. Disabled firewalls and antivirus. Still no luck.
Photo of Jason Thornton

Jason Thornton

  • 200 Points 100 badge 2x thumb
Hosting Computer
Photo of Jason Thornton

Jason Thornton

  • 200 Points 100 badge 2x thumb
(Edited)
Photo of Reckon FAQs

Reckon FAQs, Employee

  • 10,138 Points 10k badge 2x thumb
Hi Jason,

Welcome to the Reckon Community.

The (-6000,-77) error can result from a few sources like:
  • The company file is located on external media, like a USB stick;
  • BitDefender software may be blocking communication between computers on a network; 
  • The permission settings are incorrect for the folder hosting the company data file; 
See our article: Error (-6000, -77) when opening a Quickbooks company file for steps to try.


Hope this helps,

regards,
John
Photo of Jason Thornton

Jason Thornton

  • 200 Points 100 badge 2x thumb
G'day John,
The company is located on an internal HDD on the host.
BitDefender is not installed and I tried disabling the firewall and antivirus software.
As shown in the screenshots, the permissions are correctly set up.
Photo of Reckon FAQs

Reckon FAQs, Employee

  • 10,138 Points 10k badge 2x thumb
Hi Jason, 

Ok, lets go to some basics...

Is your version 2013 (v22) or 2012/13 (v21)?
Ctrl+1 will give you the basic information.

Close all QuickBooks and start with the Host PC1.
In the folder holding your datafile, delete the file with the .ND extension.

check the Properties > Security on the folder containing the company file.
In Group or user names, do you see QBDataServiceUserXX, where the XX is the version number of your Reckon Acounts programme?
If not, create it:  Add > enter the name and click Check Names, then OK it.
Back on the Security screen, give this user Full Control.

Now try again.

if that works try opening the file from PC2.


Hope this makes a difference.



regards,

John
(Edited)
Photo of Jason Thornton

Jason Thornton

  • 200 Points 100 badge 2x thumb
G'day John,
It's v22.
I've already tried deleting the .ND file and QBDataServiceUser22 already has full control of the folder.
Photo of Reckon FAQs

Reckon FAQs, Employee

  • 10,138 Points 10k badge 2x thumb
Hmmm....

Check out the pointers in Error opening a company file on a QBi network.  

Check that PC1 is hosting multi-user access.  that is, File > Utilities you see the option Stop Hosting multi-user access.

Check that PC2 is not hosting multi-user access.  that is, File > Utilities you see the option Host multi-user access.

Check that both PCs have under the File option Switch to Single-User mode,


regards,
John.

BTW, the PCs are running Pro editions of Windows 7?
Photo of Jason Thornton

Jason Thornton

  • 200 Points 100 badge 2x thumb
G'day John,
PC1 is hosting, PC2 is not. PC1 has the server services installed.
Both list "switch to single-user mode".
Yes both are Win 7 Pro.
(Edited)
Photo of John G

John G, Information Support Analyst

  • 27,490 Points 20k badge 2x thumb
Hi Jason,

Next suggestion - back to square 1:

Switch off Hosting - both PCs to show the option Host multi-user access.
Are there any other PCs in the network that have Reckon Accounts installed?  Make sure these are not hosting.  
Exit Reckon Accounts on all PCs.
Delete the .ND file in the company file directory.
On PC1 (where the company file resides) launch Reckon Accounts and open the Company file through the path File > Open or Restore...
What is the file path to the company file?
Are there any messages and/or errors on opening?
Close the company file.

Open the company file again on PC1 the same way, and when selecting the company file, tick the box at the bottom of the Open a Company screen for:  Open file in multi-user mode.
Make sure the option under File is Switch to Single user mode.
File > Utilities > make sure you see the option Stop Hosting multi-user access.
Close Reckon Accounts

Launch Reckon Accounts - does it open the company file in multi-user mode without any problems?

Keep file open on PC1 and go to PC2
Launch Reckon Accounts and open the Company file through the path File > Open or Restore...
What is the file path to the company file? (the same as on PC1?)
Are  there any messages and/or errors on opening?

If you still have an error opening, then close the company file on PC1 and close Reckon Accounts there.
Now does PC2 open the company file?
Can PC1 open the company file without error?



regards,
John
Photo of Jason Thornton

Jason Thornton

  • 200 Points 100 badge 2x thumb
There are no other computers on the network with Reckon.
Company file on PC1 is in Documents in a Quickbooks folder. PC2 uses that folder mapped to a network drive Z: I can navigate to the location fine.
There are no errors when I open the file from either computer alone. As before, if PC1 attempts to open the file when it's already open on PC2 I get the single-user mode error, and if PC2 attempts to open the file when it's already open on PC1 I get the -6000, -77 error.
Photo of Reckon FAQs

Reckon FAQs, Employee

  • 10,138 Points 10k badge 2x thumb
Hi Jason,

For a test, create a new company file and try to open it from both PCs - same result?


regards,
John
Jason - where are you located?  I'm in The Basin,  eastern suburbs of Melbourne - this issue seems to have bounced around far too long, and perhaps a Teamviewer session or a  chat session would assist you.  DO you want to call me on 0408994799 and I'll return a call to you if in Australia.,

Gary
(Edited)
Photo of Jason Thornton

Jason Thornton

  • 200 Points 100 badge 2x thumb
So you think it might be specific to the company file John? I'll try that the next time I'm on site. The Quickbooks File Doctor didn't return any errors however except that QBDBMgrN wasn't running.

I'm in Warrnambool Gary. Thanks for the offer, however I doubt my boss would be keen on me letting a random guy on the internet remote into the system lol. Official support staff he'd be cool with it.
That's fine, Jason.  I've been called a number of things in my 40 years of supporting businesses from Geelong through to Portland (my family roots from Narrawong and Terang)....  but I won't take offence at your concerns.  With Teamviewer you would be observing what I'm doing as I do it of course.  But,  come back if still in trouble.    

Cheers

Gary
Photo of Reckon FAQs

Reckon FAQs, Employee

  • 10,138 Points 10k badge 2x thumb
Hi Jason,

How was the application installed on each of the PC's?

Hosting PC must install Reckon Accounts with method:  Reckon Accounts and company File Server.

Other PC can be installed Reckon Accounts Only.

Try uninstalling Reckon Accounts from Hosting PC and reinstalling.  



regards,
John.
Photo of Jason Thornton

Jason Thornton

  • 200 Points 100 badge 2x thumb
I recently reinstalled both. The hosting PC with server and the client PC without. It didn't make any difference.
Photo of Michael

Michael, Alum

  • 772 Points 500 badge 2x thumb

Hi Jason,

did you tried to configure the firewall port 10176 and also grant exceptions for the .exe files?

This applies to both the Windows firewall and any 3rd party anti-virus/firewall programs.

For more information on this, please refer to http://kb.reckon.com.au/issue_view.asp?ID=220

Hope that helps you.

Regards,
Michael

Photo of Jason Thornton

Jason Thornton

  • 200 Points 100 badge 2x thumb
Yes I did. I also tried disabling the firewall and antivirus.
If it was a firewall issue wouldn't that mean it would never connect? That's not the case.
Jason

Try testing your two PC's but use  the test company file instead,  to confirm that idea of John Gajewski two weeks ago (above) - or create your own test company to ensure that it is not a corrupted QBW file that you are suffering from here.   And make sure there are no services running the DBmanager other than the one needed for the v22 of your 2012/13R2 file structure of Reckon.

Gary Pope
m: 0408994799 
An Accredited Partner- Consultant (VIC. Aust)
http://www.alchester.com.au/reckon-ac...
"Working with Accountants/Bookkeepers PPs/APs, as an
independent IT Professional and retired FCPA Accountant"
Photo of Michael

Michael, Alum

  • 772 Points 500 badge 2x thumb

Hi Jason,

can you email your contact details to community@reckon.com
so that we can get in contact with you.

Regards,
Michael

Photo of Jason Thornton

Jason Thornton

  • 200 Points 100 badge 2x thumb
Thanks for the help guys. After trying a sample company file, which worked fine, it looks like the issue is with the company file not the software. I advised the user to archive the file and start a new one.
Jason

I'd be curious if the LOCATION of the real company file sits in,  has different hosting service/sharing permission versus the SAMPLE company.... Might lead you to the cause.

Gary
Photo of Jason Thornton

Jason Thornton

  • 200 Points 100 badge 2x thumb
I copied the sample file to the same folder as the real company file before testing.
Jason

A reasonable deduction then,  as you stated,  that the real company file was corrupted for reasons unknown then.  Moving the sample as you've done,  subject to the privileges of who you are logged in as at the time of such copying,  perhaps exonerates the the question of permissions/access, and leaves you with the conclusion of a corruption.  Thanks for clarifying that step though, it will help others debug a similar situation.

Gary