You must specify a tax agency for the tax account

  • 1
  • Question
  • Updated 3 years ago
  • Answered
We have upgraded from QuickBooks 07/08 through to Reckon Accounts Premier Edition 2016.  I went through the upgrade process step by step to get to the current year.  My problem is, I am trying to enter a BAS refund from the ATO.  I do this by creating a new sales receipt, then selecting the relevant item and inserting the amount.  When I click on Save it comes up with "You must specify a tax agency for the tax account".  I have been into the supplier centre - there are two ATO's listed.  One has been selected as a tax agency, the other not.  What can I do to overcome this problem, has anyone else had a similar problem?
Photo of Carol

Carol

  • 140 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Shane

Shane, Employee

  • 7,448 Points 5k badge 2x thumb
Hi Carol,

To enter a tax refund go to Suppliers > Tax Activities > Manage Tax > Receive a Tax Refund.  Enter the amount of the refund and click Save and Close.

Regards,
Shane.
Photo of Carol

Carol

  • 140 Points 100 badge 2x thumb
Thanks for your reply Shane.  I have just done this in one of our Reckon files and it worked, thank you.  In our other company  that we run accounts for, I receive the below message "You have no tax  agencies.  Was wondering if you have any solutions to the below error messages? 
Photo of Heather Sanders

Heather Sanders, Accredited Partner

  • 680 Points 500 badge 2x thumb
Change the supplier in edit, preferences, tax, tax agent. Choose the one you have set in the suppliers list. Hope this helps. Heather