Emailing Invoices from Reckon Accounts 2016, Outlook 2016, Windows 10

Martin FrenchMartin French Member Posts: 3
edited March 2018 in Accounts Business Range
Hi there,

A client of mine is unable to send Invoices from Reckon Accounts 2016 using Outlook 2016 (non-365) on Windows 10.

They're getting a MAPI error code and have tried many of the solutions posted within the community. 

Are there any troubleshooting steps anyone can recommend?

Thanks,
Martin.

Comments

  • Lyn ManganLyn Mangan Member Posts: 9
    edited July 2016
    I had similar problems. My new Outlook will not Sync, yet it sends test messages just fine. My sent  invoices would get stuck in the outbox. I suspect there may be a problem because the Outlook email wants my Microsoft password (same email) not my server's email password. Or there are compatability issues between IMTP/SMTP/POP settings. After trying many online suggestions with various settings, uninstalling and reinstalling Windows/Reckon, etc, I found Reckon 2016 works with Gmail quite easily. After wasting a week, I finally started a new Gmail account, just for emailing invoices and statements, and forward it to my Bigpond email, which still works through WLM.  I'll wait for my Bigpond email to change to SMTP and not POP, and try again in a few months. I just had to find a way to email straight from Reckon. Hope this helps someone.
  • Martin FrenchMartin French Member Posts: 3
    edited July 2016
    Hi Andrew,

    Apologies, I should have been more specific.

    No the email never makes it to Outlook. Yes emails can be sent normally.

    The error message is:
    An internal error occurred while preparing your message.  It has not bee sent.  (MAPI error code 00000000 (0) at line 921 in sendmail.cpp)

    image


    Mail setup is set to use Outlook.

    I've tried a few things mentioned elsewhere including executing as Administrator (both quickbooks and outlook), granting Full Access privileges to Quickbooks, the SimpleMAPI flag in the ini file, and a few registry changes.

    Thanks for your time.
    Regards,
    Martin.

  • Martin FrenchMartin French Member Posts: 3
    edited July 2016
    Hi Lyn,

    Thanks for the suggestion. Unfortunately in our case the email never makes it to Outlooks outbox.

    It does sound like you were experiencing some mail server settings issues though and your interface between Reckon and Outlook was sound.

    I'd prefer to have emails sent from my clients domain so gmail wouldn't work for us. I've also tried using SMTP directly from Reckon to their ISP mail server and their private mail server, both to no avail.

    I feel like I've been battling invoice emailing for this client since back in the Quickbooks 2011/12 days! For something so simple, it's frustrating that it doesn't just work...

    Cheers,
    Martin.


  • Lyn ManganLyn Mangan Member Posts: 9
    edited July 2016
    Hi Martin
    I'm sorry that didn't help. Obviously, many people are still having email issues. I just needed to find a way around, and gmail works for now. I do not use Outlook 2016 - can't get it to work and I prefer Windows Live Mail. I used to get your message with Reckon 2015/ Win 8, and the administrator privileges or qbw.ini changes used to work. I submitted this comment with more details of my problem in another post:
    Hi. Win 10, Reckon Plus 2016 V101, Office 365, Bigpond email address, Windows Live, Outlook 2016. Help
    Windows Live Mail works fine so far for every other matter except Reckon. It stopped sending emails a few months ago after an update, so I have been printing, scanning and emailing as PDF attachments because it will not save invoices as PDF either.
    Cannot send emails direct from Reckon, although I found them sitting in Outlook 2016 outbox.
    I have uninstalled Reckon 2016 and re-installed V101 - no help there.
    I cannot revert to Win 7 as the external HD died with previous backup.
    I used to open both Windows Live and Reckon as administrator, and that would allow me to send invoices, but no longer works.
    QBW.ini debugging fix used to work, but doesn't anymore.
    I have a gmail account that I sent one invoice with, but cannot replicate that miracle.
    I do not know if this is an office problem, Reckon or Bigpond - or just me!
    There is a suggestion that Bigpond increased their password standards, so I have re-set my password there as well.
    Message reads: "The email service you selected to use currently cannot be reached. Please ensure you are connected to the internet before trying again. If the problem persists, etc". 
    There are so many conflicting settings regarding port numbers, etc for email settings, and after a few wasted days, I need help, please.
  • Lyn ManganLyn Mangan Member Posts: 9
    edited March 2018
    Thanks Andrew,
    I will try these out, although I don't get a MAPI error now; it just can't find my server. The debugging trick worked last year, and running mail and Reckon both as administrator worked then too, but not since an update months ago. You're right - it shouldn't be this hard!
    Cheers :)
    Lyn
  • Lyn ManganLyn Mangan Member Posts: 9
    edited July 2016
    Hi Andrew. 
    I have changed permissions as per kb but it makes no difference. I am already running IE11 as well. All that happened were more errors:
    Error: - -6123,0 Reckon Accounts is trying to access Company File...  and
    Reckon Accounts - unrecoverable error - Reckon has to close
    It is running okay again now, but I see if I run a compatibility check, it wants to check Win 8 and I am running Win 10.
    I'll stick with Gmail for now - at least it is working!
    Cheers
    Lyn
  • Lyn ManganLyn Mangan Member Posts: 9
    edited July 2016
    Thanks Andrew.
    After a phone call to support, they have recommended I stick with Gmail, as they cannot help if Outlook isn't working properly, but Microsoft support told me it's probably a Reckon add-in problem? 
  • Clare BuckleyClare Buckley Member Posts: 3
    edited October 2016
    come on Reckon only a few issues with this.................error occurred while preparing your message. It has not bee sent. (MAPI error code 00000000 (0) at line 921 in sendmail.cpp) this keeps reoccurring on my machine. HOW DO WE FIX THE PROBLEM Or do we change products as suggested above???/
  • Sue EllicottSue Ellicott Member Posts: 1
    edited November 2016

    I have tried everything including trying Gmail account, will not work with anything, never had any problems before with Reckon 2013-14 and Windows 7, I am going nuts, tried to adjust settings as suggested by one of Reckon desk links, still no good.

  • Reckon FAQsReckon FAQs Reckon Staff Posts: 700 ✭✭
    edited March 2017
    Hi Sue and Clare,

    Welcome to the Community, and sorry Clare for the delay in responding to you.

    Reckon Accounts Business 2016 should work seemlessly with Outlook 2016 on Windows 10.  

    Check for the following:
    Outlook 2016 is your default email client;
    In Reckon Accounts, Edit > Preferences > Send Forms > My Preferences > Email Provider is set to Outlook and not Hotmail/Outlook.com;
    Do not run either Reckon Accounts or Outlook in Run As Administrator mode.

    Next, consider the KB article Attempt to email from RAB2016 through Outlook2016 fails with a MAPI error.

    Also, these older articles may be of help.
    MAPI error code 00000000 (0) at line 947 in sendemail.ccp in Accounts Business 2014
    MAPI error at line 947 in sendemail.ccp when emailing from QuickBooks through Outlook 2010.

    Finally, consider there may be an issue with your Office installation - you may want to talk to your IT professional about it.  Consider:
    Updates to Office Suite;
    and if you are getting errors emailing outside Reckon Accounts, do a repair/reinstall of Office.


    Hope this helps

    regards,
    John

  • MaxMax Member Posts: 2
    edited May 2017
    In case anyone isn't aware, you can now put SMTP mail settings directly into Reckon Accounts. For details see: http://kb.reckon.com.au/issue_view.asp?ID=5391

    You can set it to BCC your address if you like a copy in your mailbox, then set a rule in your email client to file it automatically.
This discussion has been closed.