error code (6000,83)

JohnJohn Member Posts: 12
edited October 2018 in Accounts Business Range
Our files are saved on a NAS drive, there's no single controlling it, it's just an automatic backup drive. I've read the previous posts regarding (6000,83). I've followed the instructions to solve the permission issue and didn't work.

There are three computers using reckon, only one is able to open the file. Here're the attempts.

Attempt 1.
Using that working computer to login in and go into the multi-user mode. Then use the target computer to login in and comes up with a warning saying that it may be due to a firewall issue without a specific error code.

My firewall is fully disabled though.

Attempt 2.

With the working computer logged out,
use the target computer to login in and then
comes up with the error code (6000,83).

My firewall is fully disabled though.

Attempt 3.
Move the file from the NAS driver to the local one and login in.

the error code (6000,83).

Attempt 4.
Try to create a new file on the local drive and fail with the
error code (6000,83).

Note: All had been working well with the firewall on until last friday and just over a weekend, without doing any change, it's simply refusing to work.

Really frustrating.

Please help.

P.S. I've tried this.

And I don't think it would be appropriate to call a paid technical support because it's very likely to be an inherent problem of the software.

And it's urgent.



  • MirkoMirko Alumni Posts: 2,054 ✭✭
    edited November 2015
    Have there been any Windows updates? - Trying to work out what has changed.

    Have you tried removing the .ND file so it recreates? 

    Try turning Multi-User mode off and then on?

    Which anti virus program are you using?
  • JohnJohn Member Posts: 12
    edited January 2015
    Have there been any Windows updates?
    Have you tried removing the .ND file so it recreates? 
    Try turning Multi-User mode off and then on?
    Yes. multi times
    Which anti virus program are you using?
    AVG. Doing tests with it fully disabled
  • JohnJohn Member Posts: 12
    edited January 2015
    I just did another one.

    Not even close AVG but also disable the Windows firewall.

    And still the same.
  • ShisirShisir Reckon Staff Posts: 257
    edited August 2018

    Hi John

    Thank you for asking Reckon Community.

    Please take care as the NAS drive is not an ideal solution for hosting the file in Multi user environment. As NAS drive do not have the operating system. Users are required to install the Reckon accounts Database server manager (DBSM) on the server where the data file is hosted.

    Since the DBSM can only host the file situated on local Drive only, it wont be able to scan the file on the NAS, hence you will get different issues.

    So I will recommend doing below;

    1. Make sure Reckon Database server manager is installed on the server where your data file is located.

    2. Make sure step 4 from solution 1 on KB 404  is done

    3. Please turn the Hosting On on the server PC and turn it off from the other PC where it is not hosting from. (as suggested on solution 2 on above KB link)

    4. Make sure you have at minimum Professional version of windows operating system.

    5. Please add the exception to your firewall as suggested here

     Please let me know how it goes.



  • JohnJohn Member Posts: 12
    edited January 2015
    Thanks Shisir.

    It's bad news.

    I've tried to moved the files from NAS drive to a local computer and make it as a server. (and done the whole process again) Still doesn't work.

    What's more strange is I can't even create a new file on the problematic computer, the same error code pops up!!

    What's next?

  • JohnJohn Member Posts: 12
    edited January 2015
    It's working!!

    I kept trying for another while.

    I don't know which step makes the difference.

    I suspect it's "verify or rebuild the data"

    Whoops. Such a relief.
  • ShisirShisir Reckon Staff Posts: 257
    edited December 2016

    That's Great news John.

    thank you for letting us know.



  • Steve CookSteve Cook Member Posts: 161 ✭✭
    edited July 2016

    I have a client with this exact issue - error code (6000,83)
    Was not an issue with RA2015
    Issue started after Reckon upgrade to RA2016
    So something has changed in RA2016 to cause this issue

    All shared data on NAS drive
    NAS has a dedicated shared folder, only for Reckon data
    2 computers Windows 7 Professional
    Reckon Accounts Premier 2016
    The 2 computers have mapped drive letter pointing to the NAS shared folder

    Temporarily, have moved the company files to one of the PC's.
    RA2016 is now working correctly in multi-user mode

    We need the company files to reside on the NAS drive

    Basically "Reckon Database Server Manager" needs to support network shares

    Would appreciate any advice

  • Reckon FAQsReckon FAQs Reckon Staff Posts: 700 ✭✭
    edited March 2017
    Hi Steve,

    The Database Server Manager must be installed on the PC that hosts the Company File.  As a NAS does not have an installed windows operating system it needs to rely on a PC.  With NAS drives you need to think of a peer-to-peer network.

    Nominate one PC to act as the "server" that will never be switched off and install Reckon Accounts on it with the option "Reckon Accounts and Company File Server".  When you access the file for the first time it will offer you an "Alternate Setup" - accept it (RA will treat the NAS as an external hard drive to this PC).  Set to Multi-user mode.

    All other PC's should have Reckon Accounts installed with the option "Reckon Accounts Only".  They will now be able to access the company file on the NAS. via the "server" PC.  

    Hope this helps.

  • TudorTudor Member Posts: 1
    edited August 2016
    We're getting this error repeatedly while running Windows 10 Professional and only since the upgrade to Reckon Accounts 2016.  

    We run in "Alternate Setup" mode with the PC acting as server and client, the database stored on a NAS, and 4 clients connected to the "server" PC.  

    Repair doesn't work.

    We have professional customer support and have been through that process a few times.  It appears that every time Windows does an update, the only option is to completely uninstall and reinstall the software.  They don't know any more than this.  It's really frustrating!  

    Is there any way we can run HijackThis or some kind of code tracing tool to provide information on what's going wrong so it can be fixed?
  • Ana BrownAna Brown Member Posts: 1
    edited November 2016
    If you can open the file locally then it could be related to the network. I suggest to move the data file to a different folder location and re-set up the folder permission.

    Let me know if you can open the file after moving it to a different folder location.

    On a side note I would recommend you using the Quickbooks on the cloud from a good company like for a worry free accounting
  • Rob DealRob Deal Member Posts: 1
    edited October 2018

    Check the username which runs the QuickBooksDBxx service on the Database server in Services.

    Grant permissions for this user to the folders where the Reckon files are located.

    Problem Solved :)

  • Sameer HusseinSameer Hussein Member Posts: 1
    edited October 2018
    This fixed it for me
Sign In or Register to comment.