Moving Reckon Accounts to Server 2012 R2

Options
Greg Miller_7086436
Greg Miller_7086436 Member Posts: 4
edited February 2020 in Reckon Accounts (Desktop)
I am in the midst of migrating from an old SBS2003 server to a new physical server running Server 2012 R2 as a Hyper-V host and 5 VMs, each running Server 2012 R2.
We are currently using Reckon Accounts Premier 2014 and the SBS box has been acting as the Reckon DB host for about 7 years (with minimal problems).
I have created a Server 2012R2 VM to host the relevant network shares and also be the Reckon DB host. This weekend I copied all the Finance dept data over to the new server and setup the required mapped drives.
I installed just the Reckon DB server software first but couldn't get the workstations (all Windows 7 Pro) to connect. So I then tried to install the full version of Reckon Accounts on the server and that failed. There appeared to be two items of Reckon Accounts 2014 in the Programs list, so uninstalled both, restarted the server and reinstalled the full version of Reckon Accounts 2014.

I have not yet been able to open our company file on the new server; not even locally. I keep getting the following message:

Warning
An error occurred when Reckon Accounts tried to access the company file. Please try again. If the problem persists, contact Reckon Technical Support and provide them with the following error codes: (-6000,-83).

I have installed the Reckon Accounts 2014 Tax Updates and I have followed the instructions here:
http://kb.reckon.com.au/issue_view.asp?ID=404

This should not be this hard!
At this point I will have to reinstate the old drive mappings and point the users back to the old server folder and do it all again when I get the new server working...what a stupid waste of time and money!

Any help with this would be greatly appreciated.
Cheers,
Greg



Comments

  • Shane_6461899
    Shane_6461899 Reckon Staff Posts: 339 Reckon Staff
    edited February 2020
    Options

    Hi Greg,

    Sorry to here that you're having a hard time with this.  Generally speaking it's not usually this hard.  It looks like you have gone through the right KB for that error code.  But just to make sure you haven't missed anything or misunderstood anything I'll go through things from the start. 

    On the server where your company files are stored install Reckon Accounts 2014 choosing the option "Install Reckon Accounts Company File Server Only" (you don't want to waste a license on the file server unless it was a Terminal Server\File Server). 

    Once it's installed check that you have the following 2 services started and automatic - "QuickBooksDB23" and "QuickBooksDatabaseManagerService" (also named "QBCFMonitorService"). 

    Take note that the company files need to be on a local drive of that file server, for example "C:\ReckonData\2014" (not on a NAS drive, or mapped drive), and shared with the appropriate user groups. 

    Next use the Reckon Accounts Database Server Manager to scan the folder holding the company files (eg: "C:\ReckonData\2014").  At that point you should notice a .ND file now resides in that folder.  Open it in Notepad and take note of the file path, it should be the exact path you just scanned.  The ServerIP should be that of your file server.  Don't worry about the ServerPort at this point (it will probably be 10160 instead of 10177, but should change to 10177 after opening the company file).

    Next go into the properties of that folder you just scanned and add the user QBDataServiceUser23 (its a local user by the way) and give them Full Control.

    Next configure your firewall so that port 10177 is open for inbound and outbound traffic (its a TCP port).

    That is your file server setup.

    Next on your workstations or terminal server install Reckon Accounts 2014 choosing the option "Install Reckon Accounts Only".

    Map a drive to your shared folder on the file server - eg: "C:\ReckonData\2014" or even "C:\ReckonData" if using earlier versions also.

    At this point I should mention that in terminal server environments start out testing with members of the Administrators group only.  As we in tech support only support Admin users in that environment as its the only way we can get it working consistently.

    Open Reckon Accounts, make sure Hosting is NOT turned on (File > Utilities > it should say Host Multiuser Access - but if it says Stop Hosting, then stop it, otherwise leave it as we don't want hosting turned on here.)

    At this point both the file server and workstation/terminal server are configured correctly.

    Open a company file via the mapped drive making sure you're opening a .QBW file with a red icon next to it.  It should open without any errors.

    Next try to switch the file to Multiuser Mode (File > Switch to Multiuser Mode).

    At this point if you encounter an error message in the 6000 range or a H505, 202, etc something has gone wrong.  

    Start by opening the .ND file associated with that company file and check if the file path is still the same as it was when you first checked it, eg: "C:\ReckonData\2014" and has not been changed to a UNC pathCheck if the IP address is that of your file server.  If not something has caused them to change upon opening the company file. 

    Double check you have done everything exactly as described above. 

    Next rescan the folder holding the company file which will rewrite the ND file with the correct info as it first did.  

    See if mapping a new drive makes any difference, and try mapping with and without the fully qualified domain name as this has made a difference in an a previous case I dealt with.  That customer had everything setup perfect but every time they switched to multiuser mode the ND file would change causing an error.  Simply by remapping his drive without the full qualified domain name the issue was solved.

    Remember to test with users who are part of the Administrators group.

    If at this point it's still not working I would go with disabling the firewall on both file server and workstation/terminal server, and giving the "Everyone" group full control over the folder where the company files are stored, in order to rule out it being a firewall or permissions issue.

    Make sure the company file name is more than 9 characters in length (why this matters I don't know but it does).

    At this point it should be working, and I can't think of anything else to check, so if the problem persists give tech support a call for some one on one assistance, I'm not sure what more they can do, but perhaps a team leader will have some more knowledge than I do.

    Hope I have been of some help Greg.  Let me know how things go, if I think of anything else that might help I'll let you know.

    All the best, Shane.

  • Greg Miller_7086436
    Greg Miller_7086436 Member Posts: 4
    edited February 2015
    Options
    Hi Shane,
    Thanks for your detailed reply.
    I have gone through your suggestions step-by-step and ended up in the same place: still getting 6000, 83 errors.
    I am currently on-hold with Reckon Tech Support, after trying much the same stuff with them, they are now just checking that Reckon Accounts Premier 2014 is actually compatible with Windows Server 2012 R2. I have found a document that confirms this but they still want to check...
    http://www.quicken.co.nz/accounts/2014/RA%202014%20System%20Requirements.pdf
    Hopefully they will be able to resolve it in the end though.
    Cheers,
    Greg


  • Greg Miller_7086436
    Greg Miller_7086436 Member Posts: 4
    edited February 2015
    Options
    So, Reckon Tech Support have now informed me that Reckon Accounts 2014 is NOT supported on Windows Server 2012 R2. (Apparently, the NZ version is, but not the Australian version.)
    Yes. Let me repeat that....Reckon Accounts 2014 is NOT supported on Windows Server 2012 R2.

    To say the least, I am dumbfounded. However, that is not to say that it can't work...just not supported. Apparently, it is supported on Server 2012 and Reckon Accounts 2015 will be supported on Server 2012 R2 when it is released in a few months.

    Also, my network setup could be too complicated because I have been so radical as to store our Reckon company files in a folder on a drive other than the drive that I installed the Reckon software on. Don't know what I was thinking....

    So, I was recommended to make a new folder in C: drive and put the company file in there, share it, set permissions, etc. and do all the usual stuff to make it work.
    Did that. No luck..but slightly different error on the client PC (-6129, -101).

    Next step is to create another VM and install Server 2012 (which by the way is a supported platform for Reckon Accounts 2014 in Australia). I'll do that and reply with the outcome.

    Cheers,
    Greg
  • Graham Boast
    Graham Boast Accredited Partner Posts: 331 Accredited Partner Accredited Partner
    edited December 2017
    Options
    Hi Greg

    Have you set up firewall on the server correctly?  The file location shouldn't be an issue as long as the permissions are in place.

    image
    Ports 10177 is both TCP and UDP.  

    If you install the Server Only component, you won't need to install tax updates.
    Don't try to install full version - often just doesn't open on server anyway.

    Not supported really just means that R2 was released after the product was tested.  Shouldn't be an issue unless Microsoft broke something. 

    Good luck.  I have gone grey thinking things shouldn't be this hard!  

    Graham


    Graham Boast 0409317366
    Reckon Accredited Consultant
    graham@reckonhelp.com.au
    http://reckonhelp.com.au/remotesupport.htm





    Graham Boast | 0409 317366 | graham@reckonhelp.com.au